pacman (Русский)

From ArchWiki
(Redirected from Удалите)
Jump to navigation Jump to search

Состояние перевода: На этой странице представлен перевод статьи pacman. Дата последней синхронизации: 3 октября 2020. Вы можете помочь синхронизировать перевод, если в английской версии произошли изменения.

Система управления пакетами pacman — одна из отличительных особенностей Arch Linux. Она объединила в себе простую систему сборки и пакеты в двоичном формате. Цель pacman — организация удобного управления пакетами вне зависимости от того, взяты они из официальных репозиториев или же собраны самостоятельно.

pacman поддерживает систему в актуальном состоянии, синхронизируя пакеты с сервером. Эта клиент-серверная модель позволяет пользователю скачивать/устанавливать пакеты с необходимыми зависимостями всего одной командой.

pacman написан на языке Си и работает с tar-пакетами в формате bsdtar(1).

Совет: Официальный пакет pacman также содержит такие утилиты, как makepkg и vercmp(8). В пакет pacman-contrib вошли другие полезные программы, например, pactree и checkupdates, которые раньше были частью pacman. Команда pacman -Ql pacman pacman-contrib | grep -E 'bin/.+' выведет полный список доступных утилит.

Contents

Использование

В этом разделе приведена небольшая подборка доступных возможностей pacman. Больше примеров можно найти в руководстве pacman(8).

Совет: Если раньше вы использовали другой дистрибутив Linux, то будет полезно ознакомиться со статьёй pacman/Rosetta.

Установка пакетов

Пакет представляет собой архив, в котором содержатся:

  • все (скомпилированные) файлы приложения;
  • метаданные о приложении (имя приложения, версия, зависимости и т.д.);
  • установочные файлы и указания pacman;
  • (необязательно) дополнительные файлы для облегчения жизни, например — сценарии запуска/остановки.

Pacman, менеджер пакетов Arch Linux, может устанавливать, обновлять и удалять пакеты. Использование pacman имеет ряд преимуществ по сравнению с альтернативным подходом — ручной компиляцией и установкой программ:

  • удобное обновление: pacman будет устанавливать обновления по мере их появления;
  • проверка зависимостей: pacman самостоятельно отслеживает зависимости, вам нужно только указать целевую программу, и pacman установит её вместе с неоходимыми дополнительными пакетами.
  • чистое удаление: pacman хранит список файлов всех пакетов. При удалении пакета в системе не остаётся лишнего "мусора".
Примечание:
  • Часто у пакетов есть опциональные зависимости, которые не являются обязательными, но предоставляют дополнительную функциональность. Во время установки pacman выведет список опциональных зависимостей, но в файле pacman.log упоминаний о них не будет. Чтобы получить информацию об опциональных зависимостях пакета, используйте #Запросы к базам данных пакетов.
  • При установке пакета, который нужен только в качестве зависимости для другого пакета, в том числе опциональной, и который не будет использоваться напрямую, рекомендуется использовать параметр --asdeps. Подробнее смотрите раздел #Причина установки.
Важно: При установке пакетов старайтесь не синхронизировать базу данных пакетов без последующего обновления системы (например, на случай, если пакета уже нет в официальных репозиториях). В частности, не используйте команду pacman -Sy название_пакета вместо pacman -Syu название_пакета, потому что это может привести к проблемам с зависимостями. Подробнее смотрите статью System maintenance#Частичные обновления не поддерживаются и ветку форума BBS#89328.

Установка отдельных пакетов

Для установки одного пакета или списка пакетов (включая зависимости) используйте следующую команду:

# pacman -S название_пакета1 название_пакета2 ...

Для установки списка пакетов при помощи поиска по регулярному выражению (смотрите эту ветку форума) выполните:

# pacman -S $(pacman -Ssq регулярное_выражение)

Если пакет имеет несколько версий в разных репозиториях (например, в extra и testing), можно указать, откуда именно следует установить пакет:

# pacman -S extra/имя_пакета

Чтобы установить несколько пакетов с частично совпадающими названиями, используйте фигурные скобки:

# pacman -S plasma-{desktop,mediacenter,nm}

Можно использовать несколько уровней вложенных фигурных скобок:

# pacman -S plasma-{workspace{,-wallpapers},pa}
Виртуальные пакеты

Виртуальным называется такой пакет, который сам по себе не существует, но предоставляется другими пакетами. "Виртуальность" позволяет другим пакетам не называть конкретный пакет зависимостью, если есть возможность выбора из нескольких кандидатов. Виртуальный пакет нельзя установить по имени, он добавляется в систему только при установке "предоставляющего" пакета.

Установка группы пакетов

Некоторые пакеты объединены в группы и могут устанавливаться одной командой. Например, после команды

# pacman -S gnome

вам будет предложено выбрать пакеты из группы gnome, которые вы хотели бы установить.

Некоторые группы содержат большое количество пакетов, и среди них могут быть всего несколько нужных или ненужных вам. Вместо того, чтобы вводить все необходимые вам номера, иногда удобнее выбрать или исключить отдельные числа или диапазоны чисел при помощи приведенного ниже синтаксиса:

Enter a selection (default=all): 1-10 15

— будут выбраны все пакеты в диапазоне с 1 по 10, а также 15;

Enter a selection (default=all): ^5-8 ^2

— будут выбраны все пакеты, кроме входящих в диапазон с 5 по 8, а также 2.

Чтобы увидеть список пакетов, принадлежащих к группе gnome, выполните:

# pacman -Sg gnome

Перечень групп можно найти на странице https://www.archlinux.org/groups/.

Примечание: Установлены будут все пакеты из списка, в том числе и те, которые уже были установлены в систему ранее — даже если они последней версии и не нуждаются в обновлении. Чтобы не устанавливать такие пакеты заново, укажите параметр --needed.

Удаление пакетов

Удалить пакет, не удаляя его зависимости:

# pacman -R название_пакета

Удалить пакет и те его зависимости, которые не нужны никаким другим пакетам:

# pacman -Rs название_пакета

Команда выше может не сработать при удалении группы с другими необходимыми пакетами. В этом случае используйте команду:

# pacman -Rsu название_пакета

Удалить пакет, его зависимости, а также все пакеты, для которых он сам является зависимостью:

Важно: Эта операция рекурсивна. Используйте её с осторожностью — есть риск удалить нужные пакеты.
# pacman -Rsc название_пакета

Удалить пакет, который требуется другому пакету, без удаления зависимостей:

Важно: Этой операции следует избегать, так как она может нанести тяжелый вред системе. Подробнее смотрите статью System maintenance#Избегайте определенных команд pacman.
# pacman -Rdd название_пакета

pacman создает резервные копии конфигурационных файлов удаляемых приложений и добавляет к ним расширение .pacsave. Если вы хотите удалить и эти файлы, используйте ключ -n:

# pacman -Rn название_пакета
Примечание: pacman не удаляет файлы настроек, которые созданы самими приложениями — например, скрытые файлы (имя которых начинается с точки) в домашнем каталоге).

Обновление пакетов

Важно:

pacman полностью обновляет систему всего одной командой. Если система давно не обновлялась, процесс может занять довольно длительное время. Приведённая ниже команда одновременно синхронизирует базы данных репозиториев и выполняет обновление системы — при этом пакеты, которых нет в подключённых репозиториях, обновлены не будут:

# pacman -Syu

Запросы к базам данных пакетов

Для взаимодействия с базами данных в pacman предусмотрены флаги -Q (база данных пакетов), -S (база данных синхронизации) и -F (база данных файлов). Команды pacman -Q --help, pacman -S --help и pacman -F --help выведут список возможных опций для этих флагов.

pacman может выполнять поиск в базе данных как среди названий пакетов, так и по их описаниям:

$ pacman -Ss условие1 условие2 ...

Иногда поиск с параметром -s выдаёт много ненужных результатов, поэтому имеет смысл ограничить поиск только названиями пакетов, отключив поиск по описаниям и другим полям. Для этого можно использовать регулярные выражения:

$ pacman -Ss '^vim-'

Искать среди установленных пакетов:

$ pacman -Qs условие1 условие2 ...

Искать пакет в репозиториях по названию файла:

$ pacman -F условие1 условие2 ...

Показать подробную информацию о пакете в репозитории:

$ pacman -Si название_пакета

То же самое — для установленного пакета:

$ pacman -Qi название_пакета

Если указать сразу два флага -i, то будет также выведен список резервных копий файлов и их состояние (модифицирован/нет):

$ pacman -Qii название_пакета

Вывести список файлов установленного пакета:

$ pacman -Ql название_пакета

Вывести список файлов пакета в репозитории:

$ pacman -Fl название_пакета

Проверить наличие файлов установленного пакета:

$ pacman -Qk название_пакета

С двумя флагами -k проверка будет более тщательной.

Узнать, какому пакету принадлежит файл:

$ pacman -Qo /путь/к/файлу/имя_файла

Узнать, какому пакету в репозиториях принадлежит файл:

$ pacman -F /путь/к/файлу/имя_файла

Вывести список пакетов, которые больше не требуются как зависимости ("пакеты-сироты"):

$ pacman -Qdt
Совет: Последнюю команду имеет смысл сделать пост-транзакционным хуком pacman, чтобы получить уведомление, если какое-то действие привело к появлению пакета-сироты. Это может быть полезно, например, если пакет был удалён из репозитория, вследствие чего на локальной системе он будет считаться сиротой (кроме случая, когда пакет был установлен явно). Чтобы не получать ошибку "failed to execute command" в случае отсутствия пакетов-сирот, укажите следующую команду в параметре Exec в описании хука: /usr/bin/bash -c "/usr/bin/pacman -Qtd || /usr/bin/echo '=> None found.'"

Вывести список пакетов, установленных явно (explicitly) и не являющихся зависимостями для других пакетов:

$ pacman -Qet

Другие полезные команды можно найти в статье pacman/Советы и приёмы.

Pactree

Примечание: pactree(8) больше не является частью пакета pacman. Теперь он входит в состав pacman-contrib.

Дерево зависимостей пакета можно узнать командой

$ pactree название_пакета

Чтобы увидеть "обратное" дерево зависимостей, т.е. список пакетов, которые сами зависят от указанного, используйте флаг pactree -r или утилиту whoneeds из пакета pkgtoolsAUR.

Структура базы данных

Базы данных pacman обычно размещаются в каталоге /var/lib/pacman/sync. Для каждого подключённого в файле /etc/pacman.conf репозитория в этом каталоге находится соответствующий файл базы данных. Сам файл представляет собой gzip-сжатый tar-архив (с расширением .db), содержащий по одному каталогу для каждого пакета. Например, для пакета which содержимое каталога имеет вид:

$ tree which-2.21-5
which-2.21-5
|-- desc

В файле desc хранятся мета-данные пакета — описание, список зависимостей, размер, хэш-сумма MD5 и т.д.

Очистка кэша пакетов

Скачиваемые пакеты pacman сохраняет в каталог (/var/cache/pacman/pkg/). Устаревшие версии пакетов, как и версии пакетов удалённых, автоматически не удаляются. Такой подход обладает следующими преимуществами:

  1. Можно выполнить откат пакета без необходимости искать где-то (например, в архиве Arch Linux) его старую версию;
  2. Удалённый по ошибке пакет можно заново установить из кэша, не скачивая из репозитория.

Тем не менее, это означает, что время от времени необходимо чистить этот каталог самостоятельно, чтобы предотвратить его разрастание.

Скрипт paccache(8) из пакета pacman-contrib удаляет из кэша старые версии пакетов, как установленных в системе, так и уже удалённых, по умолчанию оставляя только 3 самые свежие:

# paccache -r

Включите и запустите paccache.timer, чтобы очистка кэша выполнялась каждую неделю автоматически.

Совет: Также можно создать хук, чтобы очистка запускалась после каждого действия pacman. Подробнее смотрите примеры на форуме и пакет pacman-cleanup-hookAUR.

При необходимости можно задать количество последних версий, которые нужно оставить. Команда для удаления всех версий, кроме последней:

# paccache -rk1

Флаг -u/--uninstalled позволяет ограничить действие paccache только версиями пакетов, которых в системе уже нет. Например, команда удаления всех кэшированных версий удалённых пакетов:

# paccache -ruk0

В одной команде можно комбинировать указания как для установленных, так и для уже удалённых пакетов. Например, чтобы удалить все кэшированные копии удалённых пакетов, но оставить две последние для пакетов, которые всё ещё установлены, выполните:

# paccache -rk2 -ruk0

Список возможных опций выводится командой paccache -h.

В pacman есть встроеный функционал очистки кэша и удаления баз данных репозиториев, которые были заблокированы в файле /etc/pacman.conf. Однако pacman гораздо менее гибок по сравнению с paccache и не даёт возможности сохранить некоторое количество последних версий, просто очищая каталог кэша.

Чтобы удалить все кэшированные версии удалённых пакетов и неиспользуемые базы данных, выполните:

# pacman -Sc

Чтобы удалить вообще все файлы из кэша, укажите флаг очистки дважды:

# pacman -Scc
Важно: Следует избегать полной очистки кэша, кроме случая, когда вам очень нужно освободить дисковое пространство. Очистка сделает невозможным откат пакетов или их переустановку без повторного скачивания.

pkgcachecleanAUR и pacleanerAUR — две альтернативные программы для очистки кэша.

Дополнительные команды

Скачать пакет без установки:

# pacman -Sw название_пакета

Установить пакет не из удалённого репозитория, а хранящийся локально (например, предварительно скачанный из AUR):

# pacman -U /путь/к/пакету/имя_пакета-версия.pkg.tar.xz

Сохранить копию локально устанавливаемого пакета в кэше pacman:

# pacman -U file:///путь/к/пакету/имя_пакета-версия.pkg.tar.xz

Скачать и установить пакет из удаленного источника (но и не из репозиториев, перечисленных в конфигурационном файле pacman):

# pacman -U http://www.example.com/repo/example.pkg.tar.xz

Флаг -p можно использовать для подавления стандартных действий -S, -U и -R.

Pacman всегда выводит список пакетов, которые будут установлены или удалены, и спрашивает разрешение пользователя перед выполнением действия.

Причина установки

Для pacman с точки зрения причины установки пакет относится к одной из двух категорий:

  • установлен явно (explicitly-installed): установлен пользователем командами pacman -S или pacman -U;
  • зависимость (dependency): установлен автоматически в процессе установки другого пакета, поскольку являлся его зависимостью.

При явной установке пакета можно принудительно изменить причину установки на зависимость:

# pacman -S --asdeps название_пакета
Совет: При установке опциональных зависимостей вручную стоит всегда указывать флаг --asdeps. Тогда при удалении пакетов-сирот ненужные опциональные зависимости тоже будут удаляться.

При переустановке пакета текущая причина установки не меняется.

Список явно установленных пакетов выводится командой pacman -Qe, а пакетов-зависимостей — командой pacman -Qd.

Чтобы изменить причину установки уже установленного пакета, выполните:

# pacman -D --asdeps название_пакета

Для противоположной операции используйте флаг --asexplicit.

Примечание: Не стоить использовать опции --asdeps и --asexplicit в команде обновления системы, например pacman -Syu название_пакета --asdeps. Это изменит причину установки не только для устанавливаемого пакета, но и для всех обновляемых.

Поиск пакета по названию файла

Синхронизировать базу данных файлов:

# pacman -Fy

Найти пакет, содержащий определённый файл (например, файл pacman):

$ pacman -Fs pacman
core/pacman 5.0.1-4
    usr/bin/pacman
    usr/share/bash-completion/completions/pacman
extra/xscreensaver 5.36-1
    usr/lib/xscreensaver/pacman
Совет: Вы можете назначить задачу в Cron или таймер systemd для регулярной синхронизации баз данных.

Утилита pkgfile также осуществляет поиск пакетов по файлам, опираясь на свою базу данных; она обладает расширенной функциональностью по сравнению с pacman -F.

Настройка

Настройки pacman находятся в файле /etc/pacman.conf. Подробную информацию о файле настроек можно найти в руководстве pacman.conf(5).

Глобальные параметры

Глобальные настройки pacman указываются в разделе [options]. Помимо руководства pacman.conf(5) некоторая информация о настройках из этого раздела содержится в комментариях самого файла pacman.conf.

Сравнение версий пакетов перед обновлением

Чтобы увидеть сравнение старых и новых версий доступных для обновления пакетов, раскомментируйте строку VerbosePkgLists в файле pacman.conf. Теперь команда pacman -Syu будет выводить примерно следующее:

Package (6)             Old Version  New Version  Net Change  Download Size

extra/libmariadbclient  10.1.9-4     10.1.10-1      0.03 MiB       4.35 MiB
extra/libpng            1.6.19-1     1.6.20-1       0.00 MiB       0.23 MiB
extra/mariadb           10.1.9-4     10.1.10-1      0.26 MiB      13.80 MiB

Запрет на обновление отдельных пакетов

Важно: Будьте осторожны при использовании этой настройки, потому что частичные обновления не поддерживаются.

Чтобы пропустить пакет во время обновления системы добавьте его название в параметр IgnorePkg:

IgnorePkg=linux

Если необходимо пропустить обновление для нескольких пакетов, укажите названия, разделив их пробелами, или используйте несколько строк IgnorePkg. Также можно использовать шаблоны поиска. Если нужно пропустить обновление пакета всего один раз, то лучше использовать опцию командной строки --ignore — здесь в качестве разделителя для названий пакетов используется запятая.

При необходимости обновить пакет из списка исключений всё же можно, командой pacman -S название_пакета: pacman при этом выведет напоминание, что пакет указан в IgnorePkg.

Запрет на обновление группы пакетов

Важно: Будьте осторожны при использовании этой настройки, потому что частичные обновления не поддерживаются.

Аналогично запрету на обновление отдельного пакета, можно запретить обновление сразу для целой группы, например:

IgnoreGroup=gnome

Запрет на обновление файлов

Файлы, указанные в параметре NoUpgrade, не будут изменяться в процессе установки/обновления; новые версии этих файлов будут сохраняться с расширением .pacnew.

NoUpgrade=путь/к/файлу
Примечание: Путь к файлу соответствует названию файла в tar-архиве пакета. Следовательно, указывать ведущий слэш не нужно.

Запрет на установку файлов

Чтобы запретить установку файлов в определённые каталоги, перечислите их в параметре NoExtract. Например, запрет установки юнитов systemd:

NoExtract=usr/lib/systemd/system/*
Совет: Pacman выводит предупреждение о недостающих файлах локализаций при обновлении пакетов, локали которых были удалены утилитами вроде localepurge или bleachbit. Чтобы отключить эти сообщения, закомментируйте параметр CheckSpace в файле pacman.conf, но имейте в виду, что это отключит функционал проверки наличия свободного места для всех пакетов.

Работа с несколькими файлами настроек

Если имеется несколько конфигурационных файлов (например, основная конфигурация и дополнительная с подключённым репозиторием testing), то работу с ними можно упростить, если вынести общие пункты настроек в отдельный файл и подключать его с помощью опции Include:

Include = /путь/к/файлу/общих/настроек

В этом примере общие настройки вынесены в файл /путь/к/файлу/общих/настроек. Приведённую выше строку нужно добавить в оба файла настроек, основной и дополнительный.

Хуки

Системные пре- и пост-транзакционные хуки хранятся в каталоге /usr/share/libalpm/hooks; pacman может выполнять хуки как из системного каталога, так и из каталогов, подключённых опцией — HookDir в файле pacman.conf (каталог по умолчанию — /etc/pacman.d/hooks). Название файла хука должно заканчиваться на .hook. Хуки pacman неинтерактивны.

В частности, хуки pacman используются в связке с systemd-sysusers и systemd-tmpfiles для автоматического создания пользователей и файлов в процессе установки пакетов. Например, пакет tomcat8 требует наличия пользователя tomcat8 и определённых каталогов, ему принадлежащих. Хуки systemd-sysusers.hook и systemd-tmpfiles.hook вызывают команды systemd-sysusers и systemd-tmpfiles соответственно, когда pacman видит в пакете указания на пользователей и временные файлы.

Хуки alpm подробно описаны в руководстве alpm-hooks(5).

Репозитории и зеркала

Помимо общего раздела [options] в файле pacman.conf также содержатся отдельные разделы для каждого из репозиториев. Репозиторий — набор пакетов, который физически находится на одном или нескольких серверах; эти сервера называются зеркалами репозитория.

Репозитории делятся на официальные и неофициальные. Порядок репозиториев в файле настроек имеет значение: если в разных репозиториях содержатся пакеты с одинаковым названием, то вне зависимости от их версий предпочтение отдаётся тому пакету, репозиторий которого ближе к началу файла. Чтобы подключённый репозиторий можно было использовать, сначала необходимо выполнить полное обновление системы.

Разделы репозиториев в файле pacman.conf содержат информацию о зеркалах. Список зеркал хранится в отдельном файле и подключается параметром Include. Например, зеркала официальных репозиториев подключаются из файла /etc/pacman.d/mirrorlist. Настройка зеркал описана в статье Mirrors.

Безопасность пакетов

Pacman использует цифровые подписи в качестве дополнительного механизма обеспечения безопасности пакетов. Настройки проверки подписей задаются параметром SigLevel. По умолчанию в разделе [options] задано глобальное значение SigLevel = Required DatabaseOptional, что означает проверку подписей всех пакетов без исключения. Можно задать особые правила проверки подписей для отдельных репозиториев, указав параметр SigLevel в соответствующих разделах. Подробнее см. pacman/Package signing.

Решение проблем

Failed to commit transaction (conflicting files)

Следующее сообщение об ошибке [1]:

error: could not prepare transaction
error: failed to commit transaction (conflicting files)
пакет: /путь/к/файлу exists in filesystem
Errors occurred, no packages were upgraded.

означает, что при выполнении операции были обнаружены конфликтующие файлы. Pacman не будет их перезаписывать автоматически. Это не ошибка, так сделано специально.

Проблема решается тривиально. Сначала проверьте, не принадлежит ли файл другому пакету (pacman -Qo /путь/к/файлу). Если принадлежит, создайте отчет об ошибке. Если проблемный файл не нужен другим пакетам, переименуйте его и перезапустите команду обновления. Если в дальнейшем проблем не возникнет, то старый файл можно удалить.

Если программа была установлена вручную без pacman — например, при помощи команды make install — необходимо удалить программу и все её файлы, а затем выполнить установку при помощи pacman. См. также pacman/Советы и приёмы#Поиск файлов без пакета-владельца.

Информация о каждом установленном файле хранится в файле с метаданными пакета /var/lib/pacman/local/пакет-версия/files. При повреждении этого файла (он может быть пустым или отсутствовать) во время обновления пакета будет получена ошибка file exists in filesystem ("файл существует в файловой системе"). Обычно такие ошибки возникают во время установки или обновления всего лишь одного пакета. Вместо ручного переименования или удаления конфликтующих файлов, принадлежащих данному пакету, лучше выполнить команду pacman -S --overwrite шаблон пакет, чтобы pacman принудительно перезаписал файлы, название которых совпадает с шаблоном.

Важно: Будьте осторожны при использовании ключа --overwrite. См. Обслуживание системы#Избегайте определенных команд pacman.

Failed to commit transaction (invalid or corrupted package)

Удалите все файлы .part (частично скачанные пакеты) из кэша pacman /var/cache/pacman/pkg/. Причиной ошибки чаще всего является пользовательская команда в параметре XferCommand файла pacman.conf.

# find /var/cache/pacman/pkg/ -iname "*.part" -delete

Failed to init transaction (unable to lock database)

Когда pacman собирается внести изменения в базу данных пакетов, например, при установке пакета, он создает файл блокировки /var/lib/pacman/db.lck. Благодаря этому другой экземпляр pacman не сможет работать в то же самое время, что позволяет избежать повреждения базы.

Если работа pacman была прервана во время внесения изменений в базу, этот файл блокировки может остаться не удаленным. Если вы уверены, что на вашей машине не запущено других экземпляров pacman, удалите этот файл блокировки:

# rm /var/lib/pacman/db.lck

Не удаётся найти пакет для установки

Эта ошибка проявляется в сообщениях Not found in sync db, Target not found или Failed retrieving file.

Удостоверьтесь, что пакет, который вы пытаетесь установить, действительно существует. Если это так, возможно, список хранящихся в репозиториях пакетов устарел. Выполните pacman -Syu, чтобы получить новый список и обновить систему. Также убедитесь, что выбранные зеркала в рабочем состоянии, а репозитории настроены правильно.

Также есть вероятность того, что в вашей системе не включен репозиторий, содержащий нужный пакет — например, пакет находится в репозитории multilib, но multilib не включен в файле pacman.conf.

См. также FAQ#Почему в репозиториях есть только одна версия каждой библиотеки?

Pacman падает при обновлении

Если при удалении пакетов pacman завершает свою работу с ошибкой "database write" ("запись в базу данных"), и после этого все попытки переустановки или обновления пакетов завершаются неудачей, сделайте следующее:

  1. Загрузитесь, используя Arch Live USB. Желательно, чтобы версия pacman в образе была не старше той, что установлена в системе.
  2. Смонтируйте корневую файловую систему, например, командой mount /dev/sdaX /mnt от root, и убедитесь, что в точке монтирования достаточно свободного места (команда df -h).
  3. Смонтируйте файловые системы proc, sys и dev: mount -t proc proc /mnt/proc; mount --rbind /sys /mnt/sys; mount --rbind /dev /mnt/dev
  4. Если в системе используются стандартное расположение баз данных и каталогов, то можно синхронизировать базу данных pacman и обновить систему командой pacman --sysroot /mnt -Syu от root.
  5. После обновления стоит убедиться, что в системе не осталось необновлённых нерабочих пакетов: find /mnt/usr/lib -size 0.
  6. Если такие пакеты всё же есть, их нужно переустановить: pacman --sysroot /mnt -S package.

Переустановка pacman вручную

Важно: Есть большая вероятность, что следуя рекомендациям ниже вы добьёте свою систему. Используйте их как последнее средство, если советы из раздела #Pacman падает при обновлении не помогли или нереализуемы.

Даже если pacman не подаёт признаков жизни, всё ещё можно починить его вручную, загрузив последние версии пакетов и распаковав файлы в нужные места. Последовательность действий:

  1. Узнайте зависимости пакета pacman.
  2. Скачайте пакеты с любого рабочего зеркала.
  3. Извлеките каждый пакет в корневой каталог.
  4. Переустановите эти пакеты командами pacman -S --overwrite название_пакета, чтобы обновить базу данных.
  5. Выполните полное обновление системы.

Если у вас имеется доступ к другой работоспособной системе с Arch Linux, полный список зависимостей можно узнать командой

$ pacman -Q $(pactree -u pacman)

Возможно, вам необходимо обновить только несколько пакетов, в зависимости от серьёзности проблемы. Пример команды распаковки архива пакета:

# tar -xvpwf пакет.tar.xz -C / --exclude .PKGINFO --exclude .INSTALL --exclude .MTREE --exclude .BUILDINFO

Обратите внимание на флаг -w, который включает интерактивный режим. Запускать распаковку неинтерактивно рискованно, потому что можно перезаписать важный файл. Также не забудьте, что пакеты нужно распаковывать в правильном порядке (сначала зависимости). На форуме рассмотрен пример процесса восстановления работоспособности pacman c несколькими неработающими пакетами-зависимостями.

Ошибка "Unable to find root device" после перезагрузки

Вероятно, при обновлении ядра был повреждён образ initramfs (например, при использовании pacman с опцией --overwrite). Для восстановления работоспособности есть два варианта, и первый из них — использовать fallback-образ.

Совет: Если вы удалили этот образ по каким-либо причинам, вы можете нажать клавишу Tab (при использовании Syslinux) или e (при использовании GRUB или systemd-boot), когда на экране появится меню загрузчика, переименовать образ в initramfs-linux-fallback.img и нажать Enter или b (в зависимости от используемого загрузчика), чтобы выполнить загрузку с новыми параметрами.

Когда система запустится, выполните команду пересборки образа initramfs либо из консоли, либо из терминала (для стандартного ядра linux):

# mkinitcpio -p linux

Если этот способ не сработает, загрузитесь с Live-USB, смонтируйте корневой и загрузочный разделы, после чего сделайте chroot командой arch-chroot:

# arch-chroot /mnt
# pacman -Syu mkinitcpio systemd linux
Примечание:
  • Если у вас нет текущего релиза, или есть только какой-либо другой "live"-дистрибутив Linux, вы можете выполнить chroot, используя старый способ. Очевидно, при этом вам придется напечатать больше, чем просто arch-chroot для запуска соответствующего скрипта.
  • Если pacman выдает ошибку Could not resolve host, пожалуйста, проверьте ваше интернет-соединение.
  • Если вы не можете войти в окружение arch-chroot или chroot, но нуждаетесь в переустановке пакетов, можете использовать команду pacman --sysroot /mnt -Syu foo bar, чтобы указать pacman ваш корневой раздел.

Переустановка ядра (пакета linux) автоматически пересоздаст образ initramfs при помощи mkinitcpio -p linux. Нет необходимости дополнительно вводить эту команду.

После всего этого рекомендуется выполнить exit, umount /mnt/{boot,} и reboot.

Signature from "User <email@example.org>" is unknown trust, installation failed

Возможные решения:

  • Обновите существующие ключи командой pacman-key --refresh-keys.
  • Вручную обновите пакет archlinux-keyring командой pacman -Sy archlinux-keyring && pacman -Su.
  • Выполните полный сброс ключей.

Требование импортировать ключи PGP

При установке Arch Linux со старого ISO-образа скорее всего вы получите сообщение о необходимости выполнить импорт PGP-ключей — подтвердите загрузку. Если добавить ключи всё же не получится, синхронизируйте связку ключей или обновите пакет archlinux-keyring (см. выше).

Error: key "0123456789ABCDEF" could not be looked up remotely

Если пакеты подписаны свежими ключами, которые были добавлены к archlinux-keyring совсем недавно, это ключи могут оказаться недоступны в процессе обновления системы (проблема курицы и яйца). Установленный пакет archlinux-keyring должен обновиться, чтобы получить новые ключи. Pacman попытается обойти эту проблему обращением к серверу ключей, но это может оказаться невыполнимо из-за работы прокси или межсетевого экрана и приведёт к ошибке. Обновите пакет archlinux-keyring как описано выше.

Signature from "User <email@archlinux.org>" is invalid, installation failed

Такая ошибка может появиться, если системное время установлено неверно и подписи ключей кажутся устаревшими:

error: пакет: signature from "User <email@archlinux.org>" is invalid
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occured, no packages were upgraded.

Задайте правильное время (например, командой # ntpd -qg) и выполните # hwclock -w, после чего установите нужные пакеты или обновите систему.

Warning: current locale is invalid; using default "C" locale

Как сказано в сообщении ошибки, локаль системы настроена неправильно (см. Locale).

Pacman игнорирует настройки прокси

Удостоверьтесь, что соответствующие переменные окружения ($http_proxy, $ftp_proxy и т.д.) заданы верно. Если вы используете pacman вместе с sudo, необходимо настроить sudo на передачу переменных окружения в pacman. Также убедитесь, что настройки dirmngr в файле /etc/pacman.d/gnupg/dirmngr.conf содержат параметр honor-http-proxy, отвечающий за использование прокси при обновлении ключей.

Как переустановить все пакеты, сохранив информацию о том, какие из них установлены явно, а какие — в качестве зависимостей?

Чтобы переустановить все пакеты из официальных репозиториев, выполните pacman -S $(pacman -Qnq) (опция -S сохраняет причину установки по умолчанию).

После этого необходимо переустановить все пакеты из неизвестных источников, список которых можно получить командой pacman -Qmq.

Cannot open shared object file

Скорее всего, это означает, что при выполнении предыдущей операции pacman удалил или повредил разделяемые библиотеки, необходимые для него самого.

Чтобы выйти из этой ситуации, нужно вручную распаковать необходимые библиотеки в вашу файловую систему. Сперва определите, в каком пакете содержится требуемая библиотека, а затем найдите этот пакет в кэше pacman (/var/cache/pacman/pkg/). Распакуйте разделяемую библиотеку в файловую систему. Это позволит вам запустить pacman.

Теперь необходимо переустановить испорченный пакет. При этом обязательно используйте ключ --overwrite, поскольку вы лишь распаковали системные файлы, но pacman об этом не знает. pacman корректно заменит ваш файл разделяемой библиотеки на тот, что имеется в пакете.

Вот и все. Обновите оставшуюся часть системы.

Проблемы с загрузкой пакетов

Были сообщения о некоторых сетевых проблемах, которые приводят к невозможности обновления/синхронизации: [2], [3]. При обычной установке Arch Linux эти проблемы не появляются, так как стандартный загрузчик файлов при этом заменяется другим (см. pacman/Советы и приёмы#Производительность). При установке Arch Linux в VirtualBox эта проблема также появляется, когда вы используете опцию виртуальной машины Host interface вместо NAT.

Failed retrieving file 'core.db' from mirror

Если зеркала настроены правильно, но вы получаете такое сообщение об ошибке, попробуйте выбрать другой сервер имён.

'local-package.pkg.tar': permission denied

Если вы пытались установить пакет в смонтированной файловой системе sshfs с помощью команды pacman -U и получили такую ошибку, переместите пакет в локальный каталог и попробуйте ещё раз.

Пояснения

Процесс установки/обновления/удаления пакета

Tango-inaccurate.pngThe factual accuracy of this article or section is disputed.Tango-inaccurate.png

Reason: В соответствии с обсуждением на форуме, возможно, информация неполна/неточна. Переместить в раздел #Решение проблем или даже в #Установка пакетов? (Discuss in Talk:Pacman (Русский)#)

При выполнении операций с пакетами посредством pacman происходит следующее:

  1. pacman получает список пакетов для установки.
  2. pacman выполняет различные проверки на предмет возможности установки пакетов в систему.
  3. Если возможно применить какие-то из существующих пре-транзакционных хуков pacman, то они выполняются.
  4. Пакеты по очереди устанавливаются/обновляются/удаляются.
    1. Если у пакета есть скрипт установки, выполняется функция pre_install (или pre_upgrade/pre_remove в случае обновления или удаления пакета).
    2. pacman удаляет из системы все файлы старой версии пакета (в случае его обновления или удаления). Файлы настроек не удаляются (см. Pacman/Pacnew and Pacsave).
    3. pacman извлекает файлы из архива пакета и размещает их в системе (при установке или обновлении). Файлы, которые остались с прошлой установки, перезаписываются/модифицируются, а новые файлы настроек сохраняются рядом со старыми (см. предыдущий шаг) с добавлением к названию суффикса .pacnew.
    4. Если у пакета есть скрипт установки, выполняется функция post_install (post_upgrade или post_remove при обновлении/удалении).
  5. Если возможно применить какие-то из существующих пост-транзакционных хуков pacman, то они выполняются.

Смотрите также