Flyspray

From ArchWiki
Jump to: navigation, search

Flyspray is a bug tracking system written in PHP.

Installation

Install the flyspray package. Flyspray requires a web server such as Apache HTTP Server with PHP, and an SQL server such as MySQL or PostgreSQL.

Apache Setup

Note: You will need to have Apache configured to run with PHP. Check Apache#PHP for instructions. Make sure to uncomment extension=mysqli in /etc/php/php.ini.

You will need to create a config file for apache to find your Flyspray install. Create the following file:

/etc/httpd/conf/extra/flyspray.conf
Alias /flyspray "/usr/share/webapps/flyspray"
<Directory "/usr/share/webapps/flyspray">
	AllowOverride All
	Options FollowSymlinks
	Require all granted
	php_admin_value open_basedir "/srv/http/:/tmp/:/usr/share/webapps/flyspray"
</Directory>

You will then need to edit /etc/webapps/flyspray/.htaccess and change deny from all to allow from all. You should now be able to navigate to the flyspray interface (e.g. http://localhost/flyspray) and it will show a page of pre-installation checks. Any issues here should be resolved before continuing.