Google Earth

From ArchWiki
Jump to: navigation, search

From the project web page:

"Google Earth allows you to travel the world through a virtual globe and view satellite imagery, maps, terrain, 3D buildings, and much more. With Google Earth's rich, geographical content, you are able to experience a more realistic view of the world. You can fly to your favorite place, search for businesses and even navigate through directions."

Installation

If on 64-bit, enable multilib. Google Earth is available in the AUR:

Troubleshooting

Tip: See the official support forum for topics not covered here.

Crash on startup

Google Earth can crash on startup for numerous reasons. Here are some of the most common ones.

Startup tips are enabled

While startup tips can be useful, they are also known to cause crashes. To disable them, add to ~/.config/Google/GoogleEarthPlus.conf:

[General]
enableTips=false

No new line at the end of ~/.drirc

This can cause a crash with -dri drivers:

$ echo >> ~/.drirc

Corrupt settings

In case the cache is corrupt and needs recreation, remove it:

$ rm -r ~/.googleearth/Cache/

If that didn't work, try removing the whole settings folder:

$ rm -r ~/.googleearth/

Another crash happened while handling crash!

You may try removing the following:

$ rm -f ~/.googleearth/Cache/cookies ~/.googleearth/instance-running-lock

Panoramio photos not working

There have been numerous reports [1] [2] [3] on this in the Google Earth forums with varying solutions.

If setting the _attempt_fix variable on top of the google-earthAUR PKGBUILD does not help, fall back to google-earth6AUR.

Graphical corruption

Either refer to the #Corrupt cache section above or disable texture compression in Tools > Options... > 3D View > Compress.

Earth shows nothing but yellow borders

Taken from the changelog of 7.0.3 this issue has improved to some extent but overall it's still there:

Imagery now displays for Linux users running specific families of Intel GPUs.

The solution is to use the legacy google-earth6AUR.

Excessive memory use

Memory use can be controlled by limiting the maximum cache size in Tools > Options... > Cache, or by lowering the graphics settings in the 3D View tab.