LibreOffice

From ArchWiki
(Redirected from Libreoffice)
Jump to: navigation, search

Related articles

From Home - LibreOffice:

LibreOffice is the free power-packed Open Source personal productivity suite for Windows, Macintosh and Linux, that gives you six feature-rich applications for all your document production and data processing needs: Writer, Calc, Impress, Draw, Math and Base.

Installation

Install one of the following packages from the official repositories:

Note:

Check the optional dependencies pacman displays. If you want to use LibreOffice Base, you must install a Java Runtime Environment: see Java. You may need hsqldb2-javaAUR to use some modules in LibreOffice Base.

Theme

Tango-view-refresh-red.pngThis article or section is out of date.Tango-view-refresh-red.png

Reason: With version 5.0, GTK3 is the default, it isn't completely working however. (Discuss in Talk:LibreOffice#)

LibreOffice includes support for GTK+ and Qt theme integration. See also Uniform look for Qt and GTK applications.

As of LibreOffice v3.5.x toolkit libraries are checked in the following order:

gtk3 > gtk > kde4 > generic

To force the use of a certain VCL UI interface, use one of the SAL_USE_VCLPLUGIN=gen, SAL_USE_VCLPLUGIN=kde4, SAL_USE_VCLPLUGIN=gtk or SAL_USE_VCLPLUGIN=gtk3 environment variables. These variables can be uncommented in /etc/profile.d/libreoffice-fresh.sh or /etc/profile.d/libreoffice-still.sh.

However, if it looks like it is using Windows 95/98 icons, go to Tools > Options... in the menus (which presents the Options Dialog), then select LibreOffice > Accessibility and uncheck "Automatically detect high-contrast mode of operating system".

If that does not work immediately, you may need to change the icon set that is in use; this is also in the Options Dialog, under LibreOffice > View with two pop-up boxes for "Icon size and style" (the latter pop-up box should be changed to something other than "High-contrast").

Firefox themes

LibreOffice 4.x series is able to use Firefox themes. Enter LibreOffice options and choose Personalization > Select Theme, then paste the URL of your favourite one. A convenient button in the dialog box lets you open the browser.

Themes can be found on Mozilla's theme repository.

If you prefer to disable the startup logo, open /etc/libreoffice/sofficerc, find the Logo= line and set Logo=0.

Note: This variable is unrelated with the Logo scripting support.

Extension management

The following additional extensions are available in the official repositories:

For more extensions, check the AUR, the built-in LibreOffice Extension manager, or libreplanet.

Language aids

Spell checking

For spell checking, please make sure hunspell is properly installed; this should be the case for both still and fresh LibreOffice versions. Then install a language dictionary for hunspell like hunspell-en for English, hunspell-de for German, etc. Then enable the Writing aids by selecting the check-box in Tools -> Options -> Language Settings -> Writing Aids -> Hunspell SpellChecker.

Finnish

Unlike other languages, Finnish dictionaries use different naming. These four packages should be installed (in this order): libvoikko, malagaAUR, voikko-fi-malagaAUR, hfstospellAUR and voikko-libreofficeAUR.

Hyphenation rules

For hyphenation rules, you will need hyphen and a language hyphen rule set (hyphen-en for English, hyphen-de for German, etc).

Thesaurus

For the thesaurus option, you will need libmythes and a mythes language thesaurus (like mythes-en for English, mythes-de for German, etc).

Grammar checking

Tango-inaccurate.pngThe factual accuracy of this article or section is disputed.Tango-inaccurate.png

Reason: Unintelligible flow of ideas: "...the later is not packaged..." -- which one is "the later"? I can only say that LanguageTool is packaged as a LibreOffice extension. (Discuss in Talk:LibreOffice#)

For grammar checking, several tools are available. The most common is LanguageTool. While the languagetool is available in the official repositories, the later is not packaged as a LibreOffice extension. It is thus recommended to install it with via the AUR package libreoffice-extension-languagetoolAUR instead. Even if this AUR package comes bundled with LanguageTool, this does not conflict with the one in the official repositories. In the future, it could even be possible to make that AUR package depend on the official languagetool package.

After this package has been installed, please make sure you have a Java runtime installed. Indeed, Languagetool uses Java and may slow down or briefly hang LibreOffice, particularly while opening documents. Fortunately this is usually only when initially opening a document and is usually not apparent otherwise.

Other grammar tools can also be found on the LibrePlanet extension page, on the official LibreOffice Extensions website or OpenOffice's Website. Please note all OpenOffice extensions are guaranteed to work with LibreOffice.

French

French-speaking users are advantaged here: they do not need to install LanguageTool nor Java. Dicollecte provides a nice Python extension, specifically designed for Frenchs. You can install it from the website or via this AUR package: libreoffice-extension-grammalecte-frAUR. In any case, this extensions also comes with the French dictionaries otherwise provided by hunspell-fr.

Offline help for en-US

As of version 5.2.2, libreoffice-fresh provides the offline help files for en-US. Help files for different locales is provided by the appropriate libreoffice language package, (i.e., libreoffice-fresh-en-ZA provides the help files for en-ZA locales).

Installing macros

If you intend to use macros, you must have a Java Runtime Environment enabled. A Java Runtime Environment is enabled by default, but disabling it speeds up the program.

The default path for macros in Arch Linux is different from most Linux distributions. Its location is:

~/.config/libreoffice/4/user/Scripts/

Speed up LibreOffice

Some settings may improve LibreOffice's loading time and responsiveness. However, some also increase RAM usage, so use them carefully. They can all be accessed under Tools > Options.

  • Under Memory:
    • Reduce the number of Undo steps to a figure lower than 100, to something like 20 or 30 steps
    • Under Graphics cache, set Use for LibreOffice to 128 MB (up from the original 20 MB)
    • Set Memory per object to 20 MB (up from the default 5 MB).
    • If LibreOffice is used often, check Enable systray Quickstarter
  • Under Advanced, uncheck Use a Java runtime environment
Note: For a list of functionality written in Java only, see: https://wiki.documentfoundation.org/Development/Java.

Troubleshooting

Font substitution

These settings can be changed in the LibreOffice options. From the drop-down menu, select Tools > Options > LibreOffice > Fonts. Check the box that says Apply Replacement Table. Type Andale Sans UI in the font box and choose your desired font for the Replace with option. When done, click the checkmark. Then choose the Always and Screen only options in the box below. Click OK. You will then need to go to Tools > Options > LibreOffice > View, and uncheck "Use system font for user interface". If you use a non-antialised font, such as Arial, you will also need to uncheck "Screen font antialiasing" before menu fonts render correctly.

Anti-aliasing

Merge-arrows-2.pngThis article or section is a candidate for merging with Font configuration.Merge-arrows-2.png

Notes: please use the second argument of the template to provide more detailed indications. (Discuss in Talk:LibreOffice#)

Execute:

$ echo "Xft.lcdfilter: lcddefault" | xrdb -merge

To make the change persistent, add Xft.lcdfilter: lcddefault to your ~/.Xresources file, and make sure to run $ xrdb -merge ~/.Xresources (source. See X resources for more details.

If this does not work, you can also try adding Xft.lcdfilter: lcddefault to your ~/.Xdefaults. If you do not have this file, you will have to create it.

Hanging when using NFSv3 shares

If LibreOffice hangs when trying to open or save a document located on a NFSv3 share, try prepending the following lines with a # in /usr/lib/libreoffice/program/soffice:

# file locking now enabled by default
SAL_ENABLE_FILE_LOCKING=1
export SAL_ENABLE_FILE_LOCKING

To avoid overwriting on update you can copy /usr/lib/libreoffice/program/soffice in /usr/local/bin. Original post here.

LibreOffice does not detect my certificates

If you cannot see the certificates when trying to sign a document, you will need to have the certificates configured in Mozilla Firefox (or Thunderbird). If after that LibreOffice still does not show them, set the MOZILLA_CERTIFICATE_FOLDER environment variable to point to your Mozilla Firefox (or Thunderbird) folder:

export MOZILLA_CERTIFICATE_FOLDER=$HOME/.mozilla/firefox/XXXXXX.default/

Certificate detection.

Run .pps files in edit mode (without slideshow)

The only solution is to rename the .pps file to .ppt.

Add the following script to your home directory and use it to open every .pps file. Very useful to open .pps files received by email without the need to save them.

#!/bin/bash

f=$(mktemp)
cp "$1" "${f}.ppt" && libreoffice "${f}.ppt" && rm -f "${f}.ppt"

Application Error (not starting)

When using a different GTK theme than Adwaita, LibreOffice may fail to start:

(soffice:2148): GLib-GObject-CRITICAL **: g_value_set_boxed: assertion 'G_VALUE_HOLDS_BOXED (value)' failed

(soffice:2148): GLib-GObject-WARNING **: gtype.c:4268: type id '0' is invalid

(soffice:2148): GLib-GObject-WARNING **: can't peek value table for type '<invalid>' which is not currently referenced
Application Error

See FS#46614.

Exit while pushing the save button

Try either of the following workarounds:

  • Delete the ~/.config/libreoffice folder. It will erase all the settings linked to LibreOffice and so, LibreOffice will recreate them on the next launch.
  • Go to menu Tools > Options > LibreOffice > General and check Use LibreOffice dialogs.
  • The GTK3 integration provided by libvclplug_gtk3lo.so has been identified as the cause of this problem. [1] See #Theme to use a different VCL, such as gtk.

Media support

If embedded videos are just gray boxes, make sure to have installed the GStreamer plugins required.

Default paper size in Writer and Draw

If the default paper size in blank Writer and Draw documents is persistently incorrect for your locale, try installing the libpaper optional dependency and either updating /etc/papersize (for a system-wide change) or exporting the PAPERSIZE environment variable (for a user change) with your preferred paper size.

Note: libpaper defaults to Letter paper size if nothing else has been set.

LibreOffice toolbars unreadable with dark themes

See https://bugs.documentfoundation.org/show_bug.cgi?id=94632

To use toolbar icons compatible with dark themes, set environment variable VCL_ICONS_FOR_DARK_THEME=1

As an alternative workaround, run libreoffice with a light theme (e.g. with environment variable GTK_THEME=Adwaita:light).