Talk:ASUS x205ta

From ArchWiki
Jump to navigation Jump to search

General Bay Trail page

Would it maybe be better to have one page that mentions all the Bay Trail quirks and then list any specific options for the various models in their own section? Reading through the X205TA page every single fix also applies for the T100TA (save for the cstate, which the T100TA seems to like at 0) Parkerlreed (talk) 14:09, 14 April 2016 (UTC)

I initial made this page when I had just bought the x205ta on steep discount and suspected others may have taken the same opportunity so would immediately need the information. In retrospect, I should have anticipated that the solutions would likely appy to other Bay Trail devices. I am very happy for this page to be converted to a general Bay Trail page, but will not be able to test on any devices other than the x205ta so probably shouldn't lead the charge. MaciekChudek (talk) 22:10, 14 April 2016 (UTC)


I have a T100TA and I also second the idea to add T100TA information into this article. For example, gpio_crystalcove module is needed to enable special key on T100TA, which sometimes doesn't load automatically by udev. This is a T100TA only problem and thus make it inappropriate to appear in this article. Boteium (talk) 16:51, 24 May 2016 (UTC)

BREAKING NEWS! The patches have been admitted to kernel 4.11 mainline.

The relevant patches from Pierre Bossart have been admitted into the mainline 4.11 kernel rc1! How awesome! Eager to have it reach the testing repo on Arch packages.

EDIT: found linux-baytrail411AUR, usin' it right now. It does solve the freezing, and the backlight keys work! The backlight itself, though, is now broken. Preload i915 into initramfs to avoid graphical glitches.

EDIT2: The backlight broken was due to me not building the n116bge panel bindings. Will retry later.

EDIT3: Audio works! Follow the last two steps in the "Sound" section copying chtrt5645.conf and HiFi.conf and it'll work like a charm! Still confused as of the LCD and graphical glitches, currently skimming through qconf. Sleep works, yet when it wakes up the LCD panel does not function. I can still shut the PC down through TTY blindly so it's kinda the problem now. May be linked to the backlight problem.

EDIT4: Graphical glitches gone when I installed the xf86-video-intel driver. Now the only problem is backlight and display on wake. One step further towards full functionality! --TheSola10 (talk) 08:25, 11 March 2017 (UTC)


Both backlight and volume keys work out of the box for me on XFCE. I proposed to remove the special keys section. The freezing section should be updated. There is a kernel patch to be applied and the boot paramter still applies. For the kernel I'll send in two AUR packages: one with a pre-built kernel from harryharryharry and another which applies all of his patches and his config in an X205TA arch kernel PKGBUILD. --E-type (talk) 09:29, 31 December 2017 (UTC)

On the first point, I can confirm: Just installed Arch using the linux-x205taAUR AUR kernel as mentioned in the article; both backlight and volume keys are functional. Ambience (talk) 05:20, 26 May 2018 (UTC)

I'd suggest moving the existing material to a separate section for people still trying to use older kernels. I'm on 4.14.5-1 and pretty much everything seems to work these days, but I've been patching solutions over solutions for a year and a half now, so am no longer sure what is essential and what's redundant. I intend to clean this page up but am on the road at the moment and won't be back near my X205ta till late Feb. Go ahead and make the changes if you're keen. --MaciekChudek (talk) 14:05, 31 December 2017 (UTC)