Talk:Activating Numlock on Bootup

From ArchWiki
Jump to: navigation, search

Extending getty@.service

For many months I used this method, and it caused huge instability problems that I couldn't track down... Putting that service in exactly as described causes VTs to flicker and go black and unresponsive about half of the time.

Maybe we should put a warning at least?

Same here. I had more luck with ExecStartPre instead of ExecStartPost, though I don't know if that has other side effects. --Norfanin (talk) 12:16, 16 November 2013 (UTC)
I had the same problem and replacing ExecStartPost by ExecStartPre solved it without any other noticeable problem for several weeks. Someone else had the same problem on Suse and solved it in the same way (he seems to know the cause: « 4. Reason for not using the recommended "ExecStartPost" was, getty crashed due to the automated numlock hint message. »). So I made the change from ExecStartPost to ExecStartPre in the page. Vej.kse (talk) 13:04, 10 June 2014 (UTC)

GDM numlock on startup.

While I've spent countless hours trying to determine what to do to enable numlock on the GDM login, I have yet to find a definitive configuration. I somehow have it enabled, but cannot attribute this to any particular setting. The guide provided does not appear to be effective, as my /etc/gdm/Init/Default file is not modified. The only factor that seems to allow it to work is by disabling Wayland as default in /etc/gdm/custom.conf, however that does not explicitly affect the number lock status. I was hoping to edit the directions on the wiki page itself, but I haven't a clue what to change it to now. CubeTheThird (talk) 21:45, 21 November 2015 (UTC)

The method for turning on numlock in GDM should be updated. From this wiki GDM#Autostarting_applications_with_GDM GDM autostarting I found out that scripts in /etc/gdm/Init aren't run anymore. Marcarrelus (talk) 11:46, 17 August 2016 (UTC)