Talk:Arduino

From ArchWiki
Jump to: navigation, search

serial problems

i found that the arduino aur version did not generate the uucp group. it might be better to encourage user to install the aur/arduino-beta (1.5.6_r2.2) it takes care of this. Yair (talk) 08:27, 21 June 2014 (UTC)

avrdude

avrdude: ser_open(): can't open device "/dev/ttyACM0": Permission denied

i did chmod u+s /usr/bin/avrdude according to forum

is there a more proper way to solve this? (user is in both uucp and tty and lock groups) Tsester (talk) 07:13, 17 June 2016 (UTC)

The Arduino#Configuration section says to "logout and login again for this to take effect". Have you done that? You can verify the active groups by running groups <your_username>.
You don't need all three groups, the /dev/ttyACM0 device has exactly one group. See ls -l /dev/ttyACM0 for which one.
-- Lahwaacz (talk) 07:31, 17 June 2016 (UTC)
i did logout, no change, groups correct. It IS however specific to Leonardo, Due works fine .. Tsester (talk) 09:35, 17 June 2016 (UTC)
And what is the group of /dev/ttyACM0 in case of your devices? -- Lahwaacz (talk) 10:17, 17 June 2016 (UTC)
crw-rw---- 1 root uucp 166, 0 06-17 13:18 /dev/ttyACM0, i'm trying to add udev rule with vendor/product id (first time) but everytime arduino tries to upload, group changes.. still a lot to learn.. Tsester (talk) 10:20, 17 June 2016 (UTC)
same permissions/group with Due Tsester (talk) 10:37, 17 June 2016 (UTC)
Group changes to what? And when exactly? -- Lahwaacz (talk) 10:49, 17 June 2016 (UTC)
Sorry, nevermind, from uucp -> users with 666. i was following some instructions, i understand that since i am already member of uucp and ttyACM0 has g+rw there is no need. Tsester (talk) 10:51, 17 June 2016 (UTC)
This is pointless, closing. If you're interested in collaborative solution, please start a new discussion when you have a clear description of your problem and all the secondary information like "following some instructions". -- Lahwaacz (talk) 12:01, 17 June 2016 (UTC)

scons uploading does not work

scons upload gives

avrdude: stk500_recv(): programmer is not responding

arduino-cmake worked, I tried to copy the avrdude line from cmake to scons, but it wouldn't work for some reason. I'm using arduino uno v3, arduino 1:1.0-3 from AUR. --Ichernev (talk) 22:38, 5 May 2012 (UTC)

stty

I think we should add option min 1 to stty command. also i realized that after calling Arduino IDE's terminal icrnl had changed to -icrnl. So i suggest we update the command to :: stty -F /dev/ttyACM0 cs8 9600 ignbrk -brkint -imaxbel -opost -onlcr -isig -icanon -iexten -echo -echoe -echok -echoctl -echoke noflsh -ixon -crtscts icrnl min 1 Tsester (talk) 10:51, 18 June 2016 (UTC)

Missing tools

Compiling Arduino sketchbooks fails with message: "Parameter 'tools' is mandatory." I compared the arch package to the 64-bit linux download from Arduino (found at https://www.arduino.cc/en/Main/Software) and discovered that the arch package was missing the directory: /usr/share/arduino/hardware/tools. I fixed the compilation error by moving that tools directory from the Arduino download into the correct location. Unsure if I am missing a dependency or the package is broken -- I'm new to Arch.

—This unsigned comment is by Jfmathews (talk) 05:38, 5 January 2017‎. Please sign your posts with ~~~~!