Talk:Compiz Fusion

From ArchWiki
(Redirected from Talk:Compiz fusion)
Jump to: navigation, search

Install order

I had to install the packages in this order:

  • compiz
  • libcompizconfig
  • compizconfig-python
  • ccsm

However, fusion-icon-git depends on compiz-git. Something is wrong here.

Plus I think there we're -some dependencies, which I don't remember. Just a word of warning for other newbies like me - out of my stupidity I went for all GIT versions and I got some serious problems. Also, I had to get the same emerald version as the compiz version to get emerald working. Kristjans 21:43, 27 August 2007 (EDT)

Removing "Install libx11 from [testing]" Section

Seeing as the newer libx11 has been moved to "extra", I am taking out this section.

Compiz Fusion requires a newer version of <tt>libx11</tt> which is currently only available in the [testing] repository. To enable the testing repo, edit '''/etc/pacman.conf''' as root and change the following lines:
 #Include = /etc/pacman.d/testing
to this:
 Include = /etc/pacman.d/testing
Save and exit.
Synchronize the repos and install <tt>libx11</tt> with the following command:
 # pacman -Sy libx11
Finally, once you have installed <tt>libx11</tt> you can disable the [testing] repo again by re-commenting the lines mentioned above (in ''/etc/pacman.conf'').

If the section is not actually obviated for some reason, please replace it and explain the reason here. --Anthony5429 14:14, 17 September 2007 (EDT)

libx11 isn't in the extras repository yetI can understand the desire to remove deprecated information, but the new package isn't in the [extras] yet, which means that anyone following this wiki until that time will undoubtedly fail. --thayer Monday, 17 September 2007
Hrm...? When I go here, I see version 1.1.3-1 (updated 2007-09-16) in the "extra" repo.... I am running that version from the extra on arch64... --Anthony5429 19:23, 17 September 2007 (EDT)
Hrmm is right... I see what you mean by the date stamp, but it was my understanding that the -x trailing the version number is the package build revision number. Thus 1.1.3-4 would be the 4th package revision to libx11 v1.1.3, making it a newer version than 1.1.3-1. --thayer Monday, 17 September 2007
oo - I wonder if the version which is in extra would work. Has anyone here tried using the version in extra which was updated on 2007-09-16? --Anthony5429 21:22, 17 September 2007 (EDT)
I can confirm that the libx11 package from [extras] does not work with Compiz Fusion. It results in broken icons all over the desktop and CF won't load at all unless the [testing] version is installed. --thayer Tuesday, 18 September 2007, 08:09 AM
Ahh - thanks for trying that out! Well, as a future note to anyone who sees this at a later time, if libx11 1.1.3-4 or later is available in extra, that section may be removed from the article. --Anthony5429 11:24, 18 September 2007 (EDT)
The new version is up. I'm taking off part about using the testing repo for it now. --Anthony5429 05:06, 20 October 2007 (EDT)

How to make Compiz the default window manager in GNOME

Create /usr/share/applications/compiz.desktop:

[Deskop Entry]
Exec=compiz ccp
# name of loadable control center module
# name we put on the WM spec check window
[Window Manager]

Then instruct GNOME session to use this newly created file:

gconftool-2 --set --type string /desktop/gnome/session/required_components/windowmanager compiz


you have to have the package xorg-utils for compiz-fusion to work...

deprecated part concerning XFCE

Somewhere between XFCE version 4.2 and 4.4 the xfce4-session config file changed from "~/.conf/xfce4-session/xfce4-session.rc " to "~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml ". The concerned part is Xfce autostart (with "fusion-icon") Method 2. I added the Xfce autostart (without "fusion-icon") Section. It contains the right paths for XFCE 4.4. Are versions prior to 4.4 available over pacman? If not I'll update the entry.