Talk:GNUnet

From ArchWiki
Jump to: navigation, search

New release

Hi,

the package gnunet in the rep is not compatible with the latest release of the gnunet project. In Version 0.10.0 the cryptographic primitives are replaced, so the older versions wont be compatible. Should this information be in this page and if yes where should I put it?

Fr 3. Jan 00:14:59 UTC 2014

community/gnunet 0.9.5_a-2 source: pacman -Ss

Fr 3. Jan 00:16:23 UTC 2014

GNUnet 0.10.0 source: gnunet download page

--Rmmonster (talk) 00:28, 3 January 2014 (UTC)

Hi, why don't you just add a Note in the Installation section? Possibly with some reference to upstream documentation that explains what to do when upgrading (while I'm writing, 0.10.0 is still in community-testing). -- Kynikos (talk) 02:00, 4 January 2014 (UTC)

Outdated

The documentation doesn't seem to apply. The link is/was broken, GNUnet seems to be based on a gnunet user, the config filename installed differs from upstream, and there is more to GNUnet than peer to peer: VPN and DNS.

~/builds/gnunet-0.10.1/contrib $ ./gnunet-gns-import.sh
GNUnet is not running, please start GNUnet before running import

Kete (talk) 01:57, 8 June 2015 (UTC)