Talk:Private Internet Access/AUR

From ArchWiki
Jump to navigation Jump to search

I found the AUR package broken. I got PIA working by installing networkmanager-openvpn (may require a reboot) and importing the saved profiles manually from PIA's configuration zip. After importing, I made the following changes in NetworkManager:

  • obviously needed my username and password; also used the ca.crt from the configuration zip file PIA offers. This is all in one place under Network Connections → VPN → Your Regional Profile → VPN. Fill in the details you need under Authentication. Think, from this point, it already worked using the default Blowfish cipher.
  • [Optional but probably recommended AES-128 encryption] In the same window, click on Advanced. Under General, I used all the default settings, except I changed my gateway port to 1196. This is only necessary…
  • [Optional but probably recommended continued] …if you want to use AES-128 encryption. Still in the Advanced Settings window, selection 'Security' and change your cipher to AES-128-CBC.

I also keep IPv6 disabled. Not sure this is comprehensive, but I'd love feedback to know if there is anything else I should do. As of now, I haven't really configured my firewall. Otherwise, hope this helps someone. Bolwerk (talk) 16:08, 12 April 2016 (UTC)

How was it broken? If you have the AUR package installed, remember to run `pia -a` after you configure any settings in `/etc/private-internet-access/pia.conf`and login information in `/etc/private-internet-access/login.conf`. I do not normally use Network Manager but I maybe have to install it and take a look at it if the above doesn't work. However, I do need to fix when upgrading that it runs `pia -a` for you.
Flamusdiu (talk) 23:31, 12 April 2016 (UTC)
Hmm, well, when I ran pia -a I got
$ sudo pia -a
Traceback (most recent call last):
 File "/usr/bin/pia", line 9, in <module>
   load_entry_point('pia==2.5', 'console_scripts', 'pia')()
 File "/usr/lib/python3.5/site-packages/pia/command_line.py", line 23, in main
   pia.run.run()
 File "/usr/lib/python3.5/site-packages/pia/run.py", line 58, in run
   [globals()[k]() for k, v in props.commandline.__dict__.items() if
 File "/usr/lib/python3.5/site-packages/pia/run.py", line 59, in <listcomp>
   not k == 'hosts' and getattr(props.commandline, k, None)]
 File "/usr/lib/python3.5/site-packages/pia/run.py", line 108, in auto_configure
   app.config(*getattr(openvpn, config))
 File "/usr/lib/python3.5/site-packages/pia/applications/appstrategy.py", line 76, in config
   self.app.config(config_id, filename)
TypeError: 'Config' object is not callable
What goes into pia.conf? I don't see any configuration information about it on the page. Maybe I'm missing something?
Thank you for the response and let me know if there is anything else you need. I sort of suck with Python. I hope you don't mind that I formatted your response's indentation a little to help the flow for anyone else reading this. Bolwerk (talk) 14:47, 13 April 2016 (UTC)
Ha! Well, I guess I need to fix that error case. It goes into `/etc/private-internet-access`. There should be an example in there. I will update python-pia to account for a missing config. Also, I will probably need to generate a 'basic' config to put there. Well, this has been fun. Thanks for finding this out! Flamusdiu (talk) 01:26, 14 April 2016 (UTC)
I added an issue about it here https://github.com/flamusdiu/python-pia/issues/4 Flamusdiu (talk) 01:40, 14 April 2016 (UTC)
Bolwerk, can you do `git clone https://aur.archlinux.org/private-internet-access-vpn.git` and change "git+https://github.com/flamusdiu/python-pia.git#tag=v${pkgver}" to "git+https://github.com/flamusdiu/python-pia.git#branch=dev"; then build and test it? You can post here or on the Github page linked above. Flamusdiu (talk) 20:55, 16 April 2016 (UTC)
Sure, I'll follow up in a bit about that. Bolwerk (talk) 15:16, 17 April 2016 (UTC)
Here's what happened. Sorry it took me so long to get back to you, been traveling. This is an attempt to install it on my laptop, which hadn't been configured for VPN before. Git'd, changed that line, compiled/made the package (makepkg -s), installed it (sudo pacman -U ...), rebooted, and then...
$ sudo pia -a
Traceback (most recent call last):
  File "/usr/bin/pia", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 2927, in <module>
    @_call_aside
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 2913, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 2940, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 635, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 943, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 829, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'docopt' distribution was not found and is required by pia
Let me know if there's anything else. If you want to get my attention faster try my name at gmail. Bolwerk (talk) 16:21, 19 April 2016 (UTC)
I just sent an HO. Some reason it didn't pull the docopt. Flamusdiu (talk) 23:59, 19 April 2016 (UTC)

Followup concerning pia pkg

Regarding above problem, I also tried

sudo pacman -S python-docopt python2-docopt

And this changed the error above to:

$ sudo pia -a
Traceback (most recent call last):
  File "/usr/bin/pia", line 9, in <module>
    load_entry_point('pia==2.6', 'console_scripts', 'pia')()
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 542, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 2569, in load_entry_point
    return ep.load()
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 2229, in load
    return self.resolve()
  File "/usr/lib/python3.5/site-packages/pkg_resources/__init__.py", line 2235, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/usr/lib/python3.5/site-packages/pia/__init__.py", line 22, in <module>
    from . import utils, run
  File "/usr/lib/python3.5/site-packages/pia/run.py", line 27, in <module>
    from pia.docopt import docopt
ImportError: No module named 'pia.docopt'

Cheers! Bolwerk (talk) 16:27, 19 April 2016 (UTC)

Oops. That would be my fault. I'll need to fixed that one. Flamusdiu (talk) 23:59, 19 April 2016 (UTC)

Is systemd usage unsupported?

Hi! I haven't found any other way to use this package other than with the openvpn systemd configurations. I was about to make it more clear in the wiki, because it seems to be the easiest way. But then I noticed "Note: These are unsupported configurations". What's this all about?

--JD91mZM2 (talk) 12:15, 14 January 2018 (UTC)

If you can find any information about systemd's VPN support. I may be able to work with it. It's supported because of a lack of good information about it. Flamusdiu (talk) 13:37, 26 January 2018 (UTC)
Ah, I see. Thanks! --JD91mZM2 (talk) 07:22, 27 January 2018 (UTC)