Talk:Kodi

From ArchWiki
(Redirected from Talk:Xbmc)
Jump to: navigation, search

Example guide for xbmc+MySQL

I spend some considerable effort and time into drafting this section today in hopes in might lower the bar for others to implement the setup: sharing a database across multiple nodes. Please give it a try and provide some feedback, good or bad. Graysky (talk) 18:09, 21 September 2014 (UTC)

One observation: In the MySQL/MariaDB install section, you grant the 'kodi' user full permissions on all databases ('GRANT ALL ON *.*'). This is not great security for users who may be running other, private databases on the same server. Suggest this be changed to warn of this and/or to provide alternative instruction, i.e.
CREATE DATABASE <name-of-kodi-db>;
GRANT ALL ON <name-of-kodi-db>.* to 'kodi';
Unless Kodi needs to be able to perform any global actions (and I can't imagine why it would), this is a safer approach. If no objections I'll research this and edit the section in due course. Havin it (talk) 12:24, 4 April 2015 (UTC)

I recently followed the steps in this section to set up sharing of my database across nodes. I had to change:

CREATE USER 'kodi' IDENTIFIED BY 'kodi';
to
CREATE USER 'kodi'@'localhost' IDENTIFIED BY 'kodi';
in order to make it work.Dafrizz (talk) 02:09, 11 October 2015 (UTC)

Pulseaudio and XBMC autostart

Using the xbmc.service did not start pulseaudio. I ended up having to set a tty to autologin(getty) and start X in .bash_profile (using geforce integrated ION and HDIM out). Olivervbk (talk) 16:10, 28 January 2013‎ (UTC)

Yes, this is a known issue currently. See: xbmc forum post and arch bbs post and systemd bugzilla. Also, please sign your comments using four tilde characters. Graysky (talk) 07:08, 11 August 2014 (UTC)
This is now correct with xbmc-standalone-serviceAUR version 1.3-1. Graysky (talk) 15:41, 9 September 2014 (UTC)

XBMC shutdown/reboot polkit rules

I undid your modification to the XBMC page, as the polkit rule that enables poweroff and rebooting when using the systemd service is not present in the current package, as you implied in your modification comment. You can check yourself here. Any reason you thought it was? I added a bug report mentioning this issue here. --Palmaway (talk) 03:31, 9 June 2013 (UTC)

It's not the exact udev rule, but placing the user in the 'power' group, and invoking the shutdown option works for me. This can be reversed by removing the user for the power group, logging out and back in, and invoking the shutdown option again. Now, the box does not go down; xbmc just exits. So functionally, that udev rule is not needed. Graysky (talk) 10:44, 9 June 2013 (UTC)
Are you running XBMC by enabling the systemd service? What you mention works if you run XBMC in other ways (xinit with autologin, direct execution...) but not for the systemd service, as in this case it will not register the session correctly therefore not enabling poklit. See this forum post for more details. --Palmaway (talk) 20:20, 9 June 2013 (UTC)

lircd with XBMC

The section on getting an MCE remote to work with lircd under XBMC had been sitting there with a "this isn't the right way to use systemctl" warning for a while now. I was reinstalling lircd on my build, and figured I'd update this section. Fortunately, it seems that as far as I can tell, from lircd 0.9.1 onward, we don't need the custom systemctl service and the confusingly named config file for the service (which shared its name with lircd's own config file), as the lircd.socket service appeared to properly handle the /dev/lirc0 device when specified in lirc's own (also new) lirc_options.conf file. Shorter: using lircd.socket, everything now seems to work right out of the box. Would appreciate confirmation of this. --Slinkygn (talk) 15:37, 9 September 2014 (UTC)



The secion on setting up lircd with mce remote has this line, however the file isn't in the lirc pacakge.

# ln -s /usr/share/lirc/mceusb/lircd.conf.mceusb /etc/lirc/lircd.conf

--Mex (talk) 20:07, 7 June 2015 (UTC)

socket activation

The text says to replace user in the files it teaches to the user to create with the running user but the file names are inconsistent with that statement. I don't have the inclination to test the socket method to fix it. Graysky (talk) 08:01, 22 November 2014 (UTC)

It works for me as written. I'll go ahead and remove the warning. --Butler360 (talk) 18:07, 9 January 2015 (UTC)

Controlling with a gamepad/joystick

I tried a lot of things to in order to get a wireless Xbox 360 controller to work with XBMC, but the thing that finally made it work was going into System -> Settings -> System -> Input devices and checking the "Enable joystick and gamepad support" wich was disabled by default. May want to add a notice about this. Sivert (talk) 23:17, 6 December 2014 (UTC)

It's a wiki, dude. If you feel that you have some information others could benefit from, you are free to edit the main article to add it. Graysky (talk) 11:12, 8 December 2014 (UTC)

kodi-standalone systemd service does indeed need Xwrapper.config

The section about the systemd service that starts kodi-standalone mentions in its notes that the file /etc/X11/Xwrapper.config might be needed with the lines (actually, just one line) from the next section, i.e., with needs_root_rights = yes On my fresh Arch Linux box I did indeed need this file, so the remark to add this file with given content should be placed above those subsections to say that it is needed for all systemd service options.

The fact that this remark was placed at the end of the notes made me unfortunately realize it after a couple of other attempts to fix my non-starting kodi service...

Epinephrine (talk) 16:56, 2 January 2016 (UTC)

No, remove the file and reboot with the service enabled; provided that you have the correct video driver installed, it works fine without it. Graysky (talk) 17:01, 2 January 2016 (UTC)
Confirmed on a fresh install just now. Upon rebooting into it, I was greeted with kodi with no additional setup. I suspect you are missing something with regard to your ati drivers.
mount /dev/sda4 /mnt/mini
pacstrap -i /mnt/mini base xf86-video-intel kodi kodi-standalone-service
echo "LABEL=mini / ext4 defaults,relatime 0 1" >> /mnt/mini/etc/fstab
echo mini > /mnt/mini/etc/hostname
sed -i 's/#en_US.UTF-8 UTF-8/en_US.UTF-8 UTF-8/' /mnt/mini/etc/locale.gen
echo "LANG=en_US.UTF-8" > /mnt/mini/etc/locale.conf 

arch-chroot /mnt/mini /bin/bash
passwd
sed -i '/^MODULES/ s,"","i915",' /etc/mkinitcpio.conf
mkinitcpio -p linux
locale-gen
systemctl enable kodi
exit
reboot
Graysky (talk) 18:24, 2 January 2016 (UTC)
...unless the ATI drivers you're using for some reason require that file which would surprise me. I have no ATI hardware for testing. Graysky (talk) 19:13, 2 January 2016 (UTC)