AUR Cleanup Day/2010

From ArchWiki
Revision as of 16:56, 26 January 2012 by Trontonic (Talk | contribs) (See also)

Jump to: navigation, search

TU's are currently working through the list. You can still add packages but please check the whole page first. The TUs will not delete any useful package.

The AUR has a large number of obsolete packages which could use cleaning up. Examples of packages that may be cleaned up are:

  • packages that have been renamed or replaced
  • old and unmaintained developmental (cvs/svn/etc) packages

Post suggestions of packages on this pages. Trusted Users will get together and go though the list in a couple of weeks and confirm which packages should be removed.

Please DO NOT REMOVE suggestions from the wiki page but add a comment on why it should be kept instead. Please list packages in alphabetical order!

Package List

Add new packages here - check for the package in the sorted lists below before adding

  • bmp-flac - doesnt work anymore
  • bmp-scrobbler - doesnt work anymore
  • boxee - deprecated by boxee-source
  • ct - project page and sources aren't available
  • divifund - "dead" project; it's very old and doesn't work with the latest versions of its dependencies
  • drift - project page and sources aren't available
  • eclipse-i18n-pack1 - not needed anymore (it's for old eclipse), broken source link
  • eclipse-i18n-pack2 - not needed anymore (it's for old eclipse), broken source link
  • eclipse-i18n-pack2a - not needed anymore (it's for old eclipse), broken source link
  • eclipse-i18n-packbidi - not needed anymore (it's for old eclipse), broken source link
  • entropy-cvs - old dev-version, Enlightenment project uses svn now
  • eselect - is it needed in Arch Linux?
  • evfs-cvs - old dev-version, Enlightenment project uses svn now
  • exquisite-cvs - old dev-version, Enlightenment project uses svn now
  • falldown - project page and sources aren't available
  • fbpager-git - broken links (see comment by hadrurus)

<--firefox-like pkgs cleaning-->

<--end of firefox-like pkgs-->

TU Working Area

For editing by TUs only! The wiki has a history so do not think you can get away with ignoring this... --Allan

Packages to Remove

In community:

Packages to Keep

  • atmel-firmware - no longer needed -- why?
  • autoconf-compat - too old to be useful -- it is for compiling old stuff, lets keep it, does not harm
  • aur-install - does this one still work and do we need it anyway? -- Seems to be actively maintained, no reason to delete. -- package is already REMOVED
  • amsn-plugins-texim - no longer exists -- it's here: [2] (StefanHusmann) -- package is already REMOVED
  • bin32-flashplayer-standalone - not needed anymore -- Still useful, because there is no native standalone flash player from Adobe on x86_64 systems. Mightyjaym (maintener)
  • blastwave - Dead projet, doesn't compile anymore. -- stefanhusmann: maybe only needs a maintainer.
  • btrfs - newer version (0.15) available, released May 29th, 2008. -- So this package should maybe be orphaned, no obvious reason to delete it. [Edit: orphaning should be requested in the aur-general mailing list. Dragonlord] -- package is already REMOVED
  • btrfs-progs - newer version (0.15) available, released May 29th, 2008. -- So this package should maybe be orphaned, no obvious reason to delete it.
  • cairo-wglitz - not needed anymore -- needed by cairo-dock
  • chocolate-doom-svn - package is broken. cause of AUR -- it is maintained.
  • cputnik - apparently "dead" project, broken links -- package has new and active maintainer
  • eclipse33 - not needed anymore -- No reason to delete, actively maintained StefanHusmann
  • editobj2 - not needed anymore -- needed by songwrite2, I asked the maintainer to take it. (stefanhusmann)
  • empathy - empathy is in extra -- empathy is orpaned in [testing], no package in extra (stefanhusmann)
  • fluxbox-styles-boxwhore - boxwhore website is dead -- no, it seems to be down sometimes, but sometimes it works again. Package is maintained and has votes. (stefanhusmann)
  • galeon - doesn't compile (not even the latest version) -- seems to be actively maintained (stefanhusmann)
  • gdal Contributor seems to be inactive. Newer version available so this package should maybe be orphaned, no obvious reason to delete it. NOTE : updated on sept 24 2008. -- in [community]
  • gltail - apparently, this is not needed anymore (see comment) -- Should be rewritten, not dropped.
  • gnuserv - Deprecated in emacs-22+ - Please do not delete : see [3] The package never belonged to GNU emacs.(stefanhusmann)
  • gshare - The package didn't function for me with the latest gnome. Furthermore it looks like this project is dead (website is down, source is no longer available) -- it is in [community]
  • gvfs-smbfix - smb browse fix in gvfs 1.2 -- actively maintained
  • kanola - probably dead project, didn't went past the 0.0.1 release since 2006 -- PKGBUILD is maintained and maintainer is active.
  • klibc-zen - not needed anymore theres not even a kernel26zen. -- there is, but I orphand the package.
  • ii-hg - outdated, probably discontinued as the project website isn't available anymore (moved maybe?)
  • lam 7.1.3-1 - Doesn't compile and is orphaned. The successor openmpi works. -- actively maintained
  • lastfmsubmitd - Way old. -- actively maintained in [community]
  • mencode - outdated, tells aur is its homepage
    • The package is to install a perl script included in the AUR tarball so it doesn't really have a home page. So it could be kept if the script can still be useful or, at least, the script could be moved to the wiki if there is a page for scripts. --Snowman
  • mpd-pausemode - "Website" is orig. contributor's email addr.; orphaned by this contributor, so presumably no longer developed. -- no obvious need to delete
  • mlame - just a small bash script, no project page, could be moved to the wiki maybe -- actively maintained
  • mouseemu - Project not updated since 2006; xautomation also allows mouse emulation. -- package builds with little tweaking.
  • mplayer-w32codecs - not duplicate package as has more codecs than the "codecs" package. -- package is already REMOVED
    • Should rename to "codecs-extra" and not provide same files as codecs package --Allan
  • netbeans-cpp_6.1-1 - not needed anymore -- seems to be maintained.
  • netbeans-ruby_6.1-1 - not needed anymore -- seems to be maintained.
  • ndiswrapper-zen - not needed anymore. theres not even a kernel26zen.-- there is. Orphaned.
  • nvidia-96xx-zen - not needed anymore. theres not even a kernel26zen..-- there is. Orphaned.
  • nvidia-beta-zen - not needed anymore. theres not even a kernel26zen..-- there is. Orphaned.
  • nvidia-zen - http://aur.archlinux.org/packages.php?ID=13903 -- there isa zen kernel.
  • pidgimpd-svn - This package is orphaned and it doesn't build. There is mpd support in musictracker. -- actively maintained.
  • qgis contributor seems to be inactive. Newer version available so this package should maybe be orphaned, no obvious reason to delete it. -- package is in [community]
  • qgnokii - depend on qt3 but still use depend=(qt) -- builds fine with a little patch in pkgrel 6
  • sharpmusique - source is not available anymoreout this package -- angvp -- maybe it comes back again. -- maintained
  • sonata-disautocenter - not needed anymore -- actively maintained
  • truecrypt-zen - not needed anymore. theres not even a kernel26zen..-- there is. Orphaned.
  • vim-colorschemes - Mirror says 404, there is vim-colorsamplerpack in [extra] -- It is actively maintained
  • weather-wallpaper - orphaned and references as dep non-existing pymetar -- It is actively maintained (by a TU)
  • ww2d-extra - broken links, and there is no sources in other place -- maybe should be integrated into ww2d package which is also orphaned. Thoughts?
    • I tried to update ww2d, but linux binary file downloaded from SF doesn't run: no errors, no any messages in terminal. Source code is available only in cvs-repository, and last commit was on 2007-01-10. Program's author's site doesn't contain any information about ww2d. So this project is "dead". (manwithgrenade)
  • xmlwrapp no obvious reason to delete.
  • backintime-kde4 - made obsolete by other backintime version -- actively maintained
  • viceplus - maintainer wrotes that it may be deleted (see comment) -- but only because he made a mistake when uploading. no obvious need to remove. -- "Currently viceplus is merged with vice tree" ???
  • xfce4-genmon-plugin-svn - see comment for xfce-utils-svn -- there is no git-package yet
  • xfce4-notes-plugin-svn - see comment for xfce-utils-svn -- there is no git-package yet
  • xfce4-perl-svn - see comment for xfce-utils-svn -- there is no git-package yet -- package is already REMOVED
  • xfce4-power-manager-svn - see comment for xfce-utils-svn -- there is no git-package yet
  • xfce4-sensors-plugin-svn - see comment for xfce-utils-svn -- there is no git-package yet -- replaced by xfce4-sensors-plugin-git -- package is already REMOVED
  • xfce4-settings-svn - see comment for xfce-utils-svn -- there is no git-package yet
  • xfce4-smartpm-plugin-svn - see comment for xfce-utils-svn -- there is no git-package yet
  • xfce4-taskmanager-svn - see comment for xfce-utils-svn -- there is no git-package yet
  • xfce4-weather-plugin-svn - see comment for xfce-utils-svn -- there is no git-package yet

Remove from Filesystem

There are files on the AUR filesystem that have been created when poorly formed packages were uploaded. This is a secondary consideration.

There are also directories in /packages/ for which the package no longer exists. These probably need to be removed as well. All the packages that moved to community ALSO still exist there.

List here files that are in directories of existing packages.


This script will take care of packages that no longer exist.

#!/usr/bin/php
<?php
# Run this script by providing it with the top path of AUR.
# In that path you should see a file lib/aur.inc
#
# This will remove files which belong to deleted packages.
#
# ex: php cleanup dev/aur/web
#
$dir = $argv[1];

if (empty($dir)) {
        echo "Please specify AUR directory.\n";
        exit;
}

set_include_path(get_include_path() . PATH_SEPARATOR . "$dir/lib");
include("config.inc");
include("aur.inc");
include("pkgfuncs.inc");

exec('ls ' . INCOMING_DIR, $files);

$count = 0;

foreach ($files as $pkgname) {
        if (!package_exists($pkgname)) {
                echo 'Removing ' . INCOMING_DIR . "$pkgname\n";
                system('rm -r ' . INCOMING_DIR . $pkgname);
                $count++;
        }
}

echo "\nRemoved $count directories.\n";

See also