AUR Cleanup Day/2010

From ArchWiki
Jump to: navigation, search

NOTE: TU's are currently working through the list. You can still add packages but please check the whole page first.

The AUR has a large number of obsolete packages which could use cleaning up. Examples of packages that may be cleaned up are:

  • packages that have been renamed or replaced
  • old and unmaintained developmental (cvs/svn/etc) packages

Post suggestions of packages on this pages. Trusted Users will get together and go though the list in a couple of weeks and confirm which packages should be removed. Please DO NOT REMOVE suggestions from the wiki page but add a comment on why it should be kept instead. TUs will not delete any useful package.

Package List

Add new packages here - check for the package in the sorted lists below before adding

  • 4c - Home page and source not reachable
  • 9base-devel - Hasn't been update since 25/12/2005. I think its not needed.
  • abraca-hg - Replaced by abraca-git
  • advi - seems to be unmaintainable for the following reasons
    • The newest version 1.7.3 needs camlimages 3.0.0, which cannot be found on the net
    • camlimages' cvs-sources do not compile
    • package advi 1.6.0 has a patchfile of 102k size
    • package advi worked fine in former days but does does not compile anymore. It is a pity!
  • alienarena2007 - Replaced by alienarena
  • amavisd-new - old version, won't compile, maintainer don't answare for e-mails (I have made new package amavisdnew)
  • ampache-devel - Out of date since 08/19/07. It is also the stable branch, not development branch.
  • audacious-mac - Included in audacious-plugins>=1.5.0
  • audacious-xosd - Included in audacious-plugins>=1.5.0
  • azrael - dead project, does not compile
  • blender-svn-cloth - it was already merged to main svn trunk
  • blender-svn-particles - merged to main svn trunk
  • boombox - dead project, does not compile
  • cddb - Last release 31 Aug 2003
  • cdrtools-dvd - Outdated, replaced by cdrtools or cdrkit, maintainer's e-mail address is not valid
  • creapkg - web site no longer exists
  • dx9wine - contains a patch not needed anymore
  • e16-devel - Outdated, replaced by enlightenment in extra
  • e16keyedit - Outdated, never updated since Tue, 05 Jul 2005
  • ecamegapedal - Do not to compile.
  • eclipse-kde - Dead
  • eduke32 - Outdated, replaced by bin32-eduke32
    • although it is outdated, it is not replaced by bin32-eduke32, 'cause bin32-eduke32 is for Arch64 bit (this is 32bit package)
  • emacs-without-x - Dublette of emacs-nox
  • epiphany-unofficial-extensions - Out of date
  • ethereal - Renamed to wireshark, available in extra
  • exult - Do not compile, replaced by exult-cvs
  • flumotion - removed from community a year ago, orphan and 1 year out of date without any complain.
    • Note that the last version compiles fine when just changing the version and md5sum. Maybe a call should be made to ask for a maintainer.
  • fusesmb or fusesmb2 - duplicate (and both outdated, version 8.7 is available)
  • fftw2single - part of fftw2 from [extra]
  • freeplayer - Dead, 404 on source
  • freeciv-beta-svn - Outdated svn beta for version 2.1, stable 2.1 version already in Extra. Replaced by freeciv-svn
  • fretsonfire, bin32-fretsonfire which of these should be maintained?
    • I think two both should be maintained, because their dependencies are different, and an Arch64 user should be warned if package provides 32-bit binaries by bin32/lib32 prefix.
  • gaim-openq-2006 - Old plugin for gaim that has since been merged into pidgin source
  • galaxymage - Webpage is gone.
  • galeon - doesn't compile (not even the latest version)
  • gimp-freetype - This plugin was developed for gimp 2.0 and is not needed according to the notes here.
  • gimp-resynth or gimp-plugin-resynthesizer - duplicate (best to keep latter)
  • gnash-cvs - Hasn't been update since 18/11/2006. gnash is in extra now too.
    • Does the project still use CVS? If so, then this package is useful. --Slash
  • gmpc*-svn - replaced by git
  • gnuserv - Deprecated in emacs-22+
  • guifications-gaim2 - Outdated beta version, a current version is in community.
  • ii-hg - outdated, probably discontinued as the project website isn't available anymore (moved maybe?)
  • ion-modules - ion3 is not part of official repos anymore so i dont see why this should stay here. I hope AUR CleanUp involves [community].
  • ionice - part of util-linux-ng
  • jabberd1* - jabberd v.2 is in extra
  • java3d version 1.4.0, current is 1.5.1. No vital signs from maintainer. Newer PKGBUILDS are available in package comments though.
  • jfduke3d - Is not updated by his author anymore, eduke32 was made to remplace it
  • kanola - probably dead project, didn't went past the 0.0.1 release since 2006
  • kdelibs-noarts - out-of-date, modified official package
  • kdenlive 0.5_1-1 - out-of-date, doesn't compile
    • Latest stable version is 0.5, last updated in AUR on Sun, 09 Mar 2008 --Doc Angelo
    • It's not even out of date, nor duplicate of another package – 6xx
  • kernel26thinkpad - obsolete, out of date since 2006
  • lam 7.1.3-1 - Doesn't compile and is orphaned. The successor openmpi works.
  • libdvbpsi 20041028-1 - Old, recent version in extra
  • libqglviewer-latest - the same package as libqglviewer
  • librtorrent - duplicate package, already in [community]
  • linuxdcpp-cvs - Old, orphaned CVS version of a package in community
  • linux-uvc-isight and linux-uvc-isight-svn - Outdated, linux-uvc-svn does the same thing
  • lmms-cvs - Orphan, outdated, and project switched to svn.
  • mencode - outdated, tells aur is its homepage
  • mlame - just a small bash script, no project page, could be moved to the wiki maybe
  • moaceyahoo - Dead project. Will post new one, someday.
  • mouseemu - Project not updated since 2006; xautomation also allows mouse emulation.
  • mozilla-firefox-es_es - included in firefox-i18n
  • mplayer-w32codecs - duplicate package
    • I don't think it is. This packages has more codecs than the "codecs" package. It has more DLLs.
  • mpd-pausemode - "Website" is orig. contributor's email addr.; orphaned by this contributor, so presumably no longer developed.
  • mutt-cvs - mutt switched to mercurial a while back; way outdated anyway.
  • nautilus-open-terminal-gianvito 0.9-1 - not needed anymore since original version update to 0.9
  • netbeans-rubyide-hudson - useless since NetBeans supports this feature in 6.1
  • netscape-navigator - Not supported upstream anymore making it vulnerable to security issues.
    • Can be used for web development – 6xx
    • For composer functionality, seamonkey does a better job.
  • openarena - Obsolete, remplaced by openarena-bin
  • openssh-snapshot - Not needed anymore
  • org - Out of date; also, included in Emacs 22+
  • peerguardian - as the home page says: there is currently no PeerGuardian for Linux, but MoBlock can do what you need
  • pidgin-xfire - Broke; Replaced by pidgin-gfire.
  • python-gnuplot - Duplicate of gnuplot-py which was submitted almost 3 years before.
  • rb_libtorrent-svn - not needed, strange download location
  • rs_rtorrent - duplicate package, already in [community]
  • rt61-cvs - This driver is included in linus's tree and is therefore obsolete
  • slim_pam - just slim with extra configure option
  • sonic-rainbow - dead project, does not compile
  • stepmania-bin - orphan, replaced by stepmania
  • swiftfox-pentium2 - obsolete for a long time.
  • Super Mario War - The source is no longer hosted through svn. Could be easily updated though...
  • supertux-svn - It won't compile since it uses cmake insted of jam ... it must be easy to update
  • swiftfox-* 2.x optimized builds of various Mozilla products; several are orphaned and out-of-date. swiftfox3 available.
  • tar-fixed - This bug is verified fixed in tar 1.20
  • viki-svn - old, pkgbuild is broken
  • wicd-svn - Outdated, wicd on repository extra is newer.
    • Does the project still use SVN? If so, then this package is useful. --Slash
    • Yes, definitely not a candidate. However, PKGBUILD needs updating. --schiv
  • xf86-video-radeonhd-git - Seems to not be found : "error: 'xf86-video-radeonhd-git': not found in sync db" with yaourt
    • So file an yaourt bug; the files are there
  • ximian-openoffice - Ximian port of OpenOffice 1.x. Users should use the more secure OpenOffice 2.x. Also Ximian openoffice is what is now known as ooo-build.
  • pidgimpd-svn - This package is orphaned and it doesn't build. There is mpd support in musictracker.
  • sylpheed-devel - Outdated for a long time. Remove or make orphnaned.

TU Working Area

For editing by TUs only! The wiki has a history so do not think you can get away with ignoring this... --Allan

Packages to Remove

Packages to Keep

  • fretsonfire, bin32-fretsonfire - bin32 prefix is recommendable for packages with lib32-* dependencies --Allan
  • pinkytagger - Outdated by two years. (comment by Dragonlord:Latest version 2.1-0 (October 21, 2007) needs new musicbrainz, which is out of date in [extra]) --pressh

Remove from Filesystem

This is a list of files on the AUR filesystem that have been created when poorly formed packages were uploaded. This is a secondary consideration.


Remove from Filesystem (AUR Bugs)

This is a list of files that need to be removed due to AUR bugs as they hinder proper submission and maintenance of packages.

AUR Bugs


/packages/lib32-dbus is now in community - Allan