Difference between revisions of "Aiptek Tablet"

From ArchWiki
Jump to: navigation, search
m (changed category to Graphics_tablet)
(poor style, last updated in 2012, not migrated)
 
(3 intermediate revisions by 2 users not shown)
Line 1: Line 1:
[[Category:Graphics_tablet]]
 
This has been tested with an Aiptek HyperPen 12000U. I have no idea if it works with a different tablet.
 
  
==Installation==
+
#redirect [[ArchWiki:Archive]]
 
+
[[Category:Archive]]
You need to install {{Pkg|xf86-input-aiptek}} from the [[Official Repositories]].
+
 
+
Create {{Ic|/etc/udev/rules.d/20-aiptek.rules}} with the following content:
+
ACTION!="add|change", GOTO="xorg_aiptek_end"
+
KERNEL!="event[0-9]*", GOTO="xorg_aiptek_end"
+
+
ATTRS{idVendor}=="08ca", ATTRS{idProduct}=="0010", ENV{x11_driver}="aiptek", SYMLINK+="input/aiptektablet"
+
+
LABEL="xorg_aiptek_end"
+
 
+
Create {{Ic|/etc/X11/xorg.conf.d/20-aiptek.conf}} with the following content
+
Section "InputClass"
+
        Identifier "pen"
+
        Driver "aiptek"
+
        Option "Device" "/dev/input/aiptektablet"
+
        Option "SendCoreEvents" "true"
+
        Option "USB" "on"
+
        Option "Type" "stylus"
+
        Option "Mode" "absolute"
+
        Option "zMin" "0"
+
        Option "zMax" "511"
+
EndSection
+
Section "InputClass"
+
        Identifier "pen"
+
        Driver "aiptek"
+
        Option "Device" "/dev/input/aiptektablet"
+
        Option "SendCoreEvents" "true"
+
        Option "USB" "on"
+
        Option "Type" "erasor"
+
        Option "Mode" "absolute"
+
        Option "zMin" "0"
+
        Option "zMax" "511"
+
EndSection
+
Section "InputClass"
+
        Identifier "pen"
+
        Driver "aiptek"
+
        Option "Device" "/dev/input/aiptektablet"
+
        Option "SendCoreEvents" "true"
+
        Option "USB" "on"
+
        Option "Type" "cursor"
+
        Option "Mode" "absolute"
+
        Option "zMin" "0"
+
        Option "zMax" "511"
+
EndSection
+
 
+
Then restart udev and X or your display manager (gdm, kdm, slim, ...)
+
 
+
==Gimp==
+
Should work right away. If not, those settings worked for me:
+
 
+
Edit -> Input Devices -> Aiptek
+
* Mode: Screen
+
* X: 1
+
* Y: 2
+
* Pressure: 3
+
* X-Tilt, Y-Tilt and Wheel shouldn't matter
+

Latest revision as of 09:53, 12 February 2016

Redirect to: