Difference between revisions of "Apache OpenOffice (简体中文)"

From ArchWiki
Jump to navigation Jump to search
m (-)
(removed everything that was out dates for a long long time and moved something to LibreOffice)
Line 4: Line 4:
 
{{i18n|OpenOffice}}
 
{{i18n|OpenOffice}}
 
{{out of date}}
 
{{out of date}}
本文讲述了若干OpenOffice.org的技巧。如果你想修改英文wiki内容请告知我(tpowa - 软件包的维护者)。这个软件包不是从源码编译而来的软件包,而是为pacman使用直接打包了OO.org's二进制文件。
 
Arch的官方extra里,提供了openoffice的版本:
 
  
'''libreoffice'''
+
==Arch Linux中的OpenOffice==
这是openoffice最近发布的预览版 <br>
+
官方已经结束了对OpenOffice.org的支持,并选择了[[LibreOffice]]。了解详情:[http://mailman.archlinux.org/pipermail/arch-general/2011-March/018819.html Dropping Oracle OpenOffice (arch-general)].
现版本: 3.4.0 <br>
 
及可用语言包
 
  
start it with "soffice" or from Desktop menu <br>
+
推荐使用[[LibreOffice]]。
 
 
=OpenOfiice.org 3.4=
 
 
 
*查询,同3.1
 
# pacman -Ss openoffice
 
* 对于一般中文用户,可以直接安装中文套装。
 
 
 
简体版中文包:
 
# pacman -S libreoffice-zh-CN
 
 
 
繁体版中文包:
 
# pacman -S libreoffice-zh-TW
 
=(已过时)OpenOffice.org 3.1=
 
 
 
* 查询openoffice包,在终端输入:
 
# pacman -Ss openoffice
 
 
 
* 对于一般中文用户,可以直接安装中文套装。
 
 
 
简体版中文包:
 
# pacman -S openoffice-zh-CN
 
 
 
繁体版中文包:
 
# pacman -S openoffice-zh-TW
 
 
 
OpenOffice.org套装包括:
 
Openoffice.org 3.0 Cal
 
Openoffice.org 3.0 math
 
Openoffice.org 3.0 Draw
 
Openoffice.org 3.0 Impress
 
Openoffice.org 3.0 Writer
 
Openoffice.org 3.0 打印机管理
 
Openoffice.org 3.0 采用样式
 
 
 
安装OpenOffice.org(从上面的介绍的4个版本中根据自己需要,选一个安装,下面是安装openoffice.org base版本):
 
# pacman -S openoffice-base
 
==常见优化手段==
 
 
 
=(已过时)老版本安装=
 
下面介绍的都是已经过时的版本,Archlinux已经不支持这些版本。如有需要安装旧版本,或者从旧版本升级过来,可参考下面设置。
 
 
 
==OpenOffice.org 2 安装==
 
 
 
===安装===
 
* 首先,安装一个Java Runtime Environment (可选,强烈推荐):
 
# pacman -S jre
 
* 下载base:
 
# pacman -S openoffice-base
 
* 安装一个或多个语言包。base里已有英语语言包:
 
# pacman -S openoffice-XX (XX为语言包编码)
 
* 安装拼写检查工具(可选):
 
# pacman -S openoffice-spell-XX (where XX is a language)
 
 
 
* 其它语言的拼写检查工具和语言包可以在[[AUR]]里找到。
 
 
 
===配置===
 
普通用户运行'/opt/openoffice/program/soffice'将来启动OpenOffice 2,如果是第一次启动还会进行一系列配置。
 
 
 
OpenOffice 2 可以以一种精炼的方式使用若干工具包绘制和集成到不同的桌面环境里。若要手工选择,你可以设置全局(例如在/etc/profile.d/里)或者OpenOffice.org所运行的shell里的OOO_FORCE_DESKTOP环境变量
 
 
 
要以GTK2模式运行OpenOffice.org,可以这样(使用bash):
 
  # OOO_FORCE_DESKTOP=gnome soffice
 
 
 
也许你喜欢象这样写在/usr/bin/soffice里:
 
export OOO_FORCE_DESKTOP=gnome
 
 
 
或者写在~/.bashrc里
 
export OOO_FORCE_DESKTOP=gnome
 
 
 
===运行===
 
 
 
如果你想运行OpenOffice.org的某个模块(而不是默认的soffice),例如字处理软件(Write),电子表格应用程序(Calc)或者幻灯片程序(Impress),请查看以下前端脚本:
 
 
 
Writer
 
  /opt/openoffice/program/swriter
 
Calc
 
  /opt/openoffice/program/scalc
 
Impress
 
  /opt/openoffice/program/simpress
 
Math (Formula Editor)
 
  /opt/openoffice/program/smath
 
Base (Database frontend)
 
  /opt/openoffice/program/sbase
 
Printer Administration (推荐以root身份运行)
 
  /opt/openoffice/program/spadmin
 
 
 
===已知问题===
 
*如果你从OOo 1.1.x升级到OOo 2.x时遇到麻烦,可以尝试:<br>
 
- 如果安装向导问你从1.1.x里获取旧配置,请拒绝。<br>
 
- 从你的<home>目录里删除旧的.openoffice*目录 <br>
 
- 从你的<home>目录里删除旧的Openoffice*目录 <br>
 
- 从你的<home>目录里删除.sversionrc <br>
 
如果OOo被象''terminate called after throwing an instance of com::sun::star::uno::RuntimeException''这样的异常错误中断,也可以尝试上述步骤。小版本号的升级,例如从OOo 2.2到2.3的时候有可能发生这种问题。<br />
 
* 在KDE中删除OOo 1.1.x的菜单项:<br>
 
- 删除 ~/.kde/share/applnk/OpenOffice* <br>
 
*如果你无法读写NFS磁盘,编辑/opt/openoffice2/program/soffice。你可能需要通过注释掉以下内容来禁止文件锁定:
 
# file locking now enabled by default
 
#SAL_ENABLE_FILE_LOCKING=1
 
#export SAL_ENABLE_FILE_LOCKING
 
 
 
*如果出现这种错误无法启动:javaldx: Could not find a Java Runtime Environment!然后出现关于初始化失败的一个文本错误对话框,请删除你的~/.openoffice2目录。
 
*如果OpenOffice.org启动失败,请查看你的/etc/X11/xorg.conf是否正确设置权限,检查你的DRI设置。
 
*如果有疑虑,以下配置应该可以正常工作的:
 
  Section "DRI"
 
  Group "users"
 
  Mode 0660
 
  EndSection
 
*或者,你不想启用DRI和及其相关设置,那么请以ROOT身份运行。
 
*如果每次OpenOffice.org运行都弹出配置向导(并且性能很糟或者老是挂起),请检查~/.openoffice2的权限设置,可能它是root所拥有的。
 
 
 
==OpenOffice.org 1.1.4 安装==
 
 
 
===安装===
 
* 下载base
 
# pacman -S openoffice-base
 
* '''你必须安装一个语言包''',否则无法运行(没有内置英文语言包)
 
# pacman -S openoffice-XX (where XX is a language)
 
* '''拼写检查'''需要额外的软件包!
 
# pacman -S openoffice-spell-XX (where XX is a language)
 
 
 
===其它===
 
KDE可以安装OpenOffice.org quickstarter
 
# pacman -S oooqs
 
 
 
===配置===
 
# 运行'/opt/openoffice/setup',为普通用户配置OpenOffice.org。
 
# 运行'soffice'启动OpenOffice.org。
 

Revision as of 10:07, 17 September 2011

This template has only maintenance purposes. For linking to local translations please use interlanguage links, see Help:i18n#Interlanguage links.


Local languages: Català – Dansk – English – Español – Esperanto – Hrvatski – Indonesia – Italiano – Lietuviškai – Magyar – Nederlands – Norsk Bokmål – Polski – Português – Slovenský – Česky – Ελληνικά – Български – Русский – Српски – Українська – עברית – العربية – ไทย – 日本語 – 正體中文 – 简体中文 – 한국어


External languages (all articles in these languages should be moved to the external wiki): Deutsch – Français – Română – Suomi – Svenska – Tiếng Việt – Türkçe – فارسی

Tango-view-refresh-red.pngThis article or section is out of date.Tango-view-refresh-red.png

Reason: please use the first argument of the template to provide a brief explanation. (Discuss in Talk:Apache OpenOffice (简体中文)#)

Arch Linux中的OpenOffice

官方已经结束了对OpenOffice.org的支持,并选择了LibreOffice。了解详情:Dropping Oracle OpenOffice (arch-general).

推荐使用LibreOffice