Difference between revisions of "Brother HL-2030"

From ArchWiki
Jump to: navigation, search
(Drivers: Condensed the foomatic drivers section, added note about HL-2035 also working (removed in a prior edit).)
(Drivers: Removed section referencing openprinting.org, since there's already a link to openprinting.org.)
Line 7: Line 7:
 
===Foomatic drivers===
 
===Foomatic drivers===
 
[[Install]] the {{pkg|foomatic-db}} and {{pkg|foomatic-db-engine}} packages.
 
[[Install]] the {{pkg|foomatic-db}} and {{pkg|foomatic-db-engine}} packages.
 
===Driver from openprinting.org===
 
For using a Brother HL-2030 printer with CUPS, and you are unsuccessful using the foomatic drivers, you might consider using the recommended HL-2030 drivers from openprinting.org. These can be found [http://www.openprinting.org/printer/Brother/Brother-HL-2030 here]. Download the hl1250 file and place it in e.g. {{ic|/usr/share/cups/model/}}.
 
 
Configure the CUPS server by the method of your choice and you should be good to go.
 
  
 
===Brother drivers===
 
===Brother drivers===
 
Alternatively, [[install]] the {{AUR|brother-hl2030}} package.
 
Alternatively, [[install]] the {{AUR|brother-hl2030}} package.

Revision as of 20:25, 10 September 2015


Drivers

This printer works with several different drivers. See openprinting.org for a full list. Note that most drivers here also should work for the Brother HL-2035 printer.

Foomatic drivers

Install the foomatic-db and foomatic-db-engine packages.

Brother drivers

Alternatively, install the brother-hl2030AUR package.