Difference between revisions of "Compiz Troubleshooting"

From ArchWiki
Jump to navigation Jump to search
(Compiz ( or Compiz-Fusion ) Troubleshooting)
Line 3: Line 3:
 
== KDE fallback ==
 
== KDE fallback ==
  
If you are using KDE and something is not right, for example you don’t see borders for your window. Simply switch back to kwin with this command:
+
If you are using KDE and something is not right, for example you don’t see borders for your window, you can switch back to kwin with this command:
  
 
   kwin --replace
 
   kwin --replace
 +
 +
== GNOME fallback ==
 +
 +
If you are using GNOME and something is not right, for example you don’t see borders for your window, you can switch back to metacity with this command:
 +
 +
metacity --replace
  
 
== Missing GLX_EXT_texture_from_pixmaps when trying to run Compiz Fusion on ATI ==
 
== Missing GLX_EXT_texture_from_pixmaps when trying to run Compiz Fusion on ATI ==

Revision as of 19:57, 1 January 2008

Compiz ( or Compiz-Fusion ) Troubleshooting

KDE fallback

If you are using KDE and something is not right, for example you don’t see borders for your window, you can switch back to kwin with this command:

 kwin --replace

GNOME fallback

If you are using GNOME and something is not right, for example you don’t see borders for your window, you can switch back to metacity with this command:

metacity --replace

Missing GLX_EXT_texture_from_pixmaps when trying to run Compiz Fusion on ATI

First solution

If you run into the following error when trying to run Compiz Fusion on an ATI card:

Missing GLX_EXT_texture_from_pixmap

This is because Compiz Fusion's binary was compiled against Mesa's OpenGL library rather than ATI's OpenGL library (which is what you are using). Re-install libgl-dri (yes you will have to uninstall fglrx temporarily) to get Mesa's OpenGL library.

copy the library into a directory to keep it because ATI's drivers will over write it.

mkdir /lib/mesa
cp /usr/lib/libGL.so.1.2 /lib/mesa

Once you have it copied, you can reinstall your fglrx drivers (It should have been removed when you installed libgl-dri). Now you can start Compiz Fusion using the following example syntax:

LD_PRELOAD=/lib/mesa/libGL.so.1.2 compiz --replace &

Second solution

An other problem could arise with GLX_EXT_texture_from_pixmap, it is possible that the card could only render it indirectly, then you have to pass the option to your libgl like that :

 LIBGL_ALWAYS_INDIRECT=1 compiz --replace ccp &

(Workaround tested on the following card : ATI Technologies Inc Radeon R250 [Mobility FireGL 9000] (rev 02))

As at 17-Oct-07 the Compiz-Fusion Wiki states: "If you are using an Intel GMA card with AIGLX, you will need to start Compiz Fusion with LIBGL_ALWAYS_INDIRECT=1 appended."

Fusion-Icon showing up as red "X" in status bar, icon missing in menus

The GTK icon cache needs to be refreshed (hopefully this will be added in the .install file of the package). Run the following command:

# gtk-update-icon-cache -f /usr/share/icons/hicolor

if this fails try installing the package hicolor-icon-theme:

# pacman -S hicolor-icon-theme

Fixed with new community package.

Compiz starts, but no effects are visible

If you have installed compiz-decorator-gtk: Check if GConf schema was correctly installed:

 gconftool-2 -R /apps/compiz/plugins | grep plugins

make sure that all plugins are listed (not only fade!). If not, try to install compiz schema manually (do this as normal user, not as root!!!):

 gconftool-2 --install-schema-file=/usr/share/gconf/schemas/compiz-decorator-gtk.schemas

Compiz starts, but gtk-window-decorator does not

It is a configuration problem for gconf and gconfd. I solved it by removing ".gconf" dir in my home, but I'm using KDE. If you are using Gnome you should enter your ".gconf" directory and remove all compiz keys. You'll loose your Compiz settings tough! Finally exec as user:

 gconftool-2 --install-schema-file=/usr/share/gconf/schemas/compiz-decorator-gtk.schemas

Blank screen on resume from suspend-to-ram using the Nvidia binary drivers

If you receive a blank screen with a responsive cursor upon resume, try disabling sync to vblank:

gconftool -s /apps/compiz/general/screen0/options/sync_to_vblank-t boolean false

fusion-icon doesn't start

If you get an output like this from the command line:

[andy@andylaptop ~]$ fusion-icon
 * Detected Session: gnome
 * Searching for installed applications...
Traceback (most recent call last):
  File "/usr/bin/fusion-icon", line 57, in <module>
    from FusionIcon.interface import choose_interface
  File "/usr/lib/python2.5/site-packages/FusionIcon/interface.py", line 23, in <module>
    import start
  File "/usr/lib/python2.5/site-packages/FusionIcon/start.py", line 36, in <module>
    config.check()
  File "/usr/lib/python2.5/site-packages/FusionIcon/util.py", line 362, in check
    os.makedirs(self.config_folder)
  File "/usr/lib/python2.5/os.py", line 172, in makedirs
    mkdir(name, mode)
OSError: [Errno 13] Permission denied: '/home/andy/.config/compiz'

the problem is with the permission on ~/.config/compiz. You have set the owner of a folder in your area as root. To change this, run (as root)

chown <username> /home/<username>/.config/compiz