Dell Inspiron N5010

From ArchWiki
Revision as of 09:05, 14 August 2011 by Gnu d (Talk | contribs) (To do)

Jump to: navigation, search

Intro

Summary

To do

  • eSata test
  • HDMI test
  • Force acpi/cpufreq to work (somehow :))
  • Need someone with wikimedia syntax skills to guide me formating this wiki page, please :).

Working

Ethernet

Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02) Works out of the box.

Wireless

Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01) In kernel 2.6 it works out of the box, but in kernel 3.0 there is no wlan0, we've to blacklist some modules.

So open "/etc/modprobe.d/modprobe.conf" and append the following line: /* Please somebody help me put the whole iwconfig output in one block :) */ blacklist bcma


now, reboot or restart the kernel.

When we issue iwconfig, it should now list wlan0:

lo        no wireless extensions.


eth0      no wireless extensions.


wlan0     IEEE 802.11bgn  ESSID:"*******"  
          Mode:Managed  Frequency:2.427 GHz  Access Point: XX:XX:XX:XX:XX:XX   
          Bit Rate=72.2 Mb/s   Tx-Power=19 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=70/70  Signal level=-32 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:968   Missed beacon:0

Bluetooth

Both pairing, sending files and receiving files works out of the box, tested with blueman.

VGA

Tested on an external CRT monitor, works out of the box on KDE 4.7.

Graphic adapter

ATI Mobility Radeon HD 5600 working out of the box.

Audio

Intel Corporation 5 Series/3400 Series Chipset High Definition Audio

Display

Available sizes:

1366x768       60.0*+
1280x720       59.9  
1152x768       59.8  
1024x768       59.9  
800x600        59.9  
848x480        59.7  
720x480        59.7  
640x480        59.4

Brightness controls work out of the box.

Suspending to disk (Hibernation)

works out of the box - tested on KDE 4.7

Suspending to ram (Sleep)

works out of the box - tested on KDE 4.7

Sensors

We got 3 sensors:

  • radeon-pci-0100
  • acpitz-virtual-0
  • acpi termal zone 0 Temperature

They work out of the box.

Partially Working

Not Working

  • Processor frequency control - says unsupported I think:

:: Setting cpufreq governing rules [BUSY] grep: /sys/devices/system/cpu/cpu* /cpufreq/scaling_available_governors: No such file or directory, cpu 0 wrong, unknown or unhandled CPU? Error setting new values. Common errors: - Do you have proper administration rights? (super-user?) - Is the governor you requested available and modprobed? - Trying to set an invalid policy? - Trying to set a specific frequency, but userspace governor is not available, for example because of hardware which cannot be set to a specific frequency or because the userspace governor isn't loaded? 1wrong, unknown or unhandled CPU? Error setting new values. Common errors: - Do you have proper administration rights? (super-user?) - Is the governor you requested available and modprobed? - Trying to set an invalid policy? - Trying to set a specific frequency, but userspace governor is not available, for example because of hardware which cannot be set to a specific frequency or because the userspace governor isn't loaded? 2wrong, unknown or unhandled CPU? Error setting new values. Common errors: - Do you have proper administration rights? (super-user?) - Is the governor you requested available and modprobed? - Trying to set an invalid policy? - Trying to set a specific frequency, but userspace governor is not available, for example because of hardware which cannot be set to a specific frequency or because the userspace governor isn't loaded? 3wrong, unknown or unhandled CPU? Error setting new values. Common errors: - Do you have proper administration rights? (super-user?) - Is the governor you requested available and modprobed? - Trying to set an invalid policy? - Trying to set a specific frequency, but userspace governor is not available, for example because of hardware which cannot be set to a specific frequency or because the userspace governor isn't loaded? [DONE]

Unknown / Untested

HDMI Video Redwood HDMI Audio 5600 eSata port

Installation

Normal installation with no issues to report.

Kernel

ATI Mobility Raedon 5600

To do: Synaptic guide

Troubleshoot

  • On boot the following error is printed:

boot error message:

intel ips 0000:00:1f.6: failed to get i915 symbols, graphics turbo disabled


Workaround:

Blacklist the intel_ips module, open configuration file "/etc/modprobe.d/modprobe.conf" and add:


blacklist intel_ips

Links

General