Difference between revisions of "Dell Vostro 1000"

From ArchWiki
Jump to: navigation, search
(changed 'synaptic' to 'synaptics' so as to be correct =))
(Backlight doesn't come back after Resume: aur template + out of date)
(14 intermediate revisions by 10 users not shown)
Line 1: Line 1:
[[Category:Laptops (English)]]
+
[[Category:Dell]]
[[Category:HOWTOs (English)]]
+
 
*'''Use Kernel 2.6.24 or greater'''
 
*'''Use Kernel 2.6.24 or greater'''
 
*'''Use install disc 2008.03 or greater (see install)'''
 
*'''Use install disc 2008.03 or greater (see install)'''
  
'''Questions:''' IM pyther24 (AIM) or diogo.urb@hotmail.com (MSN) .
+
'''Questions:''' IM diogo.urb@hotmail.com (MSN) .
  
 
=Hardware=
 
=Hardware=
Line 11: Line 10:
 
| '''Device''' || '''Status''' || '''Modules'''
 
| '''Device''' || '''Status''' || '''Modules'''
 
|-  
 
|-  
| Ati Radeon Xpress || style="color:green" | '''Working''' || fglrx (cataylst)  
+
| Ati Radeon Xpress || style="color:green" | '''Working''' || fglrx (cataylst), radeon
 
|-  
 
|-  
 
| Ethernet || style="color:green" | '''Working''' || b44  
 
| Ethernet || style="color:green" | '''Working''' || b44  
 
|-
 
|-
| Wireless || style="color:green" | '''Working''' || [http://aur.archlinux.org/packages.php?ID=19514 wl], b43, ndiswrapper
+
| Wireless || style="color:green" | '''Working''' || [https://aur.archlinux.org/packages.php?ID=19514 wl], b43, ndiswrapper
 
|-
 
|-
 
| Audio || style="color:green" | '''Working''' || snd_hda_intel
 
| Audio || style="color:green" | '''Working''' || snd_hda_intel
Line 26: Line 25:
 
|}
 
|}
  
==Problems==
+
=Problems=
*You must pass nolapic_timer as a boot option if your using kernel 2.6.26 (not needed for 2.6.27)
+
 
 +
=="Unknown Key Pressed"==
 +
* You may occasionally run across an error (occurring in an extremely high frequency) in your messages.log/dmesg:
 +
 
 +
  atkbd.c: Unknown key pressed (translated set 2, code 0xee on isa0060/serio0).
 +
  atkbd.c: Use 'setkeycodes e06e <keycode>' to make it known.
 +
 
 +
* The fix for this issue is fairly simple. Power down your dell laptop, and reseat the battery.
 +
* Another possible cause may be due to your AC adapter being unplugged from the outlet, yet attached to the back of your laptop.
 +
* Yet another suggested fix for the problem is updating your BIOS.. but since this is an extreme measure (found on the ubuntu forums.. so take it with a grain of salt), try the first two solutions before moving on to this potentially dangerous measure.
 +
 
 +
 
 +
==Legacy Kernels==
 +
*You must pass nolapic_timer as a boot option if you're using kernel 2.6.26 (not needed for 2.6.27)
 +
 
  
 
==High Temperature==
 
==High Temperature==
Line 38: Line 51:
  
 
This is because the CPU frequency is at full usage always... so before continuing with the install process install '''cpufrequtils''', you can see further details on [[Cpufrequtils]]
 
This is because the CPU frequency is at full usage always... so before continuing with the install process install '''cpufrequtils''', you can see further details on [[Cpufrequtils]]
 +
 +
* Note: using lm_sensors 'sensors' utility, k8temp-pci-00c3 reports much more reasonable temperatures (more along the lines of what windows reports) compared to this Virtual Thermal Zone. [[User:Igneous| I]] have noticed no issues running without cpu scaling while on AC.
  
 
=Installation=
 
=Installation=
Line 44: Line 59:
  
 
=Xorg=
 
=Xorg=
 +
 
==Xorg 7.4==
 
==Xorg 7.4==
 
#Install xorg <pre>pacman -S xorg</pre>
 
#Install xorg <pre>pacman -S xorg</pre>
Line 148: Line 164:
  
 
*Gnome users should be able to open up the keyboard-shortcuts and just hit the Function which they would like to use
 
*Gnome users should be able to open up the keyboard-shortcuts and just hit the Function which they would like to use
 
==Xorg <= 7.3==
 
#Install the catalyst and catalyst-utils package: <pre>pacman -Sy catalyst catalyst-utils</pre>
 
#To configure X run: <pre>X -configure</pre>
 
#Move xorg.conf to /etc/x11/xorg.conf then run <pre>aticonfig --inital -input=/etc/X11/xorg.conf</pre>
 
#Add to xorg.conf: <pre>Option     "XAANoOffscreenPixmaps" "true"</pre> Under the Video section (without out this I get black lines in the corner of screen)
 
 
===Xorg Config===
 
Section "ServerLayout"
 
  Identifier    "X.org Configured"
 
  Screen      0  "Screen[0]" 0 0
 
  InputDevice    "TouchPad" "CorePointer"
 
  InputDevice    "Mouse0" "SendCoreEvents"
 
  InputDevice    "Keyboard0" "CoreKeyboard"
 
EndSection
 
 
 
Section "Files"
 
  RgbPath      "/usr/share/X11/rgb"
 
  ModulePath  "/usr/lib/xorg/modules"
 
  FontPath    "/usr/share/fonts/misc"
 
  FontPath    "/usr/share/fonts/100dpi:unscaled"
 
  FontPath    "/usr/share/fonts/75dpi:unscaled"
 
  FontPath    "/usr/share/fonts/TTF"
 
  FontPath    "/usr/share/fonts/Type1"
 
  FontPath    "/usr/share/fonts/local"
 
EndSection
 
 
Section "Module"
 
  Load  "xtrap"
 
  Load  "record"
 
  Load  "dri"
 
  Load  "dbe"
 
  Load  "extmod"
 
  Load  "type1"
 
  Load  "freetype"
 
  Load  "glx"
 
EndSection
 
 
Section "InputDevice"
 
  Identifier  "Keyboard0"
 
  Driver      "kbd"
 
EndSection
 
 
Section "InputDevice"
 
  Identifier  "TouchPad"
 
  Driver      "synaptics"
 
  Option     "SendCoreEvents"
 
  Option     "Protocol" "auto-dev"
 
  Option     "SHMConfig" "on"
 
EndSection
 
 
Section "InputDevice"
 
  Identifier  "Mouse0"
 
  Driver      "mouse"
 
  Option     "Protocol" "auto"
 
  Option     "Device" "/dev/input/mice"
 
  Option     "ZAxisMapping" "4 5 6 7"
 
EndSection
 
 
Section "Monitor"
 
  Identifier  "Monitor[0]"
 
  Option     "VendorName" "ATI Proprietary Driver"
 
  Option     "ModelName" "Generic Autodetecting Monitor"
 
  Option     "DPMS" "true"
 
EndSection
 
 
Section "Device"
 
  Identifier  "Device[0]"
 
  Driver      "fglrx"
 
  Option      "XAANoOffscreenPixmaps" "true"
 
EndSection
 
 
Section "Screen"
 
  Identifier "Screen[0]"
 
  Device    "Device[0]"
 
  Monitor    "Monitor[0]"
 
  DefaultDepth    24
 
  SubSection "Display"
 
  Viewport  0 0
 
  Depth    24
 
  EndSubSection
 
EndSection
 
 
Section "DRI"
 
  Mode        0666
 
EndSection
 
 
 
===Touchpad (Synaptic)===
 
#Install synaptics <pre>pacman -Sy synaptics</pre>
 
#Add ''synaptics'' to the '''MODULES=()''' on '''/etc/rc.conf'''.
 
 
===Function Keys: keytouch===
 
*Install keytouch and keytouch-config <pre>pacman -Sy keytouch keytouch-editor</pre>
 
*Then copy this to /usr/share/keytouch/keyboards/Vostro 1000.Dell
 
<keyboard>
 
  <file-info>
 
    <syntax-version>1.1</syntax-version>
 
    <last-change format="%d-%m-%Y">21-01-2008</last-change>
 
    <author></author>
 
  </file-info>
 
  <keyboard-info>
 
    <keyboard-name>
 
      <manufacturer>Dell</manufacturer>
 
      <model>Vostro 1000</model>
 
    </keyboard-name>
 
  </keyboard-info>
 
  <key-list>
 
    <key>
 
      <name>Volume Up</name>
 
      <scancode>176</scancode>
 
      <keycode>VOLUMEUP</keycode>
 
      <default-action action-type="plugin">
 
        <plugin-name>Amixer</plugin-name>
 
        <plugin-function>Volume increase</plugin-function>
 
      </default-action>
 
    </key>
 
    <key>
 
      <name>Volume Down</name>
 
      <scancode>174</scancode>
 
      <keycode>VOLUMEDOWN</keycode>
 
      <default-action action-type="plugin">
 
        <plugin-name>Amixer</plugin-name>
 
        <plugin-function>Volume decrease</plugin-function>
 
      </default-action>
 
    </key>
 
    <key>
 
      <name>Mute</name>
 
      <scancode>160</scancode>
 
      <keycode>MUTE</keycode>
 
      <default-action action-type="plugin">
 
        <plugin-name>Amixer</plugin-name>
 
        <plugin-function>Mute</plugin-function>
 
      </default-action>
 
    </key>
 
    <key>
 
      <name>Eject CD</name>
 
      <scancode>137</scancode>
 
      <keycode>EJECTCD</keycode>
 
      <default-action>sudo eject /dev/cdrom</default-action>
 
    </key>
 
    <key>
 
      <name>Sleep</name>
 
      <scancode>138</scancode>
 
      <keycode>SLEEP</keycode>
 
      <default-action>sudo pm-suspend</default-action>
 
  </key>
 
  </key-list>
 
</keyboard>
 
*Then you want to start <pre>keytouch</pre>
 
*Go to the keyboard tab, click change keyboard, select the keyboard from the list. If it is not in the list, click import and select /usr/share/keytouch/keyboards/Vostro 1000.Dell, then click ok
 
*Set the actions you want the key to preform, then click apply
 
*Start /etc/rc.d/keytouchd
 
*Add keytouchd to /etc/rc.conf
 
  
 
=Wireless=
 
=Wireless=
Line 320: Line 182:
 
Broadcom's Official Binary Wireless Driver
 
Broadcom's Official Binary Wireless Driver
  
#Download the pkgbuild from Aur [[http://aur.archlinux.org/packages.php?ID=19514 here]]
+
#Download the pkgbuild from AUR: {{AUR|broadcom-wl}}
 
#Extract the pkgbuild
 
#Extract the pkgbuild
 
#Run makepkg
 
#Run makepkg
Line 329: Line 191:
  
 
{{Box Note |'''''The ssb module must be unloaded for this module to work. When the b44 (Ethernet) module gets loaded, it loads sbb. This means you can only use wireless or Ethernet with this module, not both!.'''''}}
 
{{Box Note |'''''The ssb module must be unloaded for this module to work. When the b44 (Ethernet) module gets loaded, it loads sbb. This means you can only use wireless or Ethernet with this module, not both!.'''''}}
 +
 +
{{Box Note |'''''Currently appears that you can use both, wireless and ethernet. Just make sure your wireless network is loaded before the ethernet by adding the following in your rc.conf in the MODULES section: MODULES<nowiki>=</nowiki>(!b43 wl ...) !.'''''}}
  
 
==Ndiswrapper==
 
==Ndiswrapper==
#Install ndiswrapper <pre>pacman -Sy ndiswrapper ndiswrapper-utils</pre>
+
#Install ndiswrapper <pre>pacman -S ndiswrapper ndiswrapper-utils</pre>
 
#Download Dell Wireless Drivers: <pre>http://support.dell.com/support/downloads/download.aspx?c=us&cs=04&l=en&s=bsd&releaseid=R157039&SystemID=VOS_N_1000&servicetag=&os=WLH&osl=en&deviceid=9805&devlib=0&typecnt=0&vercnt=3&catid=-1&impid=-1&formatcnt=1&libid=5&fileid=209641</pre>
 
#Download Dell Wireless Drivers: <pre>http://support.dell.com/support/downloads/download.aspx?c=us&cs=04&l=en&s=bsd&releaseid=R157039&SystemID=VOS_N_1000&servicetag=&os=WLH&osl=en&deviceid=9805&devlib=0&typecnt=0&vercnt=3&catid=-1&impid=-1&formatcnt=1&libid=5&fileid=209641</pre>
 
#Extract drivers using wine: <pre>wine R157039.EXE</pre>
 
#Extract drivers using wine: <pre>wine R157039.EXE</pre>
Line 346: Line 210:
 
* Suspend and Hibernate works with pm-utils
 
* Suspend and Hibernate works with pm-utils
 
* Also works by issuing <pre>echo mem > /sys/power/state</pre>
 
* Also works by issuing <pre>echo mem > /sys/power/state</pre>
 +
 +
==Resume not working after suspend to RAM==
 +
To workaround this issue edit the file <pre>/boot/grub/menu.lst</pre> and add the following to the kernel boot line: <pre>hpet=disable</pre>
  
 
==Backlight doesn't come back after Resume==
 
==Backlight doesn't come back after Resume==
 +
 +
{{Out of date|radeontool no longer exists}}
 +
 
You may need a workaround because the backlight doesn't come back after Resuming.
 
You may need a workaround because the backlight doesn't come back after Resuming.
  
Line 363: Line 233:
 
   ;;
 
   ;;
 
   thaw)
 
   thaw)
   echo "Suspend to disk is over, Resuming..."
+
   echo "Suspend to disk is over, Resuming. .."
 
   ;;
 
   ;;
 
   resume)
 
   resume)
Line 376: Line 246:
 
  <nowiki>#</nowiki> chmod +x /etc/pm/sleep.d/radeonlight
 
  <nowiki>#</nowiki> chmod +x /etc/pm/sleep.d/radeonlight
  
Now to make it work you need the package radeontool which is in the [http://aur.archlinux.org/packages.php?ID=2751 AUR]
+
Now to make it work you need {{AUR|radeontool}}.
  
 
And '''DONE''', you can suspend and resume with pm-utils normally.
 
And '''DONE''', you can suspend and resume with pm-utils normally.
 
  
 
=Adjust Brightness=
 
=Adjust Brightness=
 
Adjust normally with the FN Keys if your using the kernel 2.6.24 or greater
 
Adjust normally with the FN Keys if your using the kernel 2.6.24 or greater

Revision as of 12:24, 5 October 2012

  • Use Kernel 2.6.24 or greater
  • Use install disc 2008.03 or greater (see install)

Questions: IM diogo.urb@hotmail.com (MSN) .

Hardware

Device Status Modules
Ati Radeon Xpress Working fglrx (cataylst), radeon
Ethernet Working b44
Wireless Working wl, b43, ndiswrapper
Audio Working snd_hda_intel
Modem Untested
PCMCIA Slot Untested
Card Reader Working

Problems

"Unknown Key Pressed"

  • You may occasionally run across an error (occurring in an extremely high frequency) in your messages.log/dmesg:
 atkbd.c: Unknown key pressed (translated set 2, code 0xee on isa0060/serio0).
 atkbd.c: Use 'setkeycodes e06e <keycode>' to make it known.
  • The fix for this issue is fairly simple. Power down your dell laptop, and reseat the battery.
  • Another possible cause may be due to your AC adapter being unplugged from the outlet, yet attached to the back of your laptop.
  • Yet another suggested fix for the problem is updating your BIOS.. but since this is an extreme measure (found on the ubuntu forums.. so take it with a grain of salt), try the first two solutions before moving on to this potentially dangerous measure.


Legacy Kernels

  • You must pass nolapic_timer as a boot option if you're using kernel 2.6.26 (not needed for 2.6.27)


High Temperature

After the installation you will see that the temperature is around 60°C (Too High). You can get the temperature through:

cat /proc/acpi/thermal_zone/THRM/temperature

or

cat /proc/acpi/thermal_zone/THM/temperature


This is because the CPU frequency is at full usage always... so before continuing with the install process install cpufrequtils, you can see further details on Cpufrequtils

  • Note: using lm_sensors 'sensors' utility, k8temp-pci-00c3 reports much more reasonable temperatures (more along the lines of what windows reports) compared to this Virtual Thermal Zone. I have noticed no issues running without cpu scaling while on AC.

Installation

  1. Use installation disc 2008.03 or greater
  2. Follow the Beginners_Guide

Xorg

Xorg 7.4

  1. Install xorg
    pacman -S xorg
  2. Install catalyst drivers
    pacman -S catalyst catalyst-utils
  3. Install Synaptic Mouse Driver
    pacman -S xf86-input-synaptics
  4. Copy and the paste the xorg configuration below and save it /etc/X11/xorg.conf
    As of right now, Xorg 7.4 crashes when trying to auto generate (X -configure) a configuration file.
  5. Copy /usr/share/hal/fdi/policy/10osvendor/10-input-policy.fdi to /etc/hal/fdi/policy/
    No Modifications should have to be made
  6. Follow the step below for the synaptic driver

Sample xorg.conf

Section "InputDevice"
 Identifier	"Keyboard"
 Driver	"kbd"
 Option	"CoreKeyboard"
 Option	"XkbRules"	"xorg"
 Option	"XkbModel"	"pc105"
 Option	"XkbLayout"	"us"
EndSection

Section "InputDevice"
 Identifier	"Mouse0"
 Driver	"evdev"
 Option	"SencCoreEvents"
EndSection

Section "Device"
 Identifier	"Card0"
 Driver	"fglrx"
 BusID		"PCI:1:5:0"
 VendorName	"ATI Technologies Inc"
 BoardName	"RS482 [Radeon Xpress 200]"
 BusID		"PCI:1:5:0"
EndSection

Section "Monitor"
 Identifier	"LCD Display"
 Option	"DPMS"
EndSection

Section "Screen"
 Identifier	"Screen0"
 Device	"Card0"
 Monitor	"LCD Display"
 DefaultDepth	24
EndSection

Section "ServerLayout"
 Identifier	"Default Layout"
 Screen	"Screen0"
 InputDevice	"Keyboard"
 InputDevice	"Mouse0"
EndSection

Section "DRI"
 Mode    0666
EndSection

Touchpad

The following configuration gives a vertical scroll and one-tap click. Modify to suite your needs. The default file does not give you the scroll or one-tap click.

Copy /usr/share/hal/fdi/policy/10osvendor/11-x11-synaptics.fdi to /etc/hal/fdi/policy/

Edit /etc/hal/fdi/policy/11-x11-synaptics.fdi and In between

 
 <match key="info.product" contains="Synaptics TouchPad">
 <!--Insert the following here-->
 </match>

Insert:

 <merge key="input.x11_options.Emulate3Buttons"	type="string">true</merge>
 <merge key="input.x11_options.SHMConfig"	type="string">true</merge>
 <merge key="input.x11_options.HorizEdgeScroll"	type="string">false</merge>
 <merge key="input.x11_options.HorizScrollDelta"	type="string">100</merge>
 <merge key="input.x11_options.TapButton1"	type="string">1</merge>
 <merge key="input.x11_options.VertEdgeScroll"	type="string">true</merge>
 <!--
  <merge key="input.x11_options.VertScrollDelta"	type="string">100</merge>
 -->
 <merge key="input.x11_options.TapButton1"	type="string">1</merge>
 <merge key="input.x11_options.TapButton2"	type="string">2</merge>
 <merge key="input.x11_options.TapButton3"	type="string">3</merge>


Function Keys

To set the Functions keys you can use xmodmap. In xorg 7.4 the function keys are given keycodes. Xmodmap will bind the function key codes to a keysymname.

Create an .Xmodmap and put the following in:

keycode 123 = XF86AudioRaiseVolume
keycode 122 = XF86AudioLowerVolume
keycode 121 = XF86AudioMute

keycode 213 = XF86Sleep
keycode 246 = XF86Launch2
keycode 244 = XF86Launch3
keycode 170 = XF86Launch9

Next add xmodmap .Xmodmap to your start up

Then in your window manager you can bind the function key by providing the keysymname. For example in openbox I just have to pass in the key name XF86AudioMute and provide the action I want preformed when I hit that key.

  • Gnome users should be able to open up the keyboard-shortcuts and just hit the Function which they would like to use

Wireless

b43

Native Linux Driver - Works with kernels >= 2.6.25

Install b43

  1. Install b43 fwcutter
    pacman -S b43-fwcutter
  2. Download version 4.80.53.0 of Broadcom's proprietary driver.
    wget http://downloads.openwrt.org/sources/broadcom-wl-4.150.10.5.tar.bz2
  3. Unpack the compressed file.
    tar xvf broadcom-wl-4.150.10.5.tar.bz2
  4. Change the current directory to the newly created directory, and then further to the kmod folder:
    cd broadcom-wl-4.150.10.5/driver
  5. Run
    b43-fwcutter-011/b43-fwcutter -w "/lib/firmware/" wl_apsta_mimo.o
    You may have to create /lib/firmware first.
  6. Load b43
    modprobe b43
  7. Edit rc.conf and add b43
    MODULES=(... b43)

wl

Broadcom's Official Binary Wireless Driver

  1. Download the pkgbuild from AUR: broadcom-wlAUR
  2. Extract the pkgbuild
  3. Run makepkg
  4. Run pacman -U broadcom-wl-5.10.27.6-6-${arch}.tar.gz
  5. modprobe wl

If you add wl to your MODULES=(... wl) make sure you blacklist b43 (Open Wireless) and b44 (Ethernet)

Template:Box Note

Template:Box Note

Ndiswrapper

  1. Install ndiswrapper
    pacman -S ndiswrapper ndiswrapper-utils
  2. Download Dell Wireless Drivers:
    http://support.dell.com/support/downloads/download.aspx?c=us&cs=04&l=en&s=bsd&releaseid=R157039&SystemID=VOS_N_1000&servicetag=&os=WLH&osl=en&deviceid=9805&devlib=0&typecnt=0&vercnt=3&catid=-1&impid=-1&formatcnt=1&libid=5&fileid=209641
  3. Extract drivers using wine:
    wine R157039.EXE
  4. Move the drivers to your home directory
    cp -R /home/youruser/.wine/drive_c/DELL/R157039 /home/youruser/wirelessdrivers
  5. As root run:
    ndiswrapper -i bcmwl5.inf
  6. Run:
    ndiswrapper -l 
    It should show something similar to:
     bcmwl5 : driver installed device (14E4:4311) present (alternate driver: bcm43xx)
  7. Run
    modprobe ndiswrapper
  8. Add ndiswrapper to your MODULES in rc.conf

Wicd

Wicd is a network manager which allows you to connect to wireless networks very easily, you can follow this wiki page Wicd

Suspend/Hibernate

  • Suspend and Hibernate works with pm-utils
  • Also works by issuing
    echo mem > /sys/power/state

Resume not working after suspend to RAM

To workaround this issue edit the file
/boot/grub/menu.lst
and add the following to the kernel boot line:
hpet=disable

Backlight doesn't come back after Resume

Tango-view-refresh-red.pngThis article or section is out of date.Tango-view-refresh-red.png

Reason: radeontool no longer exists (Discuss in Talk:Dell Vostro 1000#)

You may need a workaround because the backlight doesn't come back after Resuming.

Install Pm-utils, and create this file:

/etc/pm/sleep.d/radeonlight
#!/bin/bash
case $1 in
 hibernate)
  echo "Suspending to disk!"
 ;;
 suspend)
  echo "Suspending to RAM"
 ;;
 thaw)
  echo "Suspend to disk is over, Resuming. .."
 ;;
 resume)
  echo "Suspend to RAM is over, Resuming..."
  radeontool light on
  radeontool dac on
 ;;
 *)  echo "somebody is calling me totally wrong."
 ;;
esac
# chmod +x /etc/pm/sleep.d/radeonlight

Now to make it work you need radeontoolAUR.

And DONE, you can suspend and resume with pm-utils normally.

Adjust Brightness

Adjust normally with the FN Keys if your using the kernel 2.6.24 or greater