Dell Vostro 1000

From ArchWiki
Revision as of 22:41, 16 September 2008 by Pyther (Talk | contribs) (Problems)

Jump to: navigation, search
  • Use Kernel 2.6.24 or greater
  • Use install disc 2008.03 or greater (see install)

Arch 32: Questions IM pyther24(aim)
Arch 64: Any questions about the vostro 1000 and Arch64, find me diogo.urb@hotmail.com (MSN) . Note: I'm working on radeon open source driver to work on 64 bit because for those who use blender... the catalyst driver don't work and keep crashing blender with segfaults... I got around 1564 FPS on glxgears and no errors, and i have dual head working... just need some ajust and fixes and I'll post here a link to the Arch ATI Xpress Wiki so that i get ok... PS: the AUR xf86-video-ati-git does not work because of missing Mesa dri... don't try it yet.

Hardware

ATI Radeon Xpress 1150: Working (xf86-video-ati and ATI Cataylst Drivers)
Ethernet: - Working (b44 module)
Wireless: - Working (b43 or ndiswrapper)
Sata Chipset - Working (PATA_ATIIXP)
Audio - Working (snd_hda_intel module)
Modem - Untested
Pcmcia Slot - Untested
Card Reader - Working

Problems

  • You must pass nolapic_timer as a boot option if your using kernel 2.6.26
  • dmesg gives MP-BIOS BUG .... and also APIC ERROR's....
solution: add on /boot/grub/menu.lst : kernel /boot/vmlinuz26 root=/dev/sda8 ro vga=0x317 nolapic_timer
Note: This decreased my temperature from 43°C to 39°C

Installation

  1. Use install disc 2008.03 or greater
    http://ftp.archlinux.org/iso/2008.03/
  2. Just follow the install guide.

Post-Install Steps

High Temperature

After the installation you will see that the temperature is around 60°C (Too High). You can get the temperature through:

cat /proc/acpi/thermal_zone/THRM/temperature

This is because the CPU frequency is at full usage always... so before continuing with the install process install cpufrequtils, you can see further details on Cpufrequtils


ATI Radeon Xpress 1150

  • The xf86-video-ati only gets around 200fps on glxgears this is very bad, so I won't cover how to install those drivers
  1. Install the catalyst and catalyst-utils package:
    pacman -Sy catalyst catalyst-utils
  2. To configure X run:
    X -configure
  3. Move xorg.conf to /etc/x11/xorg.conf then run
    aticonfig --inital -input=/etc/X11/xorg.conf
  4. Add to xorg.conf:
    Option	    "XAANoOffscreenPixmaps" "true"
    Under the Video section (without out this a I got black lines in the corner of screen)

Xorg Config

Laptop LCD Only

Section "ServerLayout"
 Identifier     "X.org Configured"
 Screen      0  "Screen[0]" 0 0
 InputDevice    "TouchPad" "CorePointer"
 InputDevice    "Mouse0" "SendCoreEvents"
 InputDevice    "Keyboard0" "CoreKeyboard"
EndSection
 
Section "Files"
 RgbPath      "/usr/share/X11/rgb"
 ModulePath   "/usr/lib/xorg/modules"
 FontPath     "/usr/share/fonts/misc"
 FontPath     "/usr/share/fonts/100dpi:unscaled"
 FontPath     "/usr/share/fonts/75dpi:unscaled"
 FontPath     "/usr/share/fonts/TTF"
 FontPath     "/usr/share/fonts/Type1"
 FontPath     "/usr/share/fonts/local"
EndSection

Section "Module"
 Load  "xtrap"
 Load  "record"
 Load  "dri"
 Load  "dbe"
 Load  "extmod"
 Load  "type1"
 Load  "freetype"
 Load  "glx"
EndSection

Section "InputDevice"
 Identifier  "Keyboard0"
 Driver      "kbd"
EndSection

Section "InputDevice"
 Identifier  "TouchPad"
 Driver      "synaptics"
 Option	    "SendCoreEvents"
 Option	    "Protocol" "auto-dev"
 Option	    "SHMConfig" "on"
EndSection

Section "InputDevice"
 Identifier  "Mouse0"
 Driver      "mouse"
 Option	    "Protocol" "auto"
 Option	    "Device" "/dev/input/mice"
 Option	    "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
 Identifier   "Monitor[0]"
 Option	    "VendorName" "ATI Proprietary Driver"
 Option	    "ModelName" "Generic Autodetecting Monitor"
 Option	    "DPMS" "true"
EndSection

Section "Device"
 Identifier  "Device[0]"
 Driver      "fglrx"
 Option      "XAANoOffscreenPixmaps" "true"
EndSection

Section "Screen"
 Identifier "Screen[0]"
 Device     "Device[0]"
 Monitor    "Monitor[0]"
 DefaultDepth     24
 SubSection "Display"
  Viewport   0 0
  Depth     24
 EndSubSection
EndSection

Section "DRI"
 Mode         0666
EndSection

Dual Monitor Enabled - Catalyst 8.3

Now here is the xorg.conf that is working on my Arch64 with the driver 8.3 (PS.: Dual Monitor Enabled) :

########### Arch Linux Catalyst X11 Config File ############ >> 8.3
Section "ServerLayout"
 Identifier     "DefaultLayout"
 Screen      0  "Screen0" 0 0
 InputDevice    "Mouse0" "CorePointer"
 InputDevice    "Mouse1" "SendCoreEvents"
 InputDevice    "Keyboard0" "CoreKeyboard"
 Option        "Clone" "off"
 Option	    "Xinerama" "off"
EndSection
Section "Files"
 RgbPath      "/usr/share/X11/rgb"
 ModulePath   "/usr/lib/xorg/modules"
 FontPath     "/usr/share/fonts/misc"
 FontPath     "/usr/share/fonts/100dpi:unscaled"
 FontPath     "/usr/share/fonts/75dpi:unscaled"
 FontPath     "/usr/share/fonts/TTF"
 FontPath     "/usr/share/fonts/Type1"
EndSection
Section "Module"
 Load  "xtrap"
 Load  "record"
 Load  "dri"
 Load  "dbe"
 Load  "ddc"
 Load  "bitmap"
 Load  "extmod"
 Load  "freetype"
 Load  "glx"
 Load  "synaptics"
EndSection
Section "ServerFlags"
 Option	    "AllowMouseOpenFail" "on"
 Option	    "IgnoreABI" "on"
 Option	    "AIGLX" "on"
EndSection
Section "InputDevice"
 Identifier  "Keyboard0"
 Driver      "kbd"
 Option	    "XkbLayout" "br"
 Option	    "XkbModel" "abnt2"
EndSection
Section "InputDevice"
 Identifier      "Mouse0"
 Driver           "synaptics"
 Option	    "Protocol" "auto-dev"
 Option	    "Device" "/dev/input/mice"
 Option	    "ZAxisMapping" "4 5"
 Option	    "Emulate3Buttons" "on"
 Option	    "SHMConfig" "on"
 Option	    "Name" "Touchpad"
 Option	    "Vendor" "Synaptics"
 Option	    "LeftEdge" "1700"
 Option	    "RightEdge" "5300"
 Option	    "TopEdge" "1700"
 Option	    "BottomEdge" "4200"
 Option	    "FingerLow" "25"
 Option      "FingerHigh" "30"
 Option	    "MaxTapTime" "180"
 Option	    "MaxTapMove" "220"
 Option	    "VertScrollDelta" "100"
 Option	    "HorizScrollDelta" "100"
 Option	    "MinSpeed" "0.06"
 Option	    "MaxSpeed" "0.12"
 Option	    "AccelFactor" "0.0010"
EndSection
Section "InputDevice"
 Identifier      "Mouse1"
 Driver           "mouse"
 Option	    "Buttons" "3"
 Option	    "Device" "/dev/input/mice"
 Option	    "Emulate3Buttons" "on"
 Option	    "Name" "Microsoft Basic Optical Mouse"
 Option	    "Protocol" "explorerps/2"
 Option	    "Vendor" "Sysp"
 Option	    "ZAxisMapping" "4 5"
EndSection
Section "Monitor"
 Identifier   "Monitor0"
 VendorName   "SEC"
 ModelName    "XU105 154X3 LCD MONITOR"
 #Option	     "DPMS"
EndSection
Section "Device"
 Identifier		        "Card0"
 Driver			"fglrx"
 VendorName		"ATI Technologies Inc"
 BoardName		"[RS482 5974] Radeon Xpress 1150"
 Option			"XaaNoOffscreenPixmaps"
 Option			"DesktopSetup" "single"
 Option			"ForceMonitors" "auto,crt1"
 Option			"EnableMonitor" "lvds"
 Option			"MaxGARTSize" "256"
 Option			"Capabilities" "0x00000000"
 Option			"CapabilitiesEx" "0x00000000"
 Option			"CenterMode" "on"
 Option			"Textured2D" "off"
 Option			"TexturedVideo" "on"
 Option			"TexturedVideoSync" "on"
 Option			"TexturedXrender" "off"
 Option			"VideoOverlay" "on"
 Option			"OpenGLOverlay" "off"
 BusID			"PCI:1:5:0"
EndSection
Section "Screen"
 Identifier "Screen0"
 Device     "Card0"
 Monitor    "Monitor0"
 DefaultDepth     24
 SubSection "Display"
  Viewport   0 0
  Depth     1
  Modes    "1280x800"
 EndSubSection
 SubSection "Display"
  Viewport   0 0
  Depth     4
  Modes    "1280x800"
 EndSubSection
 SubSection "Display"
  Viewport   0 0
  Depth     8
  Modes    "1280x800"
 EndSubSection
 SubSection "Display"
  Viewport   0 0
  Depth     15
  Modes    "1280x800"
 EndSubSection
 SubSection "Display"
  Viewport   0 0
  Depth     16
  Modes    "1280x800"
 EndSubSection
 SubSection "Display"
  Viewport   0 0
  Depth     24
  Modes    "1280x800"
 EndSubSection
EndSection
Section "DRI"
 Group        "video"
 Mode         0666
EndSection
Section "Extensions"
 Option	    "RENDER" "true"
 Option	    "DAMAGE" "true"
 Option	    "Composite" "true"
 Option	    "XVideo" "true"
EndSection

Touchpad (Synaptic)

  1. Install synaptics
    pacman -Sy synaptics
  2. Add synaptics to the MODULES=() on /etc/rc.conf.

Function Keys

keytouch

  • Install keytouch and keytouch-config
    pacman -Sy keytouch keytouch-editor
  • Then copy this to /usr/share/keytouch/keyboards/Vostro 1000.Dell
<keyboard>
  <file-info>
    <syntax-version>1.1</syntax-version>
    <last-change format="%d-%m-%Y">21-01-2008</last-change>
    <author></author>
  </file-info>
  <keyboard-info>
    <keyboard-name>
      <manufacturer>Dell</manufacturer>
      <model>Vostro 1000</model>
    </keyboard-name>
  </keyboard-info>
  <key-list>
    <key>
      <name>Volume Up</name>
      <scancode>176</scancode>
      <keycode>VOLUMEUP</keycode>
      <default-action action-type="plugin">
        <plugin-name>Amixer</plugin-name>
        <plugin-function>Volume increase</plugin-function>
      </default-action>
    </key>
   <key>
     <name>Volume Down</name>
     <scancode>174</scancode>
     <keycode>VOLUMEDOWN</keycode>
     <default-action action-type="plugin">
       <plugin-name>Amixer</plugin-name>
       <plugin-function>Volume decrease</plugin-function>
     </default-action>
   </key>
   <key>
     <name>Mute</name>
     <scancode>160</scancode>
     <keycode>MUTE</keycode>
     <default-action action-type="plugin">
       <plugin-name>Amixer</plugin-name>
       <plugin-function>Mute</plugin-function>
     </default-action>
   </key>
   <key>
     <name>Eject CD</name>
     <scancode>137</scancode>
     <keycode>EJECTCD</keycode>
     <default-action>sudo eject /dev/cdrom</default-action>
   </key>
   <key>
     <name>Sleep</name>
     <scancode>138</scancode>
     <keycode>SLEEP</keycode>
     <default-action>sudo pm-suspend</default-action>
  </key>
 </key-list>
</keyboard>
  • Then you want to start
    keytouch
  • Go to the keyboard tab, click change keyboard, select the keyboard from the list. If it is not in the list, click import and select /usr/share/keytouch/keyboards/Vostro 1000.Dell, then click ok
  • Set the actions you want the key to preform, then click apply
  • Start /etc/rc.d/keytouchd
  • Add keytouchd to /etc/rc.conf

Wireless

b43

Native Linux Driver - Works with kernel 2.6.25

Install b43

  1. Install b43 fwcutter
    pacman -S b43-fwcutter
  2. Download version 4.80.53.0 of Broadcom's proprietary driver.
    wget http://downloads.openwrt.org/sources/broadcom-wl-4.80.53.0.tar.bz2
  3. Unpack the compressed file.
    tar xjf broadcom-wl-4.80.53.0.tar.bz2
  4. Change the current directory to the newly created directory, and then further to the kmod folder:
    cd broadcom-wl-4.80.53.0/kmod
  5. Run
    b43-fwcutter-011/b43-fwcutter -w "/lib/firmware/" wl_apsta.o
    You may have to create /lib/firmware first.
  6. Load b43
    modprobe b43
  7. Edit rc.conf and add b43
    MODULES=(... b43)

Note : Even though the kernel is 2.6.25 and so the firmware version should be 4.150.5, if you use the new firmware you'll experience nertwork downs... use the 4.80.53.0 instead

Ndiswrapper

  1. Install ndiswrapper
    pacman -Sy ndiswrapper ndiswrapper-utils
  2. Download Dell Wireless Drivers:
    http://support.dell.com/support/downloads/download.aspx?c=us&cs=04&l=en&s=bsd&releaseid=R157039&SystemID=VOS_N_1000&servicetag=&os=WLH&osl=en&deviceid=9805&devlib=0&typecnt=0&vercnt=3&catid=-1&impid=-1&formatcnt=1&libid=5&fileid=209641
  3. Extract drivers using wine:
    wine R157039.EXE
  4. Move the drivers to your home directory
    cp -R /home/youruser/.wine/drive_c/DELL/R157039 /home/youruser/wirelessdrivers
  5. As root run:
    ndiswrapper -i bcmwl5.inf
  6. Run:
    ndiswrapper -l 
    It should show something similar to:
     bcmwl5 : driver installed device (14E4:4311) present (alternate driver: bcm43xx)
  7. Run
    modprobe ndiswrapper
  8. Add ndiswrapper to your MODULES in rc.conf

Wicd

Wicd is a network manager which allows you to connect to wireless networks very easily, you can follow this wiki page Wicd

Suspend/Hibernate

  • Suspend and Hibernate works with pm-utils
  • Also works by issuing
    echo mem > /sys/power/state

Backlight doesn't come back after Resume

You may need a workaround because the backlight doesn't come back after Resuming.

Install Pm-utils, and create this file:

/etc/pm/sleep.d/radeonlight
#!/bin/bash
case $1 in
 hibernate)
  echo "Suspending to disk!"
 ;;
 suspend)
  echo "Suspending to RAM"
 ;;
 thaw)
  echo "Suspend to disk is over, Resuming..."
 ;;
 resume)
  echo "Suspend to RAM is over, Resuming..."
  radeontool light on
  radeontool dac on
 ;;
 *)  echo "somebody is calling me totally wrong."
 ;;
esac
# chmod +x /etc/pm/sleep.d/radeonlight

Now to make it work you need the package radeontool which is in the AUR

And DONE, you can suspend and resume with pm-utils normally.


Adjust Brightness

Adjust normally with the FN Keys if your using the kernel 2.6.24 or greater