Difference between revisions of "DeveloperWiki:Repo Cleanup"

From ArchWiki
Jump to: navigation, search
(cleanup)
(Updated)
Line 14: Line 14:
 
This packages will be moved to Unsupported, if you want to maintain a package in [community] DO NOT cross it out, but add it to [[ArchWiki DeveloperWiki:Repo_Cleanup#Candidate_to_.5Bcommunity.5D | this list]]
 
This packages will be moved to Unsupported, if you want to maintain a package in [community] DO NOT cross it out, but add it to [[ArchWiki DeveloperWiki:Repo_Cleanup#Candidate_to_.5Bcommunity.5D | this list]]
  
* 3ddesktop
+
* abcde
* <s>aalib</s> - needed by gphoto2, gstreamer-0.10-good-plugins, mplayer, mplayer-vaapi, xaos, xawtv
+
* <s>archlinux-artwork</s> - artwork
* abuse
+
* <s>archlinux-themes-slim</s> - artwork
* acct - needed by bootchart (orphan)
+
* <s>archlinux-wallpaper</s> - artwork
* acidrip
+
* aria2
* afterstep
+
* artwiz-fonts
* agg
+
* <s>aspell-*</s> - languages support
* alltray
+
* <s>atkmm-docs</s> - part of the atkmm package
* antiword
 
* arch
 
* <s>arj</s> - needed by fileroller, squeeze, xarchiver
 
* <s>at</s>
 
* <s>at-spi2-atk</s>
 
* <s>at-spi2-core</s>
 
* <s>aubio</s> - needed by ardour
 
 
* <s>aufs2</s> - needed by aufs2-util
 
* <s>aufs2</s> - needed by aufs2-util
* autofs
+
* banshee
* biogrep
+
* bladeenc
* biopython
+
* bs
* <s>bittorrent</s> - needed by archboot
+
* chrootkit
* blassic
+
* chromium
* bomberclone
+
* clang-analyzer
* bonnie++
+
* cscope
* bootchart
+
* dosbox
* <s>botan</s> - needed by monotone
+
* <s>eog-plugins</s> - recently updated, ioni/heftig should adopt it
* <s>brltty</s> - keep this for blind users, Andrea
+
* eric4-plugins
* <s>btrfs-progs-unstable</s> - needed by archboot
+
* ettercap-gtk
* came
+
* <s>festival-english</s> - voices for festival
* ccrtp - needed by libzrtpcpp (orphan)
+
* <s>festival-us</s> - voices for festival
* ccscript3
+
* gcdmaster
* cdcd
+
* gnome-alsamixer
* cddb_get
+
* gnupod
* cdlabelgen - needed by gcombust (orphan)
+
* <s>gperf</s> - makedependence of various packages
* cdtool - needed by tcdr (orphan)
+
* gptfdisk
* centerim
+
* gqmpeg
* chntpw
+
* gtk-theme-switch2
* colortail
+
* <s>gtkmm3-docs</s> - parf ot the gtkmm3 package
* commoncpp2 - needed by ccrtp, ccscript3, twinkle (orphans)
+
* <s>haskell-platform</s> - up to Vesa
* corewars
 
* cpudyn
 
* cpufreqd
 
* crimson
 
* cssed
 
* culmus
 
* <s>cvs</s> - needed by a lot of packages
 
* <s>cvsps</s> - needed by git
 
* <s>cx_freeze</s> - needed by eric-plugins
 
* dbh
 
* <s>dconf</s> - needed by nautilus-sendto, empathy, gnome-bluetooth, evince...
 
* devil
 
* dia
 
* ding
 
* distcc
 
* dmenu
 
* dopewars
 
* dvdbackup
 
* eboard
 
* ed2k-gtk-gui
 
* <s>eject</s> - needed by hal, oxine
 
* elinks
 
* enigma
 
* epdfview
 
* <s>ethstatus</s>
 
* evms
 
* <s>fcgi</s> - needed by lighttpd
 
* <s>fcitx</s> - needed by kdeplasma-addons
 
* <s>festival</s> - needed by gnome-speech
 
* <s>festival-english</s> - voices support to festival
 
* <s>festival-us</s> - voices support to festival
 
* fftw2
 
* <s>figlet</s>
 
* flite
 
* <s>folks</s> - needed by empathy
 
* <s>fsarchiver</s> - needed by archboot
 
* galculator
 
* gcal
 
* gcombust
 
* <s>gd</s> - needed by mrtg, ntop, pstoedit, texlive-bin, amule, libgphoto2...
 
* gdeskcal
 
* gdesklets
 
* gdk-pixbuf - needed by xosd, gtk-smooth-engine (orphans)
 
* <s>gdome2</s> - needed by gmetadom
 
* gift - needed by gift-fasttrack, gift-gnutella, gift-openft
 
* gift-fasttrack
 
* gift-gnutella
 
* gift-openft
 
* gimp-fourier
 
* glabels
 
* gmencoder
 
* <s>gmpc</s>
 
* <s>gnokii</s> - needed by gnome-phone-manager
 
* gnomeicu
 
* gocr
 
* gpart
 
* <s>gperf</s> - needed by a lot of packages
 
* graveman
 
* gtick
 
* gtk1-engines
 
* gtkam
 
* gtklp
 
* gtk-smooth-engine
 
* gtkterm
 
* gtk-theme-switch
 
* <s>gtk-vnc</s> - needed by vinagree
 
* <s>gweled</s>
 
* gxine
 
* <s>haskell-binary</s> - up to Vesa
 
* <s>haskell-cgi</s> - up to Vesa
 
* <s>haskell-mtl</s> - up to Vesa
 
* <s>haskell-network</s> - up to Vesa
 
* <s>haskell-regex-compat</s> - up to Vesa
 
 
* <s>haskell-tar</s> - up to Vesa
 
* <s>haskell-tar</s> - up to Vesa
* <s>haskell-text</s> - up to Vesa
+
* <s>hunspell-hu</s> - languages support
* hexcurse
+
* <s>hunspell-ln</s> - languages support
* hping
+
* <s>hyphen-hu</s> - languages support
* <s>httplib2</s> - needed by totem
+
* <s>hyphen-nl</s> - languages support
* httptunnel
+
* icecast
* httrack
 
* hugs98
 
* icmake - needed by yodl (orphan)
 
* <s>ilmbase</s> - needed by openexr
 
 
* <s>imap</s> - needed by php
 
* <s>imap</s> - needed by php
* imwheel
+
* ipod-sharp
* <s>iptraf</s>
+
* iptraf-ng
* ipvsadm
+
* <s>ispell</s> - needed by hunspell-de
* irda-utils
+
* <s>kernel26-manpages</s> - part of the kernel26 package
* <s>jade</s> - needed by gtk-doc
+
* kmldonkey
* jed
+
* kmplayer
* joe
+
* krusader
* jpilot
+
* <s>laptop-mode-tools</s> - keep this, Andrea
* <s>json-glib</s> - needed by rhythmbox
+
* libbtctl
* <s>kdelibs3</s> - needed by qalculate-kde, labplot, ksensors
+
* llvm-ocaml
* lesstifextensions
+
* ltrace
* <s>lha</s> - needed by squeeze, xarchiver
+
* <s>mailman</s> - keep this, Andrea
* <s>libchewing</s> - needed by scim-chewing
+
* mc
* <s>libdvdcss</s> - needed by acidrip, libdvdread
+
* meld
* libexif-gtk - needed by gtkam (orphan)
+
* <s>mm-common</s> - needed by gtkmm3
* <s>libffi</s> - needed by ruby, librep
+
* monotone
* <s>libfm</s> - needed by pcmanfm
+
* <s>mythes-hu</s> - languages support
* <s>libftdi</s> - needed by lirc-utils
+
* <s>mythes-nl</s> - languages support
* <s>libhangul</s> - needed by scim-hangul
+
* nbsmtp
* <s>libieee1284</s> - needed by sane
+
* nickle
* libixp
+
* nppangband
* <s>liblo</s> - needed by dssi, ardour, ecasound
+
* numlockx
* <s>liblqr</s> - needed by digikam
+
* <s>obconf</s> - keep this for OpenBox users, Andrea
* <s>libmad</s> - needed by a lot of packages
+
* perl-text-csv
* libmal
+
* <s>perl-text-patch</s> - needed by perl-alien-sdl
* <s>libmcs</s> - needed by audacious
+
* proftpd
* <s>libmodplug</s> - needed by moc, mpd, vlc
+
* python-gtkglext
* <s>libmowgli</s> - needed by libmcs, libguess
+
* <s>qt3-doc</s> - part of the qt3 package
* <s>libmp4v2</s> - needed by cmus, faac, easytag, tunepimp
+
* <s>ruby-docs</s> - part of the ruby package
* libmusepack
+
* <s>slim-themes</s> - themes for slim
* <s>libnet</s> - needed by ettercap, ettercap-gtk
+
* speedcrunch
* libnids
+
* tango-icon-theme-extras
* libnjb
 
* <s>libots</s> - needed by abiword
 
* librep - needed by rep-gtk (orphan)
 
* libsexymm
 
* libvisual-projectm
 
* <s>libwpg</s> - needed by abiword, libreoffice
 
* <s>libx86</s> - needed by vbetool
 
* libzrtpcpp - needed by twinkle (orphan)
 
* lincity
 
* linuxdcpp
 
* <s>linux_logo</s>
 
* <s>ltrace</s> - it's on gerolde so I guess we should keep it, Eric
 
* luola
 
* <s>lynx</s> - needed by xdg-utils
 
* <s>lzop</s> - needed by squeeze, xarchiver
 
* <s>mailman</s> - it's on gerolde so I guess we should keep it, Andrea
 
* <s>mcrypt</s>
 
* <s>memtest86+</s> - needed by archboot
 
* <s>mod_fastcgi</s> - apache module we'd be stupid not to provide
 
* <s>mod_wsgi</s> - apache module we'd be stupid not to provide
 
* <s>monotone</s>
 
* moon-buggy
 
* moon-lander
 
* <s>most</s>
 
* motion
 
* mp3blaster
 
* mrxvt
 
* <s>mysql</s> - needed by akonadi, amarok,...
 
* <s>mysql-python</s> - needed by django
 
* ne
 
* <s>netkit-bsd-finger</s> - needed by gnome-nettool
 
* <s>netpbm</s> - needed by groff in [core]
 
* netselect
 
* <s>net-snmp</s> - needed by php, fwbuilder, foomatic...
 
* ngrep
 
* <s>nickle</s> - needed by xorg-xrandr
 
* <s>nouveau-drm-lts</s> - needed by archboot
 
* <s>nss-mdns</s> - needed by avahi
 
* ntop
 
* nvclock
 
* <s>opengtl</s> - needed by koffice
 
* <s>openldap</s> - needed by kdepimlibs
 
* <s>opensp</s> - needed by iputils in [core], epiphan-extensions
 
* pal
 
* pan
 
* parprouted
 
* patchutils
 
* pebrot
 
* <s>perl-mail-spf</s> - needed by spamassassin
 
* <s>perl-xml-parser</s> - needed by intltool, perl-xml-simple, perl-soap-lite
 
* pinball
 
* planner
 
* prboom
 
* prelink
 
* privoxy
 
* projectm - needed by libvisual-projectm (orphan)
 
* pure-ftpd
 
* <s>putty</s>
 
* pyogg - needed by pyvorbis (orphan)
 
* python-cheetah
 
* python-eyed3
 
* <s>python-formencode</s> - needed by python-sqlobject
 
* <s>python-geoip</s> - needed by nicotine
 
* <s>python-m2crypto</s> - needed by crda in [core]
 
* <s>python-nose</s> - needed by vigra, python-numpy
 
* python-sqlobject - needed by pacbuild (orphan)
 
* python-vpython
 
* pyvorbis
 
* <s>pyxml</s> - needed by python-soappy, inkscape
 
* qgit
 
* qof
 
* qstat - needed by xqf (orphan)
 
* <s>qt3</s> - needed by a lot of packages
 
* <s>qt3-doc</s> - keep documentation for qt3, Andrea
 
* quilt
 
* <s>razor</s> - needed by spamassassin
 
* rbldnsd
 
* <s>re2c</s> - needed by spamassassin
 
* rep-gtk - needed by sawfish (orphan)
 
* revelation
 
* rockdodger
 
* root-tail
 
* rpmunpack
 
* <s>ruby</s> - needed by kdebindings-ruby
 
* <s>ruby-docs</s> - keep documentation for ruby, Andrea
 
* sawfish
 
* screem
 
* seed
 
* <s>sharutils</s> - needed by madwifi
 
* silly
 
* <s>slang</s> - needed by mc, jed, most, mutt
 
* <s>slib</s> - needed by gnucash
 
* <s>slim-themes</s> - keep themes for slim, Andrea
 
* slmodem
 
* slmodem-utils
 
* smtpprox
 
* <s>snarf</s> - needed by archboot
 
* spamassassin-spamc
 
* spidermonkey - needed by elinks, gxine (orphans)
 
* squashfs-tools
 
* <s>ssmtp</s> - needed by at
 
* swatch
 
* sylpheed
 
* synergy
 
* <s>talloc</s> - needed by samba
 
* tcdr
 
* tcptraceroute
 
* tcsh
 
* <s>telepathy-logger</s> - needed by empathy
 
 
* <s>texi2html</s> - needed by qemu
 
* <s>texi2html</s> - needed by qemu
* thttpd
+
* ttf-cheapskate
* <s>time</s> - needed by hdf5
 
* tin
 
* tor
 
* tpb
 
* <s>transcode</s> - needed by dvdrip, dvdrtools
 
* transset
 
 
* <s>ttf-fireflysung</s> - keep this for i18n support, Eric
 
* <s>ttf-fireflysung</s> - keep this for i18n support, Eric
* ttf-isabella
 
 
* <s>ttf-tibetan-machine</s> - keep this for i18n support, Eric
 
* <s>ttf-tibetan-machine</s> - keep this for i18n support, Eric
 
* <s>ttf-ubraille</s> - keep this for blind users, Andrea
 
* <s>ttf-ubraille</s> - keep this for blind users, Andrea
* twinkle
+
* vbetool
* ubuntulooks
+
* vim-a
* uml_utilities
+
* vim-bufexplorer
* unarj
+
* vim-colorsamplerpack
* <s>unzip</s> - needed by a lot of packages
+
* vim-doxygentoolkit
* <s>v86d</s> - needed by archboot
+
* vim-guicolorscheme
* vacation
+
* vim-minibufexpl
* <s>vbetool</s> - needed by pm-utils
+
* vim-omnicppcomplete
* <s>vcdimager</s> - needed by xine-lib
+
* vim-project
* vconfig
+
* vim-taglist
* viewglob
+
* vim-vcscommand
* <s>w3m</s>
+
* vim-workspace
* webalizer
+
* xchat-gnome
* <s>wipe</s> - needed by archboot
 
* wmii
 
* wmix
 
* words
 
* wput
 
* <s>wvstreams</s> - needed by wvdial
 
* x2vnc
 
* <s>xbill</s>
 
* xbl
 
* xboard
 
* xdialog
 
* xdrawchem
 
* xemacs
 
* xemacs-base
 
* xemacs-sumo
 
 
* <s>xf86-input-wacom</s> - up to Jan
 
* <s>xf86-input-wacom</s> - up to Jan
* xfsdump
+
* <s>xorg-xfontsel</s> - up to Jan
* <s>xmahjongg</s>
+
* <s>xorg-xlsfonts</s> - up to Jan
 
* <s>xorg-xvidtune</s> - up to Jan
 
* <s>xorg-xvidtune</s> - up to Jan
* xosd - needed by tpd (orphan)
 
* <s>xpdf</s>
 
* <s>xpdf-*</s>
 
* <s>xplc</s> - needed by wvstreams
 
* xpyb
 
* xqf
 
* xskat
 
* xtermcontrol
 
* xzgv
 
* <s>yasm</s> - needed by a lot of packages
 
* yodl
 
* <s>zip</s> - needed by a lot of packages
 
* <s>zvbi</s> - needed by vlc
 
  
 
== Candidate to [community] ==
 
== Candidate to [community] ==

Revision as of 17:35, 3 May 2011


Extra package cleanup

Goals and ideas

  • A cleanup of the extra repository
  • Currently we have 441 orphans packages in [extra] (any, i686, x86_64)
  • Reduce the packaging work load of the developers
  • Minimise the number of apps per task
  • TUs are easier to appoint and find, it makes sense to move some of the workload to the community repo
  • Games should all go to community (except those that come with KDE and Gnome)

Packages list

This packages will be moved to Unsupported, if you want to maintain a package in [community] DO NOT cross it out, but add it to this list

  • abcde
  • archlinux-artwork - artwork
  • archlinux-themes-slim - artwork
  • archlinux-wallpaper - artwork
  • aria2
  • artwiz-fonts
  • aspell-* - languages support
  • atkmm-docs - part of the atkmm package
  • aufs2 - needed by aufs2-util
  • banshee
  • bladeenc
  • bs
  • chrootkit
  • chromium
  • clang-analyzer
  • cscope
  • dosbox
  • eog-plugins - recently updated, ioni/heftig should adopt it
  • eric4-plugins
  • ettercap-gtk
  • festival-english - voices for festival
  • festival-us - voices for festival
  • gcdmaster
  • gnome-alsamixer
  • gnupod
  • gperf - makedependence of various packages
  • gptfdisk
  • gqmpeg
  • gtk-theme-switch2
  • gtkmm3-docs - parf ot the gtkmm3 package
  • haskell-platform - up to Vesa
  • haskell-tar - up to Vesa
  • hunspell-hu - languages support
  • hunspell-ln - languages support
  • hyphen-hu - languages support
  • hyphen-nl - languages support
  • icecast
  • imap - needed by php
  • ipod-sharp
  • iptraf-ng
  • ispell - needed by hunspell-de
  • kernel26-manpages - part of the kernel26 package
  • kmldonkey
  • kmplayer
  • krusader
  • laptop-mode-tools - keep this, Andrea
  • libbtctl
  • llvm-ocaml
  • ltrace
  • mailman - keep this, Andrea
  • mc
  • meld
  • mm-common - needed by gtkmm3
  • monotone
  • mythes-hu - languages support
  • mythes-nl - languages support
  • nbsmtp
  • nickle
  • nppangband
  • numlockx
  • obconf - keep this for OpenBox users, Andrea
  • perl-text-csv
  • perl-text-patch - needed by perl-alien-sdl
  • proftpd
  • python-gtkglext
  • qt3-doc - part of the qt3 package
  • ruby-docs - part of the ruby package
  • slim-themes - themes for slim
  • speedcrunch
  • tango-icon-theme-extras
  • texi2html - needed by qemu
  • ttf-cheapskate
  • ttf-fireflysung - keep this for i18n support, Eric
  • ttf-tibetan-machine - keep this for i18n support, Eric
  • ttf-ubraille - keep this for blind users, Andrea
  • vbetool
  • vim-a
  • vim-bufexplorer
  • vim-colorsamplerpack
  • vim-doxygentoolkit
  • vim-guicolorscheme
  • vim-minibufexpl
  • vim-omnicppcomplete
  • vim-project
  • vim-taglist
  • vim-vcscommand
  • vim-workspace
  • xchat-gnome
  • xf86-input-wacom - up to Jan
  • xorg-xfontsel - up to Jan
  • xorg-xlsfonts - up to Jan
  • xorg-xvidtune - up to Jan

Candidate to [community]

Progress

Moved to community

Moved to unsupported

Issues