DeveloperWiki:Repo Cleanup

From ArchWiki
Revision as of 15:38, 13 November 2010 by BaSh (Talk | contribs) (Moved to unsupported)

Jump to: navigation, search


Extra package cleanup

Goals and ideas

  • A cleanup of the extra repository
  • Currently we have 352 orphans packages in [extra]
  • Reduce the packaging work load of the developers
  • Minimise the number of apps per task
  • TUs are easier to appoint and find, it makes sense to move some of the workload to the community repo
  • Games should all go to community (except those that come with KDE and Gnome)

Packages list

This packages will be moved to Unsupported, if you want to maintain a package in [community] DO NOT cross it out, but add it to this list

  • 3ddesktop
  • aalib - needed by gphoto2, gstreamer-0.10-good-plugins, mplayer, mplayer-vaapi, xaos, xawtv
  • abuse
  • acct - needed by bootchart (orphan)
  • acidrip
  • afterstep
  • agg
  • alltray
  • antiword
  • arch
  • arj - needed by fileroller, squeeze, xarchiver
  • at
  • at-spi2-atk
  • at-spi2-core
  • aubio - needed by ardour
  • aufs2 - needed by aufs2-util
  • autofs
  • biogrep
  • biopython
  • bittorrent - needed by archboot
  • blassic
  • bomberclone
  • bonnie++
  • bootchart
  • botan - needed by monotone
  • brltty - keep this for blind users, Andrea
  • btrfs-progs-unstable - needed by archboot
  • came
  • ccrtp - needed by libzrtpcpp (orphan)
  • ccscript3
  • cdcd
  • cddb_get
  • cdlabelgen - needed by gcombust (orphan)
  • cdtool - needed by tcdr (orphan)
  • centerim
  • chntpw
  • colortail
  • commoncpp2 - needed by ccrtp, ccscript3, twinkle (orphans)
  • corewars
  • cpudyn
  • cpufreqd
  • crimson
  • cssed
  • culmus
  • cvs - needed by a lot of packages
  • cvsps - needed by git
  • cx_freeze - needed by eric-plugins
  • dbh
  • dconf - needed by nautilus-sendto, empathy, gnome-bluetooth, evince...
  • devil
  • dia
  • ding
  • distcc
  • dmenu
  • dopewars
  • dvdbackup
  • eboard
  • ed2k-gtk-gui
  • eject - needed by hal, oxine
  • elinks
  • enigma
  • epdfview
  • ethstatus
  • evms
  • fcgi - needed by lighttpd
  • fcitx - needed by kdeplasma-addons
  • festival - needed by gnome-speech
  • festival-english - voices support to festival
  • festival-us - voices support to festival
  • fftw2
  • figlet
  • flite
  • folks - needed by empathy
  • fsarchiver - needed by archboot
  • galculator
  • gcal
  • gcombust
  • gd - needed by mrtg, ntop, pstoedit, texlive-bin, amule, libgphoto2...
  • gdeskcal
  • gdesklets
  • gdk-pixbuf - needed by xosd, gtk-smooth-engine (orphans)
  • gdome2 - needed by gmetadom
  • gift - needed by gift-fasttrack, gift-gnutella, gift-openft
  • gift-fasttrack
  • gift-gnutella
  • gift-openft
  • gimp-fourier
  • glabels
  • gmencoder
  • gmpc
  • gnokii - needed by gnome-phone-manager
  • gnomeicu
  • gocr
  • gpart
  • gperf - needed by a lot of packages
  • graveman
  • gtick
  • gtk1-engines
  • gtkam
  • gtklp
  • gtk-smooth-engine
  • gtkterm
  • gtk-theme-switch
  • gtk-vnc - needed by vinagree
  • gweled
  • gxine
  • haskell-binary - up to Vesa
  • haskell-cgi - up to Vesa
  • haskell-mtl - up to Vesa
  • haskell-network - up to Vesa
  • haskell-regex-compat - up to Vesa
  • haskell-tar - up to Vesa
  • haskell-text - up to Vesa
  • hexcurse
  • hping
  • httplib2 - needed by totem
  • httptunnel
  • httrack
  • hugs98
  • icmake - needed by yodl (orphan)
  • ilmbase - needed by openexr
  • imap - needed by php
  • imwheel
  • iptraf
  • ipvsadm
  • irda-utils
  • jade - needed by gtk-doc
  • jed
  • joe
  • jpilot
  • json-glib - needed by rhythmbox
  • kdelibs3 - needed by qalculate-kde, labplot, ksensors
  • lesstifextensions
  • lha - needed by squeeze, xarchiver
  • libchewing - needed by scim-chewing
  • libdvdcss - needed by acidrip, libdvdread
  • libexif-gtk - needed by gtkam (orphan)
  • libffi - needed by ruby, librep
  • libfm - needed by pcmanfm
  • libftdi - needed by lirc-utils
  • libhangul - needed by scim-hangul
  • libieee1284 - needed by sane
  • libixp
  • liblo - needed by dssi, ardour, ecasound
  • liblqr - needed by digikam
  • libmad - needed by a lot of packages
  • libmal
  • libmcs - needed by audacious
  • libmodplug - needed by moc, mpd, vlc
  • libmowgli - needed by libmcs, libguess
  • libmp4v2 - needed by cmus, faac, easytag, tunepimp
  • libmusepack
  • libnet - needed by ettercap, ettercap-gtk
  • libnids
  • libnjb
  • libots - needed by abiword
  • librep - needed by rep-gtk (orphan)
  • libsexymm
  • libvisual-projectm
  • libwpg - needed by abiword, libreoffice
  • libx86 - needed by vbetool
  • libzrtpcpp - needed by twinkle (orphan)
  • lincity
  • linuxdcpp
  • linux_logo
  • ltrace - it's on gerolde so I guess we should keep it, Eric
  • luola
  • lynx - needed by xdg-utils
  • lzop - needed by squeeze, xarchiver
  • mailman - it's on gerolde so I guess we should keep it, Andrea
  • mcrypt
  • memtest86+ - needed by archboot
  • mod_fastcgi - apache module we'd be stupid not to provide
  • mod_wsgi - apache module we'd be stupid not to provide
  • monotone
  • moon-buggy
  • moon-lander
  • most
  • motion
  • mp3blaster
  • mrxvt
  • mysql - needed by akonadi, amarok,...
  • mysql-python - needed by django
  • ne
  • netkit-bsd-finger - needed by gnome-nettool
  • netpbm - needed by groff in [core]
  • netselect
  • net-snmp - needed by php, fwbuilder, foomatic...
  • ngrep
  • nickle - needed by xorg-xrandr
  • nouveau-drm-lts - needed by archboot
  • nss-mdns - needed by avahi
  • ntop
  • nvclock
  • opengtl - needed by koffice
  • openldap - needed by kdepimlibs
  • opensp - needed by iputils in [core], epiphan-extensions
  • pal
  • pan
  • parprouted
  • patchutils
  • pebrot
  • perl-mail-spf - needed by spamassassin
  • perl-xml-parser - needed by intltool, perl-xml-simple, perl-soap-lite
  • pinball
  • planner
  • prboom
  • prelink
  • privoxy
  • projectm - needed by libvisual-projectm (orphan)
  • pure-ftpd
  • putty
  • pyogg - needed by pyvorbis (orphan)
  • python-cheetah
  • python-eyed3
  • python-formencode - needed by python-sqlobject
  • python-geoip - needed by nicotine
  • python-m2crypto - needed by crda in [core]
  • python-nose - needed by vigra, python-numpy
  • python-sqlobject - needed by pacbuild (orphan)
  • python-vpython
  • pyvorbis
  • pyxml - needed by python-soappy, inkscape
  • qgit
  • qof
  • qstat - needed by xqf (orphan)
  • qt3 - needed by a lot of packages
  • qt3-doc - keep documentation for qt3, Andrea
  • quilt
  • razor - needed by spamassassin
  • rbldnsd
  • re2c - needed by spamassassin
  • rep-gtk - needed by sawfish (orphan)
  • revelation
  • rockdodger
  • root-tail
  • rpmunpack
  • ruby - needed by kdebindings-ruby
  • ruby-docs - keep documentation for ruby, Andrea
  • sawfish
  • screem
  • seed
  • sharutils - needed by madwifi
  • silly
  • slang - needed by mc, jed, most, mutt
  • slib - needed by gnucash
  • slim-themes - keep themes for slim, Andrea
  • slmodem
  • slmodem-utils
  • smtpprox
  • snarf - needed by archboot
  • spamassassin-spamc
  • spidermonkey - needed by elinks, gxine (orphans)
  • squashfs-tools
  • ssmtp - needed by at
  • swatch
  • sylpheed
  • synergy
  • talloc - needed by samba
  • tcdr
  • tcptraceroute
  • tcsh
  • telepathy-logger - needed by empathy
  • texi2html - needed by qemu
  • thttpd
  • time - needed by hdf5
  • tin
  • tor
  • tpb
  • transcode - needed by dvdrip, dvdrtools
  • transset
  • ttf-fireflysung - keep this for i18n support, Eric
  • ttf-isabella
  • ttf-tibetan-machine - keep this for i18n support, Eric
  • ttf-ubraille - keep this for blind users, Andrea
  • twinkle
  • ubuntulooks
  • uml_utilities
  • unarj
  • unzip - needed by a lot of packages
  • v86d - needed by archboot
  • vacation
  • vbetool - needed by pm-utils
  • vcdimager - needed by xine-lib
  • vconfig
  • viewglob
  • w3m
  • webalizer
  • wipe - needed by archboot
  • wmii
  • wmix
  • words
  • wput
  • wvstreams - needed by wvdial
  • x2vnc
  • xbill
  • xbl
  • xboard
  • xdialog
  • xdrawchem
  • xemacs
  • xemacs-base
  • xemacs-sumo
  • xf86-input-wacom - up to Jan
  • xfsdump
  • xmahjongg
  • xorg-xvidtune - up to Jan
  • xosd - needed by tpd (orphan)
  • xpdf
  • xpdf-*
  • xplc - needed by wvstreams
  • xpyb
  • xqf
  • xskat
  • xtermcontrol
  • xzgv
  • yasm - needed by a lot of packages
  • yodl
  • zip - needed by a lot of packages
  • zvbi - needed by vlc

Candidate to [community]

  • abuse - (cryptocrack)
  • agg - needed by desmume-*, gnash (PirateJonno)
  • alltray - (sergej)
  • antiword - needed by pinot, lesspipe, recoll (cryptocrack)
  • arch - (cryptocrack)
  • bomberclone - (cryptocrack)
  • cdcd - needed by gnormalize
  • cddb_get - needed by gnormalize, hacburn
  • centerim - (sergej)
  • chntpw - (cryptocrack)
  • devil - needed by cegui, spring
  • dia - (sergej) [Atsutane]
  • ding - (stefanhusmann)
  • distcc - (sergej)
  • dmenu - needed by uzbl, musca, surf (sergej) i3-wm [Atsutane]
  • dopewars - (schuay)
  • elinks - (sergej)
  • enigma - (schuay)
  • epdfview - (schuay)
  • fftw2 - (cryptocrack)
  • gdk-pixbuf - needed by lazarus, xchat-systray-integration
  • gocr - needed by ogmrip
  • httptunnel - (cryptocrack)
  • libnids - needed by dsniff
  • librep - needed by rep-gtk (stefanhusmann)
  • libvisual-projectm - (cryptocrack)
  • mailman - (sergej)
  • motion - (sergej)
  • ngrep - (cryptocrack) [Bluewind]
  • ntop - (cryptocrack)
  • nvclock - (cryptocrack)
  • patchutils - (sergej)
  • prboom - (cryptocrack)
  • prelink - (cryptocrack)
  • privoxy - (cryptocrack)
  • projectm - (cryptocrack)
  • pyogg - needed by fretsonfire
  • python-cheetah - needed by workrave
  • python-eyed3 - needed by gpodder
  • python-sqlobject - needed by imdbpy
  • pyvorbis - needed by listen
  • qgit - (schuay)
  • quilt - needed by gquilt
  • rep-gtk - needed by sawfish (stefanhusmann)
  • sawfish - (stefanhusmann)
  • silly - needed by cegui
  • slmodem - (sergej)
  • slmodem-utils - (sergej)
  • spidermonkey - needed by gpac, couchdb, mediatomb (PirateJonno)
  • squashfs-tools - (sergej)
  • tor - (cryptocrack)
  • twinkle - (sergej)
  • unarj - (sergej)
  • wmii - (sergej)
  • words - needed by bsd-games (cryptocrack)
  • wput - (sergej)
  • xboard - (sergej)
  • xdialog - (sergej)
  • xemacs - needed by xemacs-base, xemacs-sumo
  • xemacs-base - needed by xemacs-all-packages
  • xemacs-sumo - needed by xemacs-all-packages
  • xosd - needed by ekg2, osdbattery
  • xskat - (stefanhusmann)

Progress

Moved to community

Moved to unsupported

3ddesktop acct acidrip afterstep autofs biogrep biopython blassic bonnie++ bootchart came ccrtp ccscript3 cdlabelgen cdtool colortail commoncpp2 corewars cpudyn cpufreqd crimson cssed culmus dbh dvdbackup eboard ed2k-gtk-gui evms flite galculator gcal gcombust gdeskcal gdesklets gift gift-fasttrack gift-gnutella gift-openft gimp-fourier glabels gmencoder gnomeicu gpart graveman gtick gtk1-engines gtkam gtklp gtk-smooth-engine gtkterm gtk-theme-switch gxine hexcurse hping httrack hugs98 icmake imwheel ipvsadm irda-utils jed joe jpilot lesstifextensions libexif-gtk libixp libmal libmusepack libnjb libsexymm libzrtpcpp lincity linuxdcpp luola moon-buggy moon-lander mp3blaster mrxvt ne netselect pal pan parprouted pebrot pinball planner pure-ftpd python-vpython qof qstat rbldnsd revelation rockdodger root-tail rpmunpack screem seed smtpprox spamassassin-spamc swatch sylpheed synergy tcdr tcptraceroute tcsh thttpd tin tpb transset ttf-isabella ubuntulooks uml_utilities vacation vconfig viewglob webalizer wmix x2vnc xbl xdrawchem xfsdump xpyb xqf xtermcontrol xzgv yodl

Issues