Difference between revisions of "DeveloperWiki:Systemd"

From ArchWiki
Jump to: navigation, search
(TODO list)
Line 15: Line 15:
 
** util-linux 2.22 has the needed sulogin, but is only a release candidate as of now
 
** util-linux 2.22 has the needed sulogin, but is only a release candidate as of now
 
** Only sysvcompat and sysvinit should conflict, allowing initscripts and sysvcompat to be installed at the same time
 
** Only sysvcompat and sysvinit should conflict, allowing initscripts and sysvcompat to be installed at the same time
 +
** Remove sysvinit and initscripts from 'base', add systemd and sysvcompat

Revision as of 17:21, 15 August 2012

This page is for planning.

TODO list

  • Update our servers
  • Update arch-install-scripts and installation medias
  • Update devtools
  • Reorganize systemd and sysvinit packages:
    • Merge systemd back to a single package (aside from sysvcompat)
    • Split off some of the tools from sysvinit (pidof, last, ...)
    • util-linux 2.22 has the needed sulogin, but is only a release candidate as of now
    • Only sysvcompat and sysvinit should conflict, allowing initscripts and sysvcompat to be installed at the same time
    • Remove sysvinit and initscripts from 'base', add systemd and sysvcompat