From ArchWiki
Revision as of 20:47, 7 January 2013 by VCoolio (Talk | contribs) (Gnome Keyring integration)

Jump to: navigation, search

Template:Article summary start Template:Article summary text Template:Article summary text Template:Article summary heading Template:Article summary text Template:Article summary heading Template:Article summary wiki Template:Article summary end

From the Enlightenment wiki:

The Enlightenment desktop shell provides an efficient yet breathtaking window manager based on the Enlightenment Foundation Libraries along with other essential desktop components like a file manager, desktop icons and widgets. It boasts an unprecedented level of theme-ability while still being capable of performing on older hardware or embedded devices.

E17 is the development release 17 (DR17) of the Enlightenment Desktop Environment. It comprises both the Enlightenment window manager and Enlightenment Foundation Libraries (EFL), which provide additional desktop environment features such as a toolkit, object canvas, and abstracted objects. E17 has been under development since 2005, but in February 2011 the core EFLs saw their first stable 1.0 release. Enlightenment the window manager was released December 21st 2012, along with the 1.7.4 release of the EFL libraries. Many people currently use E17 as a day-to-day desktop environment without problems.

Installing E17

From the extra repository

To install e17:

pacman -S enlightenment17

You might also want to install additional Fonts. You need at least 1 True Type Font.

If you need/want an e17 package which is not (yet) available in [extra], see if it is available in the AUR.

From the AUR

SVN PKGBUILDs which download and install the very latest development code are available in the AUR as enlightenment17-svnAUR and it's dependencies. Be aware that they need to be built in a certain order, which is posted in the comments of the relevent PKGBUILDs.

Compiling with easy_e17.sh

Warning: Scripts like easy_e17.sh will not only compile e17, but also the efl libraries (eina, eet, evas etc.). Since the release of these libraries, and e17 itself, it's no longer necessary and even discouraged to build from svn. Large changes are taking place in the svn source (all libraries are being merged into one library called efl), so building scripts will need to be actively maintained and will still be broken from time to time. "Unless you're developing E or willing to live bleeding edje, stay away from trunk."(source)

easy_e17.sh compiles E17 from source and installs it in /opt/e17. It does not create packages and therefore does not install dependencies automatically.

  1. Get it from the AUR: easy-e17AUR.
  2. Edit /etc/easy_e17.conf if you want.
  3. Run it as user, so it downloads to ~/e17_src and builds as user, to install E17 (the script will immediately ask for your password so it can install in the end):
    # easy_e17.sh -i
    Warning: This will install the latest svn version. For a stable result add the --srcrev= parameter with the latest stable revision. The EFL 1.7.4 release matches svn revision 81558 (21 Dec. 2012).
  4. Put /opt/e17/bin in your PATH by editing /etc/profile. For example, you can add this line at the end of the file:
  5. If, after completing the install, xinitrc complains that it cannot find enlightenment upon starting, you may need to add these lines to the end of /etc/profile as well:

If you encounter any errors while trying to install E17, first check to make sure it is not a dependency problem. If it is, install the dependency and continue installing e17.

To update all installed EFL/E17 components, run this command:

# easy_e17.sh -u

Starting E17


If you use startx or a simple Display Manager like XDM or SLiM, add or uncomment the following command in xinitrc:

exec enlightenment_start


Nowadays E17 has a new display manager called Entrance, you can download it from AUR entrance-svnAUR. Entrance is quite sophisticated and its configuration is controlled by /etc/entrance.conf. To use Entrance :

# systemctl enable entrance.service


More advanced display managers like GDM and KDM will automatically detect E17 thanks to the /usr/share/xsessions/enlightenment.desktop file provided by the enlightenment17 package.

Configuring the Network


E17's preferred network manager is ConnMan. It is available from the [community] repository as the connman package. For extended configuration with E17's default Network module, you may also install EConnman (available in AUR as econnman-svnAUR) and it's associated dependencies.

Finally, configure systemd to start the ConnMan daemon at startup:

systemctl enable connman.service

ConnMan loads very quickly and appears to handle DHCP quite nicely. If you have installed Wpa_supplicant, ConnMan latches onto that shows all available wireless connections.


You can also use networkmanager to manage your network connections.

pacman -S networkmanager

Follow the instructions on NetworkManager to do the configuration. You may also need network-manager-applet to help with your settings.

pacman -S network-manager-applet

You may want to add it to the start up programs so every time your E17 starts it appears on systray.

Settings -> Settings Panel -> Apps -> Startup Applications -> System -> Network

Installing Themes

More themes to customize the look of e17 are available from:

You can install the themes (coming in .edj format) from the configuration dialog or by moving them to ~/.e/e/themes.

Note: During 2010 there was a change in how themes work, so older themes will not work unless they were updated. There used to be an edje_convert tool to do this, but that has been dropped long ago (see: trac.enlightenment.org)

Modules and Gadgets

Name used in enlightenment to refer to the "backing" code for a gadget.
Front-end or user interface that should help the end users of E17 do something.

Many Modules provide Gadgets that can be added to your desktop or on a shelf. Some Modules (such as CPUFreq) only provide a single Gadget while others (such as Composite) provide additional features without any gadgets. Note that certain gadgets such as Systray can only be added to a shelf while others such as Moon can only be loaded on the desktop.


E17 offers two modules for compositing, Composite and Ecomorph, depending on your hardware and preference.


The Composite module is the standard compositing manager provided in enlightenment. It provides some minimal compositing effects such as transparency, fade and shadow. Composite provides the more stable module and is supported on most hardware through either OpenGL or compositing software rendering. When the configuration is messed up and the settings windows can no longer be approached, configuration for the comp module can be reset by the hardcoded keybinding Ctrl + Alt + Shift + Home. See also the comp-scale module.


The Ecomorph module is a full-featured compositing manager which was ported from Compiz for E17. It can be downloaded from AUR ecomorph-gitAUR. Some experience instability with Ecomorph while others use it without a problem. Ecomorph requires 3D acceleration, while Composite does not. Development of ecomorph has been discontinued in favor of the official composite module, although some maintainance and bug fixing may still be done (source).


From the current source code README for Places:

Places module
This module manage the volumes device attached to the system.

In other words, Places is a gadget that will help you browse files on various devices you might plug into your computer, like phones, cameras, or other various storage devices you might plug into the usb port.

Note: This module is no longer required for auto-mounting external devices in e17

Scale Windows

The Scale Windows module, which requires compositing to be enabled, adds several features. The scale windows effect shrinks all open windows and brings them all into view. The scale pager effect zooms out and shows all desktops as a wall, like the compiz expo plugin. Both can be added to the desktop as a gadget or bound to a key binding, mouse binding or screen edge binding.

Some people like to change the standard window selection key binding ALT + Tab to use Scale Windows to select windows. To change this setting, you navigate to Menu > Settings > Settings Panel > Input > Keys. From here, you can set any key binding you would like.

To replace the window selection key binding functionality with Scale Windows, scroll through the left panel until you find the "ALT" section and then find and select ALT + Tab. Then, scroll through the right panel looking for the "Scale Windows" section and choose either Select Next or Select Next (All) depending on whether you would like to see windows from only the current desktop or from all desktops and click "Apply" to save the binding.

Note: This module is no longer part of the modules in [extra]. If you want to use it you should install it from the AUR comp-scale-svnAUR

Gnome Keyring integration

It is possible to use gnome-keyring in e17. However at the time of writing you need a small hack to make it work in full. First you must tell e17 to autostart gnome-kering. For that you should go to Settings Panel > Apps > Startup Applications and activate "Certificate and Key Storage", "GPG Password Agent", "SSH Key Agent" and "Secret Storage Service". After this you should edit your ~/.profile and add the following:

if [ -n "$GNOME_KEYRING_PID" ]; then
    eval $(gnome-keyring-daemon --start)
    export SSH_AUTH_SOCK
    export GPG_AGENT_INFO

This should export the variables you need for your key management at your next login.


If you find some unexpected behavior, there are a few things you can do:

  1. try to see if the same behavior exists with the default theme
  2. backup ~/.e and remove it (e.g. mv ~/.e ~/.e.back).

If you are sure you found a bug please report it directly upstream. http://trac.enlightenment.org/e/report

Screen unlocking does not work

If screenlock does not accept your password add the following to /etc/pam.d/enlightenment:

auth required pam_unix_auth.so

Unreadable fonts

If fonts are too small and your screen is unreadable, be sure the right font packages are installed:

pacman -S ttf-dejavu ttf-bitstream-vera

Failure in mounting internal partitions

Check if user is in storage group:

# groups <user>

If user is not in storage group:

# groupadd storage 
# gpasswd -a <user> storage

Then create this file as root:

# nano /etc/polkit-1/localauthority/50-local.d/10-storage-group-mount-override.pkla

And write into the file:

[storage group mount override]

For more information, see: http://bbs.archbang.org/viewtopic.php?id=2720

External Links