Difference between revisions of "Exaile (Italiano)"

From ArchWiki
Jump to: navigation, search
(update interlanguage links (https://github.com/lahwaacz/wiki-scripts/blob/master/update-interlanguage-links.py))
 
(2 intermediate revisions by one other user not shown)
Line 2: Line 2:
 
[[en:Exaile]]
 
[[en:Exaile]]
 
[[es:Exaile]]
 
[[es:Exaile]]
 +
[[ja:Exaile]]
 
[[ru:Exaile]]
 
[[ru:Exaile]]
 
=Introduzione=
 
=Introduzione=
Line 14: Line 15:
 
=Installazione=
 
=Installazione=
  
Exaile è disponibile nel repository [[Official Repositories|community]] di Archlinux. Per abilitare il repository community, è necessario decommentare in {{ic|/etc/pacman.conf}}:
+
Exaile è disponibile nel repository [[Official repositories|community]] di Archlinux. Per abilitare il repository community, è necessario decommentare in {{ic|/etc/pacman.conf}}:
  
 
  [community]
 
  [community]
Line 31: Line 32:
  
 
=Abilitare cover, testi e tabulati per chitarra=
 
=Abilitare cover, testi e tabulati per chitarra=
Mentre l'installazione di Exaile provvederà alla configurazione di tutti i pacchetti necessari alla corretta esecuzione, due pacchetti addizionali ([http://www.archlinux.org/packages/search/?q=gnome-python-extras gnome-python-extras] e [http://www.archlinux.org/packages/search/?q=libgtkhtml libgtkhtml]) devono essere installati separatamente, per attivare cover, testi, tabulati per chitarra e le informazioni da Wikipedia.
+
Mentre l'installazione di Exaile provvederà alla configurazione di tutti i pacchetti necessari alla corretta esecuzione, due pacchetti addizionali ([https://www.archlinux.org/packages/search/?q=gnome-python-extras gnome-python-extras] e [https://www.archlinux.org/packages/search/?q=libgtkhtml libgtkhtml]) devono essere installati separatamente, per attivare cover, testi, tabulati per chitarra e le informazioni da Wikipedia.
  
 
  # pacman -S gnome-python-extras libgtkhtml
 
  # pacman -S gnome-python-extras libgtkhtml

Latest revision as of 19:49, 24 August 2015

Introduzione

Exaile è un riproduttore musicale scritto in python che sfrutta le librerie GTK+. Exaile è rilasciato sotto licenza GPL. Le caratteristiche principali includono:

  • Recupero di cover per album, testi, informazioni sulla traccia e l'artista (via Wikipedia), e tabulati per chitarra (via fretplay.com)
  • Playlist in schede
  • Supporto iPod
  • Support Last.fm
  • Navigazione nelle cartelle SHOUTcast
  • Esclusione tracce

Installazione

Exaile è disponibile nel repository community di Archlinux. Per abilitare il repository community, è necessario decommentare in /etc/pacman.conf:

[community]
# Add your preferred servers here, they will be used first
 Include = /etc/pacman.d/community

Exaile può essere installato tramite Pacman:

# pacman -S exaile

Se si utilizza ALSA e si vuole usare alsasink come dispositivo di riproduzione, installare anche gstreamer0.10-base-plugins:

# pacman -S gstreamer0.10-base-plugins

Ciò potrebbe risolvere il problema se nessun suono viene riprodotto dopo l'installazione o quando si provano a riprodurre molti flussi audio contemporaneamente.

Abilitare cover, testi e tabulati per chitarra

Mentre l'installazione di Exaile provvederà alla configurazione di tutti i pacchetti necessari alla corretta esecuzione, due pacchetti addizionali (gnome-python-extras e libgtkhtml) devono essere installati separatamente, per attivare cover, testi, tabulati per chitarra e le informazioni da Wikipedia.

# pacman -S gnome-python-extras libgtkhtml

Riproduzione di CD audio

Exaile richiede 'python-cddb' per riprodurre CD audio. Il pacchetto da installare (da AUR) è cddb-py.

Risoluzione dei problemi

La barra temporale si blocca a 0:00

Prima di tutto, assicurarsi che non ci siano problemi con l'architettura audio utilizzata (ALSA, OSS, ecc...) e che l'opzione playback sink in Exaile sia impostata correttamente. Provare ad impostarla su Automatica.

Se si sta ascoltando un file MP3, provare a riprodurre un formato differente, come un file .ogg o .flac. Se questi vengono riprodotti correttamente, è necessario installare gstreamer-ugly.

# pacman -S gstreamer0.10-ugly gstreamer0.10-ugly-plugins