Difference between revisions of "GStreamer"

From ArchWiki
Jump to: navigation, search
(use new package templates, see Help:Style)
(Integration: Add gstreamer-properties)
Line 12: Line 12:
  
 
== Integration ==
 
== Integration ==
GStreamer should already support [[PulseAudio]] for all applications since '''{{Ic|gstreamer-pulse}}''' is now a part of {{Pkg|gstreamer0.10-good-plugins}}.
+
GStreamer should already support [[PulseAudio]] for all applications since {{Ic|gstreamer-pulse}} is now a part of {{Pkg|gstreamer0.10-good-plugins}}.
  
 
To avoid lots of dependencies, you may choose to install {{AUR|gstreamer0.10-good-plugins-slim}} from the [[AUR]] instead.
 
To avoid lots of dependencies, you may choose to install {{AUR|gstreamer0.10-good-plugins-slim}} from the [[AUR]] instead.
  
If you use [[KDE]] (and thus, {{Pkg|phonon}}), you can easily install the GStreamer backend: {{Pkg|phonon-gstreamer}}.
+
If you use [[KDE]] (and thus, {{Pkg|phonon}}), you can easily install the GStreamer backend: {{Pkg|phonon-gstreamer}}.  After installation, be sure gstreamer is the first engine on the list under ''SystemSettings --> Multimedia --> Backend''.
  
After installation, be sure gstreamer is the first engine on the list under ''SystemSettings --> Multimedia --> Backend''.
+
Lightweight desktop users: to configure GStreamer, for example to change the audio output device, use {{ic|gstreamer-properties}} from package {{Pkg|gnome-media}}.  This can be run by each user or as root for all users.  Per-user configuration files are under {{Ic|$HOME/.gconf/system/gstreamer}} and the global files are in {{Ic|/etc/gconf/gconf.xml.defaults}}.
  
 
== Bugs ==
 
== Bugs ==

Revision as of 11:26, 11 March 2012

This template has only maintenance purposes. For linking to local translations please use interlanguage links, see Help:i18n#Interlanguage links.


Local languages: Català – Dansk – English – Español – Esperanto – Hrvatski – Indonesia – Italiano – Lietuviškai – Magyar – Nederlands – Norsk Bokmål – Polski – Português – Slovenský – Česky – Ελληνικά – Български – Русский – Српски – Українська – עברית – العربية – ไทย – 日本語 – 正體中文 – 简体中文 – 한국어


External languages (all articles in these languages should be moved to the external wiki): Deutsch – Français – Română – Suomi – Svenska – Tiếng Việt – Türkçe – فارسی

GStreamer is a pipeline-based multimedia framework written in the C programming language with the type system based on GObject.

GStreamer allows a programmer to create a variety of media-handling components, including simple audio playback, audio and video playback, recording, streaming and editing. The pipeline design serves as a base to create many types of multimedia applications such as video editors, streaming media broadcasters, and media players.

Designed to be cross-platform, it is known to work on Linux (x86, PowerPC and ARM), Solaris (Intel and SPARC), Mac OS X, Microsoft Windows and OS/400. GStreamer has bindings for programming-languages like Python, C++, Perl, GNU Guile (guile), and Ruby. GStreamer is free software, licensed under the GNU Lesser General Public License.

Installation

Install the gstreamer0.10-base package from the official repositories.

Integration

GStreamer should already support PulseAudio for all applications since gstreamer-pulse is now a part of gstreamer0.10-good-plugins.

To avoid lots of dependencies, you may choose to install gstreamer0.10-good-plugins-slimAUR from the AUR instead.

If you use KDE (and thus, phonon), you can easily install the GStreamer backend: phonon-gstreamer. After installation, be sure gstreamer is the first engine on the list under SystemSettings --> Multimedia --> Backend.

Lightweight desktop users: to configure GStreamer, for example to change the audio output device, use gstreamer-properties from package gnome-media. This can be run by each user or as root for all users. Per-user configuration files are under $HOME/.gconf/system/gstreamer and the global files are in /etc/gconf/gconf.xml.defaults.

Bugs

In case of error GStreamer-CRITICAL **: gst_mini_object_unref: assertion `mini_object->refcount > 0' failed which usually occurs when recording video through recording software, install gstreamer0.10-ffmpeg to fix.

Links