Difference between revisions of "Gambas"

From ArchWiki
Jump to: navigation, search
(Tips and Tricks, Gambas examples)
m
Line 11: Line 11:
 
There are currently two versions of Gambas: Gambas 3 and the older Gambas 2.
 
There are currently two versions of Gambas: Gambas 3 and the older Gambas 2.
  
{{Note|Gambas consists of a run-time and IDE broken up into several distinct components. Not all of them may be needed for what you wish to do with the IDE or for running a specific Gambas application.}}
+
{{Note|Gambas consists of a runtime and IDE broken up into several distinct components. Not all of them may be needed for what you wish to do with the IDE or for running a specific Gambas application.}}
  
 
===Gambas 3===
 
===Gambas 3===
Line 27: Line 27:
 
Gambas 3 can build installation packages for various distributions and has support for building Arch packages, perfect for use with the [[AUR]].  
 
Gambas 3 can build installation packages for various distributions and has support for building Arch packages, perfect for use with the [[AUR]].  
  
Gambas supports both the [[GTK+]] and [[QT]] tool-kits and can make use of both, allowing the application to fit seamlessly into most [[Desktop Environment]]s. This also applies to applications made inside the Gambas IDE, assuming the gb3-gui component is used.
+
Gambas supports both the [[GTK+]] and [[QT]] toolkits and can make use of both, allowing the application to fit seamlessly into most [[Desktop Environment]]s. This also applies to applications made inside the Gambas IDE, assuming the gb3-gui component is used.
  
 
== External Links ==
 
== External Links ==

Revision as of 19:27, 5 April 2013


Summary help replacing me
This article explains how to install Gambas

Gambas is an object-oriented dialect of the BASIC programming language as well as the integrated development environment that accompanies it.

Installation

There are currently two versions of Gambas: Gambas 3 and the older Gambas 2.

Note: Gambas consists of a runtime and IDE broken up into several distinct components. Not all of them may be needed for what you wish to do with the IDE or for running a specific Gambas application.

Gambas 3

Gambas 3 is the latest version of the language, and is distinct from earlier versions of Gambas although most projects can be converted and ran on the latest version.

To install the latest version of Gambas 3, install the gambas3 package from the official repositories. Development versions can be grabbed by installing the gambas3-svnAUR package from the AUR.

Gambas 2

To install the latest version of Gambas 2, install the python2 package from the official repositories.

Gambas 2 will happily run alongside Gambas 3.

Tips and tricks

Gambas 3 can build installation packages for various distributions and has support for building Arch packages, perfect for use with the AUR.

Gambas supports both the GTK+ and QT toolkits and can make use of both, allowing the application to fit seamlessly into most Desktop Environments. This also applies to applications made inside the Gambas IDE, assuming the gb3-gui component is used.

External Links