From ArchWiki
Jump to: navigation, search

Tango-inaccurate.pngThe factual accuracy of this article or section is disputed.Tango-inaccurate.png

Reason: Is it necessary to install all packages from the gambas3 group? (Discuss in Talk:Gambas#)

Gambas is an object-oriented dialect of the BASIC programming language as well as the integrated development environment that accompanies it.


Note: Gambas consists of a runtime and IDE further broken up into several distinct components. Not all of them may be needed for what you wish to do with the IDE or for running a specific Gambas application.

To install the latest stable version of Gambas 3, install the gambas3 package from the official repositories.

Tips and tricks

Gambas 3 can build installation packages for various distributions and has support for building Arch packages, perfect for use with the AUR.

Gambas supports both the GTK+ and Qt toolkits and can make use of both, allowing the application to fit seamlessly into most Desktop environments. This also applies to applications made inside the Gambas IDE, assuming the gb3-gui component is used.

External Links