HP Pavilion dv6179ea

From ArchWiki
Revision as of 18:48, 22 February 2007 by Schutzstaffel (Talk | contribs) (Quickplay buttons)

Jump to: navigation, search

Tango-document-new.pngThis article is a stub.Tango-document-new.png

Notes: please use the first argument of the template to provide more detailed indications. (Discuss in Talk:HP Pavilion dv6179ea#)

Work in progress, this might take a while - by Grimn

I'm still configuring Arch (version 0.8) on this laptop but I've managed to set up a few things.

Arch Installation

I used the FTP method to install Arch and thus I thought it wouldn't make much difference if I used 0.7.2 ISO, but guess what? It doesn't work well!

Might be because of the kernel (2.6.16) since this laptop is really picky when it comes to kernel version (as I'll explain later), everything seems to be working alright until you start formating the partitions you want, then it takes ages to just write a few blocks on the disk!

So I strongly advise for everyone with these model (and this might be true with all the dv6000t series as well) to use, at least, the 0.8beta1 ISO instead.

Apart from this detail, the installation went pretty smoothly.


If you use kernel older than 2.6.20 you'll need to use noacpi or acpi=noirq parameters to boot.


There isn't much to say, just follow the Touchpad_Synaptics entry.


Section 2.1 of SpeedStep entry has pretty much what you need but notice, as it's said in section 1 on the same entry, that since you're using kernel >= 2.6.20 the speedstep_centrino module is redundant so just load acpi_cpufreq instead.

Also I advise the use of "conservative" governor because it saves battery since it will always stay on the lowest frequency supported until the cpu use justifies an increase in it's frequency (it's a dual core cpu so believe me, you won't need to have it always on max :)).

The values of min and max frequency should be:

# valid freq suffixes: Hz, kHz (default), MHz, GHz, THz


This is an issue I'm still trying to work out.

The sound works fine but if a headphone is plugged in the sound of the speakers still plays so it plays on both which is pretty dumb.

I've only figured out a workaround, when you need/want to use headphones just mute the speakers volume with alsamixer.


Just follow section 2.1.6 of Wireless entry.


You'll need uvcvideo module, once you have it and it's in use you'll see a /dev/video0 entry in your system.

To test it use luvcview

# luvcview -d /dev/video0 -f yuv

Quickplay buttons

If you use KDE this can be done easily, just go to Control Center -> Regional & Accessibility -> Keyboard Layout and choose Hewlett-Packard Pavillion ZT11xx layout and most of the QuickPlay buttons as well as fn keys will work.

If you don't use KDE or want more information about keybinding just check Gentoo's Wiki entry on [Multimedia Keys], it's really helpful.

Card Reader

Seems to work fine out-of-the-box but KDE doesn't recognize it, so you'll have to mount/umount manually.


sensors-detect detects 3 modules: i2c-i801, eeprom and coretemp but Ksensors only has 2 coretemp entries (concerning the cpus) but no sensors are detected.

Still trying to get it working properly.