IBM ThinkPad T61

From ArchWiki
Revision as of 22:40, 26 December 2007 by Owlcat (Talk | contribs) (Replaced outdated info)

Jump to: navigation, search


SATA and Linux

If there are boot problems, try going from AHCI to compatibility in the BIOS. I don't really know what is going on here, but my computer works in compatibility, I haven't tried AHCI.

Wireless

Intel 4965 WiFi

If you have the Intel 4965 NIC, simply install iwlwifi-4965-ucode, run depmod, and run "modprobe wil4965" to activate. For wpa_supplicant, use the WEXT driver, not the deprecated ipw200.

The latest Kismet runs without issue on the iwl4965.

Xorg

Widescreen

Hwd did not do the monitor widescreen (1280x800) properly, and it was instead doing 1024x768. In xorg.conf, here is the relevant section:

Section "Screen"
       Identifier "Screen0"
       Device     "Card0"
       Monitor    "Monitor0"
       DefaultColorDepth 24
       SubSection "Display"
               Depth     24
               Modes "1280x800"
       EndSubSection
EndSection

For the framebuffer in /boot/grub/menu.lst, I just used vga=773 and it doesn't look too bad. It freaks out with the vga=871 or whatever number you need for widescreen.

The Nvidia driver has it's own way of doing resolution, but I didn't find any conflict between the xorg setting and nvidia setting, so it really doesn't matter. I think the nvidia trumps the xorg.conf, though.

Synaptic

Works great with the settings provided in the Pacman output

Graphics

Nvidia

Driver works great, even with composite enabled.

Tweaks

When I have time

Intel

Don't have it, so cannot say.

xf86-video-intel from testing should support the Intel video. I haven't tried it yet, but I'll report back when I do.

Power Management

ACPI

Install acpi, acpid. Add acpi to the daemons list. Load module thinkpad_acpi. You might have to blacklist asus_acpi/toshiba_acpi, it doesn't hurt anyway. It should work.

SpeedStep

The regular way works fine.

Thinkvantage Rescue and Recovery(not tested)

http://www.klabs.be/~fpiat/linux/boot/ThinkVantage_Rescue-and-recovery/

To save time, I believe all the T61 hidden partitions are /dev/sda1. I haven't really tried any of this.

It is /dev/sda2 on my T61

Sound

The module is snd-hda-intel. It works alright. The mute button works automatically but not the volume ones. We'll see about that.