Inkscape

From ArchWiki
Revision as of 19:31, 13 April 2009 by Whoops (Talk | contribs) (Created page with '{{stub}} = Inkscape = == Help for non-gnomes == Inkscape has quite a few gnome dependencies, that can be annoying to users of other Environments - there is a nognome-versio...')

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Tango-document-new.pngThis article is a stub.Tango-document-new.png

Notes: please use the first argument of the template to provide more detailed indications. (Discuss in Talk:Inkscape#)

Inkscape

Help for non-gnomes

Inkscape has quite a few gnome dependencies, that can be annoying to users of other Environments - there is a nognome-version available on AUR.

yaourt -S inkscape-nognome


Build error with libpng 1.2.x

If inkscape fails to build with the following error:

In file included from /usr/include/libpng12/png.h:474,
from sp-image.cpp:44:
/usr/include/libpng12/pngconf.h:328: error: expected constructor, destructor, or type conversion before '.' token
/usr/include/libpng12/pngconf.h:329: error: '__dont__' does not name a type

You should be able to solve that by simply commenting the two mentioned Lines in /usr/include/libpng12/pngconf.h out:

//__pngconf.h__ already includes setjmp.h;
//__dont__ include it again.;

(this seems also to be Debian Bug#522477 and might get fixed in libpng 1.4 - someone correct me! )