Difference between revisions of "Kile and TeX Live"

From ArchWiki
Jump to: navigation, search
(http -> https://aur.archlinux.org)
(kile in extra supports KDE4)
(2 intermediate revisions by one other user not shown)
Line 1: Line 1:
[[Category:TeX (English)]]
+
[[Category:TeX]]
{{i18n|Kile and TeX Live}}
+
 
+
 
This article summarizes how to install the Kile LaTeX editor with TeXLive instead of TeTeX (which is no longer maintained). For additional information about how to install TeXLive on Arch Linux, visit the [[Texlive|TeXLive]] article.
 
This article summarizes how to install the Kile LaTeX editor with TeXLive instead of TeTeX (which is no longer maintained). For additional information about how to install TeXLive on Arch Linux, visit the [[Texlive|TeXLive]] article.
  
Line 26: Line 24:
  
 
Enjoy Kile and TeXLive.
 
Enjoy Kile and TeXLive.
 
===Kile-svn===
 
 
Please note that Kile is also available in the [[AUR]] for it's svn version for KDE4. Get the [https://aur.archlinux.org/packages.php?ID=18353 PKGBUILD] from the [[AUR]].
 
  
 
==Troubleshooting==
 
==Troubleshooting==

Revision as of 13:25, 3 October 2012

This article summarizes how to install the Kile LaTeX editor with TeXLive instead of TeTeX (which is no longer maintained). For additional information about how to install TeXLive on Arch Linux, visit the TeXLive article.

Step 1: Install TeXLive

The best way to start is installing the texlive-most package.

# pacman -S texlive-most

Make sure you have enabled the community archives (in /etc/pacman.conf). If you encounter errors during the installation complaining that commands could not be found, try running:

$ export PATH=$PATH:/opt/texlive/bin

before installing.

Step 2: Install Okular

Simply type:

# pacman -S kdegraphics-okular 

Note that okular can read .pdf as well as .dvi so there should not be the need for any other tools.

Step 3: Install Kile

Finally you have to install Kile.

# pacman -S kile

Start Kile from your menu and check whether all dependencies are solved using "Settings > Systemcheck". Kile will ask you for the Acrobat Reader (the pacman package is called acroread), but that is optional.

Note that if you installed Kile before installing the required packages (like kdvi), you can still install them and have a fully working Kile install.

Enjoy Kile and TeXLive.

Troubleshooting

pdfTeX warnings

If you get warnings such as:

pdfTeX warning: pdflatex [...] fontmap entry for [...] already exists, duplicates ignored

try to remove the map files pcr8y.map, phv8y.map, ptm8y.map from the updmap.cfg and finally run updmap.