Difference between revisions of "Kile and TeX Live"

From ArchWiki
Jump to: navigation, search
(Details about kile-svn, kpdf now obsolete remplaced by Okular.)
m (Kile-svn)
Line 26: Line 26:
 
===Kile-svn===
 
===Kile-svn===
  
Please note that Kile is also available in the [[AUR]] for it's svn version for KDE4. Get it typing
+
Please note that Kile is also available in the [[AUR]] for it's svn version for KDE4, type:
 
  # yaourt -S kile-svn
 
  # yaourt -S kile-svn
if yaourt is installed, or get the [http://aur.archlinux.org/packages.php?ID=18353 PKGBUILD] from the [[AUR]]
+
if yaourt is installed, or get the [http://aur.archlinux.org/packages.php?ID=18353 PKGBUILD] from the [[AUR]].
  
 
==Troubleshooting==
 
==Troubleshooting==

Revision as of 14:50, 4 June 2009

Introduction

This article summarizes how to install the Kile LaTeX editor with TeXLive instead of TeTeX (which is no longer maintained). For additional information about how to install TeXLive on Arch Linux, visit the TeXLive article.

Step 1: Install TeXLive

The best way to start is installing the texlive-most package.

# pacman -Sy texlive-most

Make sure you have enabled the community archives (in /etc/pacman.conf). If you encounter errors during the installation complaining that commands could not be found, try running:

$ export PATH=$PATH:/opt/texlive/bin

before installing.

Step 2: Install Okular, KDVI,..

Those packages have been regrouped under a single package named kdegraphics, except for gv, therefore, in order to install them, you have to type:

# pacman -S kdegraphics gv

Step 3: Install Kile

Finally you have to install Kile.

# pacman -S kile

Start Kile from you menu and check whether all dependencies are solved using "Settings > Systemcheck". Kile will ask you for the Acrobat Reader (the pacman package is called acroread) but that is optional.

Note that if you installed Kile before installing the required packages (like kdvi), you can still install them and have a fully working Kile install.

Enjoy Kile and TeXLive.

Kile-svn

Please note that Kile is also available in the AUR for it's svn version for KDE4, type:

# yaourt -S kile-svn

if yaourt is installed, or get the PKGBUILD from the AUR.

Troubleshooting

pdfTeX warnings

If you get warnings such as:

pdfTeX warning: pdflatex [...] fontmap entry for [...] already exists, duplicates ignored

try to remove the map files pcr8y.map, phv8y.map, ptm8y.map from the updmap.cfg and finally run updmap.