Difference between revisions of "MacBook5,1"

From ArchWiki
Jump to: navigation, search
(Anything else?)
(Multi-Touch Trackpad)
Line 9: Line 9:
=Multi-Touch Trackpad=
=Multi-Touch Trackpad=
Works partially with kernel 2.6.30. Broadcom_wl is not compatible with this kernel yet.
Works partially with kernel 2.6.30. (follow MacBook instructions)

Revision as of 03:54, 30 June 2009

This article is to provide information on how to get components of Apple's MacBook5,1 also know as the MacBook Aluminum, or the unibody Macbook, working in Arch.

Discussion of this in in this thread http://bbs.archlinux.org/viewtopic.php?pid=444664


To install, follow the instruction on the MacBook page.

Multi-Touch Trackpad

Works partially with kernel 2.6.30. (follow MacBook instructions)


The Alsa section on Arch wiki covers the sound setup mostly. However to get speaker output working, edit the following file:


And put the following in:

options snd_hda_intel model=mbp3

It appears that alsa fails to correctly detect and setup the soundcard. This is typical behaviour on some older models aswell.

To ensure that the correct modules get loaded by Arch's module autoloading system, "blacklist" the snd_pcspk module:

MODULES=(everything_else !snd_pcsp)

It is necessary to reboot Arch to make these changes useful.

NOTE: "LINE" is speakers and "PCM" and others control speakers.


Install the 'nvidia' package and run 'nvidia-xconfig' as root. Be sure to have dbus and hal installed, and enabled in rc.conf (i.e. DAEMONS=(dbus hal other_stuff)).


Follow the instructions in the Broadcom_BCM4312 article and install the broadcom-wl driver.


Issue: Either I dont know how to do this or it takes more work...

Suspend/power management stuff

Suspend works (tested in GNOME)



Issue: When using it in Cheese, logs spill out "uvcvideo: unknown event type 79." (number changes).


motion sensor: How do I test?

an ambient light sensor: How do i test?

fan sensors: How do I test?

Temperature sensors: Could only get CPU core temps.... Need more!!!

Anything else?

If you have a macbook pro 5,2 you will notice that pommed will give you an error when you run it(something about you are using a MBP 5,2 badboy!). To get this to not be the case you have to edit the pommed.c file and look for MACHINE_MACBOOKPRO (there is many instances) and sooner or later you will see where they have a if statement that says if it is a 5,1 or a 5,5 then run this, so there you should copy and paste 5,5 and replace with yep, you guessed it 5,2. I sent a email to the developers so that they can change that.