Difference between revisions of "Multilib"

From ArchWiki
Jump to navigation Jump to search
(→‎Disabling: ''paclist'' needs {{pkg|pacman-contrib}} package, so change to command where that is not required)
(→‎Enabling: rm unneed parentheses, use hc template)
Line 13: Line 13:
 
== Enabling ==
 
== Enabling ==
  
To use the [[Official repositories#multilib|multilib]] repository, uncomment the {{ic|[multilib]}} section in {{ic|/etc/pacman.conf}} (Please be sure to uncomment both lines):
+
To use the [[Official repositories#multilib|multilib]] repository, uncomment the {{ic|[multilib]}} section in {{ic|/etc/pacman.conf}}. Be sure to uncomment both lines.
  
[multilib]
+
{{hc|1=/etc/pacman.conf|2=
Include = /etc/pacman.d/mirrorlist
+
[multilib]
 +
Include = /etc/pacman.d/mirrorlist}}
  
 
Then [[upgrade]] the system and install the desired multilib packages.
 
Then [[upgrade]] the system and install the desired multilib packages.

Revision as of 19:44, 28 July 2018

The multilib repository is an official repository which allows the user to run and build 32-bit applications on 64-bit installations of Arch Linux.

Directory structure

With the multilib repository enabled, the 32-bit compatible libraries are located under /usr/lib32/.

Enabling

To use the multilib repository, uncomment the [multilib] section in /etc/pacman.conf. Be sure to uncomment both lines.

/etc/pacman.conf
[multilib]
Include = /etc/pacman.d/mirrorlist

Then upgrade the system and install the desired multilib packages.

Tip: Run pacman -Sl multilib to list all packages in the multilib repository. 32-bit library package names begin with lib32-.

Disabling

To revert to a pure 64-bit system:

Execute the following command to remove all packages that were installed from multilib:

# pacman -R $(comm -12 <(pacman -Qq | sort) <(pacman -Slq multilib | sort))

If you have conflicts with gcc-libs reinstall the gcc-libs package and the base-devel group.

Comment out the [multilib] section in /etc/pacman.conf:

#[multilib]
#Include = /etc/pacman.d/mirrorlist

Then upgrade the system.

See also