Difference between revisions of "Oolite"

From ArchWiki
Jump to: navigation, search
(editing gpu-settings.plist as root is no longer necessary)
m (Correct path)
(8 intermediate revisions by 4 users not shown)
Line 1: Line 1:
[[Category:Games and entertainment (English)]]
+
[http://www.oolite.org/ Oolite] is a space trading / sim game based on the well-known Elite game from the 80's.
==Intro==
+
  
Oolite is a space trading / sim game based on the well-known Elite game from the 80's .
+
==Installation==
Oolite has been moved from AUR to Community, use :
+
Oolite used to be in AUR, but has been moved to Community repo, use:
 +
pacman -Syu oolite
  
{{Codeline|pacman -Syu oolite}}
+
==Troubleshooting==
 +
Oolite uses shaders extensively which may not work well with all drivers, especially the gallium OSS drivers.
  
 +
By default Oolite starts with full shaders, if it hangs on the title screen please follow these 3 steps:
  
oolite uses shaders extensively, and this doesn't work well with all drivers, especially the gallium oss drivers.
+
===Testing for shader problem===
 +
Run Oolite from terminal with this command:
 +
LIBGL_ALWAYS_INDIRECT=1 oolite
  
default oolite starts with full shaders, if it hangs on the title screen please follow these 3 steps :
+
If Oolite works, the problem is with the shaders. In case this does not help, you have a different problem. Post about this on the Arch Linux forums or register a bug.
  
==Testing for shader problem==
+
===Verify which setting works===
run oolite from terminal with this command :
+
Open {{ic|~/GNUstep/Defaults/.GNUstepDefaults}} in an editor, scroll down and to the bottom, and look for these lines:
<pre>LIBGL_ALWAYS_INDIRECT=1 oolite</pre>
+
<key>shader-mode</key>
 +
<integer>3</integer>
  
if oolite works, the problem is with the shaders.
+
Try changing the value of this key to 2 and 1 and test if Oolite runs normally (WITHOUT LIBGL_ALWAYS_INDIRECT stuff).
In case this doesn't help, you have a different problem.
+
post about this in the aur comments.
+
  
==Verify which setting works==
+
Note: The lines with shader-mode key are not always present, but it is safe to add them.
open {{Filename|~/GNUstep/Defaults/.GNUstepDefaults}} in an editor
+
scroll down and to te bottom and look for these lines :
+
<key>shader-mode</key>
+
<integer>3</integer>
+
  
try changing the value of this key to 2 and 1 and test if oolite runs normally
+
===Feedback===
(WITHOUT LIBGL_ALWAYS_INDIRECT stuff)
+
For the value of shader-mode that works, please post {{ic|~/.Oolite/Logs/Latest.log}} on the [http://aegidian.org/bb/index.php Oolite forum], along with the highest shader-mode value that works for you.
  
Note : the lines with shader-mode key are not always present, but it's safe to add them.
+
This info will be used to determine the correct default shader setting for Oolite for your card/driver combination. This will then become part of the Oolite graphics configuration data in a later version.
  
==Feedback==
+
===Radeon HD 2xxx and later videocards===
for the value of shader-mode that works, please post  `/.oolite/Logs/Latest.log on
+
Mesa 8.0.2 has no problems i am aware of running oolite with shaders, but Oolite 1.76 still disables shaders for this driver.
[http://aegidian.org/bb/index.php Oolite forum] ,
+
along with the highest shader-mode value that works for you.
+
  
This info will be used to determine the correct default shader setting for oolite for your card/driver combination.
+
If you wish to use shaders:
This will then become part of the oolite graphics configuration data in a later version.
+
  
==Radeon HD 2xxx and later videocards==
+
# Execute {{ic|cp /usr/share/oolite/Resources/Config/gpu-settings.plist ~/.Oolite/AddOns}} as USER
 +
# Edit {{ic|~/.Oolite/AddOns/gpu-settings.plist}} and replace SHADERS_OFF (2 times) with SHADERS_FULL in the section shown below
 +
<pre>
  
The current mesa 7.10.2 uses R600g gallium driver for these cards, unfortunately that driver is not very mature yet.
 
Oolite 1.75.2 disables shaders for this driver.
 
 
The mesa 7.11 git development version however DOES work fine with oolite & shaders.
 
 
If you wish to use shaders :
 
 
- Install [https://aur.archlinux.org/packages.php?ID=47817 mesa-r600g-git]
 
(other mesa-git pacakges in aur didn't work for me)
 
 
- execute {{Codeline|cp /usr/share/oolite.app/Resources/Config/gpu-settings.plist ~/.Oolite/AddOns}}
 
 
- edit {{Filename|~/.Oolite/AddOns/gpu-settings.plist}}
 
 
replace SHADERS_OFF (2 times) with SHADERS_FULL in the section shown below
 
<pre>
 
(copied from version 1.75.2 )
 
  
 
"ATI R600/R700 family (X/Gallium3D)" =
 
"ATI R600/R700 family (X/Gallium3D)" =
Line 76: Line 57:
 
};
 
};
 
</pre>
 
</pre>
 +
 +
[[Category:Gaming]]

Revision as of 14:47, 16 January 2013

Oolite is a space trading / sim game based on the well-known Elite game from the 80's.

Installation

Oolite used to be in AUR, but has been moved to Community repo, use:

pacman -Syu oolite

Troubleshooting

Oolite uses shaders extensively which may not work well with all drivers, especially the gallium OSS drivers.

By default Oolite starts with full shaders, if it hangs on the title screen please follow these 3 steps:

Testing for shader problem

Run Oolite from terminal with this command:

LIBGL_ALWAYS_INDIRECT=1 oolite

If Oolite works, the problem is with the shaders. In case this does not help, you have a different problem. Post about this on the Arch Linux forums or register a bug.

Verify which setting works

Open ~/GNUstep/Defaults/.GNUstepDefaults in an editor, scroll down and to the bottom, and look for these lines:

<key>shader-mode</key>
	<integer>3</integer>

Try changing the value of this key to 2 and 1 and test if Oolite runs normally (WITHOUT LIBGL_ALWAYS_INDIRECT stuff).

Note: The lines with shader-mode key are not always present, but it is safe to add them.

Feedback

For the value of shader-mode that works, please post ~/.Oolite/Logs/Latest.log on the Oolite forum, along with the highest shader-mode value that works for you.

This info will be used to determine the correct default shader setting for Oolite for your card/driver combination. This will then become part of the Oolite graphics configuration data in a later version.

Radeon HD 2xxx and later videocards

Mesa 8.0.2 has no problems i am aware of running oolite with shaders, but Oolite 1.76 still disables shaders for this driver.

If you wish to use shaders:

  1. Execute cp /usr/share/oolite/Resources/Config/gpu-settings.plist ~/.Oolite/AddOns as USER
  2. Edit ~/.Oolite/AddOns/gpu-settings.plist and replace SHADERS_OFF (2 times) with SHADERS_FULL in the section shown below


"ATI R600/R700 family (X/Gallium3D)" =
{
	/*
		We have reports of Oolite hanging when using Gallium3D on AMD R600/R700 family GPUs with
		shaders enabled. As a stopgap, we forcibly disable shaders on affected systems.
		See http://aegidian.org/bb/viewtopic.php?f=9&t=9416
	*/
	
	match =
	{
		vendor = "X\\.Org";
		renderer = "Gallium .*(?:AMD|AT[Ii]) R[A-Za-z]?[67]\\d{2}(?!\\d)";
	};
	maximum_shader_level = "SHADERS_OFF";
	default_shader_level = "SHADERS_OFF";
};