Difference between revisions of "Oolite"

From ArchWiki
Jump to: navigation, search
m (replaced reference to aur comments)
(update Pkg/AUR templates)
(Tag: wiki-scripts)
 
(12 intermediate revisions by 8 users not shown)
Line 1: Line 1:
[[Category:Games and entertainment (English)]]
+
[[Category:Gaming]]
==Intro==
+
[[ja:Oolite]]
 +
[http://www.oolite.org/ Oolite] is a space trading / sim game based on the well-known Elite game from the 80's.
  
Oolite is a space trading / sim game based on the well-known Elite game from the 80's .
+
==Installation==
Oolite has been moved from AUR to Community, use :
 
  
{{Codeline|pacman -Syu oolite}}
+
[[Install]] the {{AUR|oolite}} package.
  
 +
==Troubleshooting==
 +
Oolite uses shaders extensively which may not work well with all drivers, especially the gallium OSS drivers.
  
oolite uses shaders extensively, and this doesn't work well with all drivers, especially the gallium oss drivers.
+
By default Oolite starts with full shaders, if it hangs on the title screen please follow these 3 steps:
  
default oolite starts with full shaders, if it hangs on the title screen please follow these 3 steps :
+
===Testing for shader problem===
 +
Run Oolite from terminal with this command:
 +
LIBGL_ALWAYS_INDIRECT=1 oolite
  
==Testing for shader problem==
+
If Oolite works, the problem is with the shaders. In case this does not help, you have a different problem. Post about this on the Arch Linux forums or register a bug.
run oolite from terminal with this command :
 
<pre>LIBGL_ALWAYS_INDIRECT=1 oolite</pre>
 
  
if oolite works, the problem is with the shaders.
+
===Verify which setting works===
In case this doesn't help, you have a different problem.
+
Open {{ic|~/GNUstep/Defaults/.GNUstepDefaults}} in an editor, scroll down and to the bottom, and look for these lines:
post about this on archlinux forums or register a bug.
+
<key>shader-mode</key>
 +
<integer>3</integer>
  
==Verify which setting works==
+
Try changing the value of this key to 2 and 1 and test if Oolite runs normally (WITHOUT LIBGL_ALWAYS_INDIRECT stuff).
open {{Filename|~/GNUstep/Defaults/.GNUstepDefaults}} in an editor
 
scroll down and to te bottom and look for these lines :
 
<key>shader-mode</key>
 
<integer>3</integer>
 
  
try changing the value of this key to 2 and 1 and test if oolite runs normally
+
Note: The lines with shader-mode key are not always present, but it is safe to add them.
(WITHOUT LIBGL_ALWAYS_INDIRECT stuff)
 
  
Note : the lines with shader-mode key are not always present, but it's safe to add them.
+
===Feedback===
 +
For the value of shader-mode that works, please post {{ic|~/.Oolite/Logs/Latest.log}} on the [http://aegidian.org/bb/index.php Oolite forum], along with the highest shader-mode value that works for you.
  
==Feedback==
+
This info will be used to determine the correct default shader setting for Oolite for your card/driver combination. This will then become part of the Oolite graphics configuration data in a later version.
for the value of shader-mode that works, please post  `/.oolite/Logs/Latest.log on
 
[http://aegidian.org/bb/index.php Oolite forum] ,
 
along with the highest shader-mode value that works for you.
 
  
This info will be used to determine the correct default shader setting for oolite for your card/driver combination.
+
===Radeon HD 2xxx and later videocards===
This will then become part of the oolite graphics configuration data in a later version.
+
{{Out of date|Fixed as of Oolite 1.84}}
 +
Mesa 8.0.2 has no problems i am aware of running oolite with shaders, but Oolite 1.76 still disables shaders for this driver.
  
==Radeon HD 2xxx and later videocards==
+
If you wish to use shaders:
  
The current mesa 7.10.2 uses R600g gallium driver for these cards, unfortunately that driver is not very mature yet.
+
# Execute {{ic|cp /usr/share/oolite/Resources/Config/gpu-settings.plist ~/.Oolite/AddOns}} as USER
Oolite 1.75.2 disables shaders for this driver.
+
# Edit {{ic|~/.Oolite/AddOns/gpu-settings.plist}} and replace SHADERS_OFF (2 times) with SHADERS_FULL in the section shown below
 
+
<pre>
The mesa 7.11 git development version however DOES work fine with oolite & shaders.
 
 
 
If you wish to use shaders :
 
  
- Install [https://aur.archlinux.org/packages.php?ID=47817 mesa-r600g-git]
 
(other mesa-git pacakges in aur didn't work for me)
 
 
- execute {{Codeline|cp /usr/share/oolite.app/Resources/Config/gpu-settings.plist ~/.Oolite/AddOns}}
 
 
- edit {{Filename|~/.Oolite/AddOns/gpu-settings.plist}}
 
 
replace SHADERS_OFF (2 times) with SHADERS_FULL in the section shown below
 
<pre>
 
(copied from version 1.75.2 )
 
  
 
"ATI R600/R700 family (X/Gallium3D)" =
 
"ATI R600/R700 family (X/Gallium3D)" =

Latest revision as of 07:29, 20 January 2018

Oolite is a space trading / sim game based on the well-known Elite game from the 80's.

Installation

Install the ooliteAUR package.

Troubleshooting

Oolite uses shaders extensively which may not work well with all drivers, especially the gallium OSS drivers.

By default Oolite starts with full shaders, if it hangs on the title screen please follow these 3 steps:

Testing for shader problem

Run Oolite from terminal with this command:

LIBGL_ALWAYS_INDIRECT=1 oolite

If Oolite works, the problem is with the shaders. In case this does not help, you have a different problem. Post about this on the Arch Linux forums or register a bug.

Verify which setting works

Open ~/GNUstep/Defaults/.GNUstepDefaults in an editor, scroll down and to the bottom, and look for these lines:

<key>shader-mode</key>
	<integer>3</integer>

Try changing the value of this key to 2 and 1 and test if Oolite runs normally (WITHOUT LIBGL_ALWAYS_INDIRECT stuff).

Note: The lines with shader-mode key are not always present, but it is safe to add them.

Feedback

For the value of shader-mode that works, please post ~/.Oolite/Logs/Latest.log on the Oolite forum, along with the highest shader-mode value that works for you.

This info will be used to determine the correct default shader setting for Oolite for your card/driver combination. This will then become part of the Oolite graphics configuration data in a later version.

Radeon HD 2xxx and later videocards

Tango-view-refresh-red.pngThis article or section is out of date.Tango-view-refresh-red.png

Reason: Fixed as of Oolite 1.84 (Discuss in Talk:Oolite#)

Mesa 8.0.2 has no problems i am aware of running oolite with shaders, but Oolite 1.76 still disables shaders for this driver.

If you wish to use shaders:

  1. Execute cp /usr/share/oolite/Resources/Config/gpu-settings.plist ~/.Oolite/AddOns as USER
  2. Edit ~/.Oolite/AddOns/gpu-settings.plist and replace SHADERS_OFF (2 times) with SHADERS_FULL in the section shown below


"ATI R600/R700 family (X/Gallium3D)" =
{
	/*
		We have reports of Oolite hanging when using Gallium3D on AMD R600/R700 family GPUs with
		shaders enabled. As a stopgap, we forcibly disable shaders on affected systems.
		See http://aegidian.org/bb/viewtopic.php?f=9&t=9416
	*/
	
	match =
	{
		vendor = "X\\.Org";
		renderer = "Gallium .*(?:AMD|AT[Ii]) R[A-Za-z]?[67]\\d{2}(?!\\d)";
	};
	maximum_shader_level = "SHADERS_OFF";
	default_shader_level = "SHADERS_OFF";
};