Oolite

From ArchWiki
Revision as of 15:37, 30 March 2011 by Lone Wolf (Talk | contribs) (Radeon HD 2xxx and later videocards)

Jump to: navigation, search

Oolite is a space trading / sim game based on the well-known Elite game from the 80's .

oolite uses shaders extensively, and this doesn't work well with all drivers, especially the gallium oss drivers.

default oolite starts with full shaders, if it hangs on the title screen please do the following :

1

run oolite from terminal with this command :

# LIBGL_ALWAYS_INDIRECT=1 oolite

if oolite works, the problem is with the shaders. In case this doesn't help, you have a different problem. post about this in the aur comments.

2

open ~/GNUstep/Defaults/.GNUstepDefaults in an editor scroll down and to te bottom and look for these lines : <key>shader-mode</key> <integer>3</integer>

try changing the value of this key to 2 and 1 and test if oolite runs normally (WITHOUT LIBGL_ALWAYS_INDIRECT stuff)

Note : the lines with shader-mode key are not always present, but it's safe to add them.

3

for the value of shader-mode that works, please post `/.oolite/Logs/Latest.log on

along with the highest shader-mode value that works for you.

If you don't feel like becoming a member on oolite forum, you can also mail the info to me. (my email is in the PKGBUILD)

This info will be used to determine the correct default shader setting for oolite for your card/driver combination. This will then become part of the oolite graphics configuration data in a later version.


Radeon HD 2xxx and later videocards

since mesa 7.10.1 archlinux uses R600g gallium driver for these cards, unfortunately that driver is not very mature yet. Oolite crashes on it, unless you disable shaders by setting shader-mode to 1 as described above.

The mesa 7.11 git development version however DOES work with oolite. the packages from the radeon repo, and mesa-full aur package didn't work for me so i created one myself :