From ArchWiki
Jump to: navigation, search

Oolite is a space trading / sim game based on the well-known Elite game from the 80's.


Oolite has been moved from AUR to Community, use:

pacman -Syu oolite


Oolite uses shaders extensively which may not work well with all drivers, especially the gallium OSS drivers.

By default Oolite starts with full shaders, if it hangs on the title screen please follow these 3 steps:

Testing for shader problem

Run Oolite from terminal with this command:


If Oolite works, the problem is with the shaders. In case this does not help, you have a different problem. Post about this on the Arch Linux forums or register a bug.

Verify which setting works

Open Template:Filename in an editor, scroll down and to the bottom, and look for these lines:


Try changing the value of this key to 2 and 1 and test if Oolite runs normally (WITHOUT LIBGL_ALWAYS_INDIRECT stuff).

Note: The lines with shader-mode key are not always present, but it is safe to add them.


For the value of shader-mode that works, please post Template:Filename on the Oolite forum, along with the highest shader-mode value that works for you.

This info will be used to determine the correct default shader setting for Oolite for your card/driver combination. This will then become part of the Oolite graphics configuration data in a later version.

Radeon HD 2xxx and later videocards

The current mesa 7.10.2 uses R600g gallium driver for these cards, unfortunately that driver is not very mature yet. Oolite 1.75.2 disables shaders for this driver.

The mesa 7.11 git development version however DOES work fine with Oolite and shaders.

If you wish to use shaders:

  1. Install mesa-r600g-git (other mesa-git packages in AUR did not work for me)
  2. Execute cp /usr/share/oolite.app/Resources/Config/gpu-settings.plist ~/.Oolite/AddOns
  3. Edit Template:Filename and replace SHADERS_OFF (2 times) with SHADERS_FULL in the section shown below
(copied from version 1.75.2 ) 

"ATI R600/R700 family (X/Gallium3D)" =
		We have reports of Oolite hanging when using Gallium3D on AMD R600/R700 family GPUs with
		shaders enabled. As a stopgap, we forcibly disable shaders on affected systems.
		See http://aegidian.org/bb/viewtopic.php?f=9&t=9416
	match =
		vendor = "X\\.Org";
		renderer = "Gallium .*(?:AMD|AT[Ii]) R[A-Za-z]?[67]\\d{2}(?!\\d)";
	maximum_shader_level = "SHADERS_OFF";
	default_shader_level = "SHADERS_OFF";