Difference between revisions of "Graphical pacman frontends (Italiano)"

From ArchWiki
Jump to: navigation, search
m (Interfacce grafice per Gnome/Gtk2)
m (Interfacce grafice per KDE/Qt)
Line 23: Line 23:
 
'''ATTTENZIONE:''' Questo programma rimuove i pacchetti con l'opzione -d attiva, il che vuol dire che pacman NON controlla le dipendenze per il pacchetto in rimozione. Usare questo programma può compromettere seriamente il sistema.  --[[User:Falcata|Falcata]] 12:35, 29 May 2010 (EDT)
 
'''ATTTENZIONE:''' Questo programma rimuove i pacchetti con l'opzione -d attiva, il che vuol dire che pacman NON controlla le dipendenze per il pacchetto in rimozione. Usare questo programma può compromettere seriamente il sistema.  --[[User:Falcata|Falcata]] 12:35, 29 May 2010 (EDT)
  
= Interfacce grafice per KDE/Qt =
+
= Interfacce grafiche per KDE/Qt =
  
 
===Shaman===
 
===Shaman===

Revision as of 11:32, 27 June 2010

Template:I18n links start Template:I18n entry Template:I18n entry Template:I18n entry Template:I18n entry Template:I18n links end Quella qui riportata è una lista di interfacce grafiche per Pacman, progettate per costituire una versione grafica dello strumento di gestione pacchetti CLI (Command Line Interface) pacman. La lista include software basato su Gtk2, Qt, e una varietà di indicatori per pannelli di sistema. Nessuno di questi software è ufficialmente supportato dal team di Archlinux.

Interfacce grafiche per Gnome/Gtk2

GtkPacman

GtkPacman è un'interfaccia semplice ma potente per il gestore di pacchetti di Archinux. È scritto in python, utilizzando pygtk, ed è rapido e stabile. Con gtkPacman, la gestione del sistema si riduce alla semplice pressione di pochi pulsanti. L'ultimo rilascio di GtkPacman è datato Febbraio 2008.


ATTTENZIONE: Questo programma rimuove i pacchetti con l'opzione -d attiva, il che vuol dire che pacman NON controlla le dipendenze per il pacchetto in rimozione. Usare questo programma può compromettere seriamente il sistema. --Falcata 12:35, 29 May 2010 (EDT)

Interfacce grafiche per KDE/Qt

Shaman

Shaman è una GUI (Graphical User Interface) per la gestione dei pacchetti per Archlinux. È basato su libalpm. Ciò rappresenta un grande vantaggio, dall'integrazione nel sistema alla velocità. Inoltre, le richieste e le ricerche sono più rapide di pacman, il tutto con un alto livello di personalizzazione. Shaman soddisfa tutte le necessità di qualsiasi manager di pacchetti, come:

Installazione/rimozione/aggiornamento dei pacchetti
Ricerca/filtraggio dei pacchetti
Informazioni sui pacchetti
Operazioni di manutenzione del database

Inoltre Shaman supporta la pianificazione di aggiornamenti del database, un RSS-feed reader per i pacchetti di Archlinux e la modifica dei file di configurazione di pacman.


Indicatori per pannelli di sistema

Archup

archup

Archup è una piccola (solo 44 linee di codice) applicazione in C. È sviluppato in modo da essere leggero e minimalista: notifica semplicemente la disponibilità di nuovi aggiornamenti. Archup usa GTk+ e libnotify per mostrare un popup se nuovi aggiornamenti sono disponibili.


Chase

Chase è un demone per KDE4, creato dal progetto Chakra. Chase usa libapm per gestire gli aggiornamenti, è completamente configurabile ed è integrato con Shaman e KDE4.

alunn

Alunn è una semplice applicazione da pannello di sistema per Archlinux. L'applet avverte l'utente ogni qualvolta ci sono pacchetti da aggiornare per pacman o quando ci sono novità sulla homepage di Archlinux. Comandi personalizzabili per aggiornare il sistema o leggere le news possono venire eseguiti con un clic sull'icona di notifica.

pacman-notifier

Scritto in Ruby, usa Gtk. Mostra un'icona nel pannello di sistema e mostra popup (attraverso libnotify) per la notifica di nuovi pacchetti.

pacupdate

Pacupdate è una piccola applicazione che notifica l'utente sugli aggiornamenti disponibili per Archlinux. Se pacupdate trova un aggiornamento per un pacchetto, mostra un popup di notifica nel pannello di sistema.

ZenMan

Indicatore di aggiornamenti per il pannello di sistema, usa GTK/GNOME/zenity/libnotify.



Gestori grafici inattivi