Difference between revisions of "Pantheon"

From ArchWiki
Jump to: navigation, search
Line 26: Line 26:
* {{AUR|dexter-contacts-bzr}}: Contacts manager (does not build)
* {{AUR|dexter-contacts-bzr}}: Contacts manager (does not build)
* {{AUR|eidete-bzr}}: Simple screencaster
* {{AUR|eidete-bzr}}: Simple screencaster
* {{Pkg|elementary-icon-theme}}: elementary icons
* {{AUR|elementary-scan-bzr}}: Simple scan utility
* {{AUR|elementary-scan-bzr}}: Simple scan utility
* {{AUR|egtk-bzr}}: elementary GTK theme
* {{AUR|feedler-bzr}}: RSS feeds reader (does not build)
* {{AUR|feedler-bzr}}: RSS feeds reader (does not build)
* {{AUR|footnote-bzr}}: Note taking app
* {{AUR|footnote-bzr}}: Note taking app

Revision as of 15:10, 21 August 2013

Tango-document-new.pngThis article is a stub.Tango-document-new.png

Notes: As of now Pantheon runs on Arch Linux with a few rough edges. This wiki article intends to support porting Pantheon to Arch. (Discuss in Talk:Pantheon#)
Template:Article summary start

Template:Article summary text Template:Article summary heading Template:Article summary wiki: A DE which is also based on GTK3. Template:Article summary end

Pantheon is the default desktop environment originally created for the elementary OS distribution. It is written from scratch using Vala and the GTK3 toolkit. With regards to usability and appearance, the desktop has some similarities with GNOME Shell and Mac OS X.


Pantheon is split into several packages which are available in the AUR. To get a minimal desktop interface, you may start by installing pantheon-session-bzrAUR. This will pull the following core components:

Additionally, you may install the following packages:

Note: You will also need to install plugs, look for "switchboard-plug-*" in the AUR.

Additional Infos

Github repository

All Pantheon related PKGBUILDs can be found on my GitHub repository: https://github.com/alucryd/aur-alucryd/tree/master/pantheon

You will need to build at least 'bamf' from there because the AUR package is out of date. Some other packages which do not belong to me can be found in the AUR, you should build those packages from the GitHub repo if available as they are packaged differently.

Stable releases

Several of the listed packages have seen stable releases, it is recommended to use them when available, they are available on the GitHub repository and in the AUR.

Packages based on older evolution-data-server

dexter-contacts-bzrAUR, feedler-bzrAUR and maya-calendar-bzrAUR do not build because they are based on evolution-data-server 3.2. Arch Linux provides version 3.8 which uses a different API.

Launching Pantheon

Via a Display Manager

pantheon-session-bzrAUR provides a session entry for display managers such as gdm or lightdm.

Note: Currently, pantheon-session-bzrAUR uses a custom gnome-session with desktop files in /etc/xdg/autostart. This method will not work with the current version of GNOME (this is the same for the GNOME/Openbox session too).

Via .xinitrc

You can also use ~/.xinitrc with slim to launch the Pantheon shell. The following code will successfully launch a Pantheon session:

# ~/.xinitrc
# Executed by startx (run your window manager from here)

if [ -d /etc/X11/xinit/xinitrc.d ]; then
  for f in /etc/X11/xinit/xinitrc.d/*; do
    [ -x "$f" ] && . "$f"
  unset f

gsettings-data-convert &
xdg-user-dirs-gtk-update &
/usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1 &
/usr/lib/gnome-settings-daemon/gnome-settings-daemon &
/usr/lib/gnome-user-share/gnome-user-share &
eval $(gnome-keyring-daemon --start --components=pkcs11,secrets,ssh,gpg)
cerbere &
pantheon-wallpaper &
exec gala

You may add any other program you'd like to start with Pantheon as well.


Configuring Pantheon is done via switchboard-bzrAUR and its plugs, some of which are available in the AUR, but close to none work as intended for the moment. Instead, most pantheon settings can be altered via dconf, they are located in the org.pantheon key. Use dconf-editor for easy editing.

Also, part of the configuration is handled by gnome-control-center via a dedicated plug, which unfortunately does not support GNOME 3.8. Use gnome-control-center itself and gnome-tweak-tool instead.