Difference between revisions of "Talk:ATI"

From ArchWiki
Jump to: navigation, search
(KMS Early)
(29 intermediate revisions by 13 users not shown)
Line 1: Line 1:
== Forking this article for proprietary ==
+
== KMS -- do we have to do anything at all to enable it? ==
Cleaned up some info today and noticed this article is really getting unruly.  I propose that we fork the proprietary portion to its own article, such as "ATI Catalyst".  Considering that the fglrx is now absolutely unsupported by Arch Linux, it would help make this article much less daunting to newcomers.
+
The KMS sections says it's on by default, should we even have to put radeon in MODULES any longer? If not, the intro to that section should probably mention that "you can skip the rest of this section if 'dmesg|grep modesetting' shows 'radeon kernel modesetting enabled'.
 
+
--[[User:Thayer | Thayer]] Mon Jan  4 10:53:18 PST 2010
+
 
+
:I wholly agree.
+
 
+
:-- [[User:Pointone|pointone]] 23:53, 13 February 2010 (EST)
+
 
+
== EXA and Adobe Flash performance ==
+
 
+
I noticed that enabling
+
<pre>Option "AccelMethod" "EXA"</pre>
+
as mentioned under "Performance tuning" lead to significantly worse Flash performance. This was using extra/flashplugin 10.0.22.87-1, aur/firefox-beta 3.5rc2-1 and extra/xf86-video-ati 6.12.2-2. My card (ATI Radeon 9550) uses the RV350 chipset, hence it is a bit dated. 
+
 
+
If this isn't just a local phenomena, perhaps it should be mentioned?
+
 
+
----
+
 
+
I don't know. I disabled EXA, and got even worse Flash performance, according to a flash benchmark test I found at Snails Animation [http://www.snailsanimation.com/benchmark08_play.php]. (flashplugin 10.0.32.18-1.1, firefox 3.5.3-1, xf86-video-ati 6.12.2-2.) Same card and chipset, though.  --[[User:Rataxes|Rataxes]] 16:38, 15 September 2009 (EDT)
+
 
+
== KMS notes ==
+
KMS on r5xx not works with linux 2.6.31.3. only if libdrm, libgl, mesa, xf86-video-ati - all installed from git.
+
 
+
KMS seems to be enabled by default on r5xx with latest packages from arch. Should all those messages about it being unsupported be removed? [[User:TheCycoONE|TheCycoONE]]
+
  
 
=== KMS Early ===
 
=== KMS Early ===
 
I don't know how others feel about this, but my preferred setup is to put <tt>options radeon modeset=1</tt> in <tt>modprobe.conf</tt> and then to include <tt>modprobe.con</tt> along with the <tt>radeon</tt> module in <tt>mkinitcpio.conf</tt>. This way KMS is enabled once for both early and late start. Also, in the event of problems, <tt>radeon.modeset=1</tt> can still be added as a kernel option to the bootloader. --[[User:piezoelectric|piezoelectric]]
 
I don't know how others feel about this, but my preferred setup is to put <tt>options radeon modeset=1</tt> in <tt>modprobe.conf</tt> and then to include <tt>modprobe.con</tt> along with the <tt>radeon</tt> module in <tt>mkinitcpio.conf</tt>. This way KMS is enabled once for both early and late start. Also, in the event of problems, <tt>radeon.modeset=1</tt> can still be added as a kernel option to the bootloader. --[[User:piezoelectric|piezoelectric]]
  
== mesa PKGBUILD ==
+
== Enabling video acceleration ==
Added a note in the KMS setup section about where to locate libgl and ati-dri in the ABS. Hope it helps.  I was banging my head on that one for a week.   [[User:Wriggary|Wriggary]] 20:04, 29 January 2010 (EST)
+
 
 +
<tt>~/.bashrc</tt> is the wrong place for setting this environment variables. This file is not consulted when starting i.e. firefox from the gnome shell. As it is a hardware dependent setting that is reasonable for every user on this box, i created a file in /etc/profile.d/ to accomplish this.  
  
== Driver ati or radeon ==
+
Setting this variables makes a difference when using flashplayer for youtube videos. When set, flashplayer reports accelerated rendering enabled at home with my ati hd3200 onboard graphics and rendering is faster in full screen mode.
  
I just did the tutorial installing:
+
It works now no more worse than under windows.
pacman -S xf86-video-ati libgl ati-dri
+
I could only get it working by changing in xorg.conf:
+
Driver "vesa"
+
to:
+
Driver "ati"
+
and not:
+
Driver "radeon"
+
as the tutorial stated. I have no idea why/how, but maybe it'll help people reading it here.
+

Revision as of 14:43, 26 November 2012

KMS -- do we have to do anything at all to enable it?

The KMS sections says it's on by default, should we even have to put radeon in MODULES any longer? If not, the intro to that section should probably mention that "you can skip the rest of this section if 'dmesg|grep modesetting' shows 'radeon kernel modesetting enabled'.

KMS Early

I don't know how others feel about this, but my preferred setup is to put options radeon modeset=1 in modprobe.conf and then to include modprobe.con along with the radeon module in mkinitcpio.conf. This way KMS is enabled once for both early and late start. Also, in the event of problems, radeon.modeset=1 can still be added as a kernel option to the bootloader. --piezoelectric

Enabling video acceleration

~/.bashrc is the wrong place for setting this environment variables. This file is not consulted when starting i.e. firefox from the gnome shell. As it is a hardware dependent setting that is reasonable for every user on this box, i created a file in /etc/profile.d/ to accomplish this.

Setting this variables makes a difference when using flashplayer for youtube videos. When set, flashplayer reports accelerated rendering enabled at home with my ati hd3200 onboard graphics and rendering is faster in full screen mode.

It works now no more worse than under windows.