Talk:ATI

From ArchWiki
Revision as of 12:54, 19 May 2012 by Kynikos (Talk | contribs) (On ATI X1600 (RV530 series) glxgears or any other 3D application or game show black windows: suggestion)

Jump to: navigation, search

KMS -- do we have to do anything at all to enable it?

The KMS sections says it's on by default, should we even have to put radeon in MODULES any longer? If not, the intro to that section should probably mention that "you can skip the rest of this section if 'dmesg|grep modesetting' shows 'radeon kernel modesetting enabled'.

KMS Early

I don't know how others feel about this, but my preferred setup is to put options radeon modeset=1 in modprobe.conf and then to include modprobe.con along with the radeon module in mkinitcpio.conf. This way KMS is enabled once for both early and late start. Also, in the event of problems, radeon.modeset=1 can still be added as a kernel option to the bootloader. --piezoelectric

required virtual size does not fit available size ...

I was getting this error when trying to setup two screens with different resolutions using 'gnome-display-properties' (which in turn uses xrandr) : required virtual size does not fit available size: requested=(3200, 1080), minimum=(320, 200), maximum=(1920, 1920)

Removing 'nomodeset' from my kernel parameters fixed it. Removing the 'nomodeset' paramter should be discussed somewhere. I don't know enough about what it actually does to do so intelligently. --Gdw2 13:52, 21 March 2011 (EDT)

nomodeset disables KMS, and you shouldn't be using it anymore. It's not there by default, so you probably read about adding it somewhere on the wiki (you could add a warning to there). thestinger 00:18, 22 March 2011 (EDT)

On ATI X1600 (RV530 series) glxgears or any other 3D application or game show black windows

There are three possible solutions:

Try editing /boot/grub/menu.lst and add pci=nomsi at the end of your kernel line.

Also if this doesn't work, you can try adding noapic instead of pci=nomsi.

If none of the above work, then you can try running vblank_mode=0 glxgears or vblank_mode=1 glxgears to see which one works for you, then install driconf via pacman and set that option in ~/.drirc.

What about moving this section to ATI#Troubleshooting? -- Kynikos (talk) 12:54, 19 May 2012 (UTC)