Difference between revisions of "Talk:Arch User Repository"

From ArchWiki
Jump to: navigation, search
(Request, tar.gz instructions: new section)
(Using fakeroot part of article editing: new section)
Line 8: Line 8:
  
 
to http://wiki.archlinux.org/index.php/AUR_User_Guidelines#Submitting_Packages_to_UNSUPPORTED ? In the age of aunpack, who cares about tar commands? :| Make it easier for people who are sane enough to write PKGBUILD files but too sane to remember legacy compression commands (7z anyone?)--[[User:Qubodup|Qubodup]] 18:25, 26 October 2009 (EDT)
 
to http://wiki.archlinux.org/index.php/AUR_User_Guidelines#Submitting_Packages_to_UNSUPPORTED ? In the age of aunpack, who cares about tar commands? :| Make it easier for people who are sane enough to write PKGBUILD files but too sane to remember legacy compression commands (7z anyone?)--[[User:Qubodup|Qubodup]] 18:25, 26 October 2009 (EDT)
 +
 +
== Using fakeroot part of article editing ==
 +
 +
It says "By default export USE_FAKEROOT="y" is included in /etc/makepkg.conf, so unless you have switched it off it is already enabled." Newer Arch systems are using BUILDENV directive and user should set ! right before the fakeroot to disable it or delete ! before fakeroot to enable it.

Revision as of 18:14, 3 November 2009

move to AUR (English)
Gog 00:51, 19 October 2009 (EDT)

Request, tar.gz instructions

Would you please add

tar cfvz PKG.tar.gz PKG/

to http://wiki.archlinux.org/index.php/AUR_User_Guidelines#Submitting_Packages_to_UNSUPPORTED ? In the age of aunpack, who cares about tar commands? :| Make it easier for people who are sane enough to write PKGBUILD files but too sane to remember legacy compression commands (7z anyone?)--Qubodup 18:25, 26 October 2009 (EDT)

Using fakeroot part of article editing

It says "By default export USE_FAKEROOT="y" is included in /etc/makepkg.conf, so unless you have switched it off it is already enabled." Newer Arch systems are using BUILDENV directive and user should set ! right before the fakeroot to disable it or delete ! before fakeroot to enable it.