Talk:Arduino

From ArchWiki
Revision as of 11:48, 21 April 2013 by Miche (Talk | contribs) (Arduino Due: new section)

Jump to: navigation, search

I merged the 64-bit version of the page here. I left an accuracy tag on the installation section because I don't know if manually loading the modules is required for 32-bit, or even at all. A quick little 'On x86_64, load these modules:' would be fine if that's the case thestinger 17:22, 16 June 2011 (EDT)

Update troubleshooting?

I've recently installed the current arduino-git package and have found that the delay() function is now smoothly functioning without any workarounds. I'm not sure if anybody else can confirm this, but it seems that the problem may have been fixed. If this is true, then I suggest updating the troubleshooting and bugs sections. --Dannickfox 17:34, 18 April 2012 (EDT)

scons uploading does not work

scons upload gives

avrdude: stk500_recv(): programmer is not responding

arduino-cmake worked, I tried to copy the avrdude line from cmake to scons, but it wouldn't work for some reason. I'm using arduino uno v3, arduino 1:1.0-3 from AUR. --Ichernev (talk) 22:38, 5 May 2012 (UTC)

Arduino Due

The new Arduino Due won't work with the old IDE (1.0.4) but needs the 1.5beta version. They have separated git branches so even installing the arduino-git package won't be enough. I think right now the best way is to download the linux 1.5 archive from [1] Miche (talk) 11:48, 21 April 2013 (UTC)