Talk:Bluetile

From ArchWiki
Revision as of 09:02, 30 June 2010 by Fukawi2 (Talk | contribs) (Created page with 'I'm getting this at the moment... This whole Haskell/cabal thing is annoying. Conventions and Standards anyone? ~~~~ fukawi2@phil-desktop /home/fukawi2 $ cabal install bluetile…')

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

I'm getting this at the moment... This whole Haskell/cabal thing is annoying. Conventions and Standards anyone? Fukawi2 05:02, 30 June 2010 (EDT)

fukawi2@phil-desktop /home/fukawi2  $ cabal install bluetile
Resolving dependencies...
Configuring X11-1.5.0.0...
configure: WARNING: unrecognized options: --with-compiler
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables... 
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking how to run the C preprocessor... gcc -E
checking for X... libraries , headers 
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking whether to build Xinerama... yes
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking X11/extensions/Xinerama.h usability... yes
checking X11/extensions/Xinerama.h presence... yes
checking for X11/extensions/Xinerama.h... yes
checking whether to include X.org keysyms... yes
checking X11/keysym.h usability... yes
checking X11/keysym.h presence... yes
checking for X11/keysym.h... yes
checking X11/DECkeysym.h usability... yes
checking X11/DECkeysym.h presence... yes
checking for X11/DECkeysym.h... yes
checking X11/Sunkeysym.h usability... yes
checking X11/Sunkeysym.h presence... yes
checking for X11/Sunkeysym.h... yes
checking X11/ap_keysym.h usability... yes
checking X11/ap_keysym.h presence... yes
checking for X11/ap_keysym.h... yes
checking X11/HPkeysym.h usability... yes
checking X11/HPkeysym.h presence... yes
checking for X11/HPkeysym.h... yes
checking X11/XF86keysym.h usability... yes
checking X11/XF86keysym.h presence... yes
checking for X11/XF86keysym.h... yes
checking X11/keysymdef.h usability... yes
checking X11/keysymdef.h presence... yes
checking for X11/keysymdef.h... yes
checking X11/cursorfont.h usability... yes
checking X11/cursorfont.h presence... yes
checking for X11/cursorfont.h... yes
configure: creating ./config.status
config.status: creating config.mk
config.status: creating X11.buildinfo
config.status: creating include/HsX11Config.h
config.status: creating include/X11_extras_config.h
configure: WARNING: unrecognized options: --with-compiler
Preprocessing library X11-1.5.0.0...
collect2: ld terminated with signal 11 [Segmentation fault]
linking dist/build/Graphics/X11/Xlib/Extras_hsc_make.o failed
command was: /usr/bin/gcc -lXinerama -lXext -lX11 -L/usr/lib/ghc-6.12.1/syb-0.1.0.2 -Wl,-R,/usr/lib/ghc-6.12.1/syb-0.1.0.2   L/usr/lib/ghc-6.12.1/base-4.2.0.0 -Wl,-R,/usr/lib/ghc-6.12.1/base-4.2.0.0 -L/usr/lib/ghc-6.12.1/integer-gmp-0.2.0.0 -Wl,-R,/usr/lib/ghc  6.12.1/integer-gmp-0.2.0.0 -lgmp -L/usr/lib/ghc-6.12.1/ghc-prim-0.2.0.0 -Wl,-R,/usr/lib/ghc-6.12.1/ghc-prim-0.2.0.0 -L/usr/lib/ghc- 6.12.1 -Wl,-R,/usr/lib/ghc-6.12.1 -lm -lrt -ldl -L/usr/lib/ghc-6.12.1 -Wl,-R,/usr/lib/ghc-6.12.1 dist/build/Graphics/X11/Xlib/Extras_hsc_make.o -o dist/build/Graphics/X11/Xlib/Extras_hsc_make
cabal: Error: some packages failed to install:
X11-1.5.0.0 failed during the building phase. The exception was:
ExitFailure 1
X11-xft-0.3 depends on X11-1.5.0.0 which failed to install.
bluetile-0.4.3 depends on X11-1.5.0.0 which failed to install.
xmonad-0.9.1 depends on X11-1.5.0.0 which failed to install.
xmonad-contrib-0.9.1 depends on X11-1.5.0.0 which failed to install.