Difference between revisions of "Talk:Broadcom wireless"

From ArchWiki
Jump to: navigation, search
(new brcm80211 driver: Remove closed discussion.)
(9 intermediate revisions by 7 users not shown)
Line 1: Line 1:
What about regdom setting? I'm in EU, but iwlist only sees 11 channels...
+
== b44 not load ==
Tried crda, but it says:
+
$ /etc/rc.d/wireless-regdom start
+
:: Setting wireless regulatory domain:HU                      [BUSY]
+
command failed: Operation not supported (-95)                [FAIL]
+
 
+
----
+
The section 'Troubleshooting' is more or less a copy of what is mentioned on the udev-page. IMHO we should not copy, but link to that page. In this prticular case there is more information on the udev-page, so the instructions on this page might be out of date...
+
 
+
 
+
 
+
 
+
----
+
 
I have the same configuration mentioned in the instructions. Dell Inspiron with BCM4401 and BCM4328 cards.
 
I have the same configuration mentioned in the instructions. Dell Inspiron with BCM4401 and BCM4328 cards.
  
Line 19: Line 7:
  
 
Is there something else that could cause a conflict between multiple Broadcom modules?
 
Is there something else that could cause a conflict between multiple Broadcom modules?
----
+
 
any thoughts on where the new [http://linuxwireless.org/en/users/Drivers/brcm80211 brcm80211] driver fits in, and howto use it with arch linux?
+
== Device not showing up ==
:: I have an update here, I have [http://linuxwireless.org/en/users/Drivers/brcm80211 brcm80211] working with my 14e4:4353 "Broadcom Corporation Device 4353 (rev 01)" wireless adapter in my [https://wiki.archlinux.org/index.php?title=Alienware_M11 alienware M11x], using arch + [http://aur.archlinux.org/packages.php?ID=41472 compat-wireless-patched]. --[[User:Fnord0|Fnord0]] 13:32, 29 November 2010 (EST)
+
Hi, I'm new to editing wiki sites. So I don't really know if there's a convention about how people are going to interact when editing others pages. I added a sentence under the section "Device not showing up" that for me it worked only if i removed the exclamation mark before lib80211. I guess I should have posted something here first. I'm sorry if I have violated the process in anyway and you are free to remove it. But I leave it there so that you can decide if it fits in the page or not. Sorry for any trouble this might have caused.
cfg80211: Calling CRDA to update world regulatory domain
+
<br>-- [[User:Mabac|Mabac]] ([[User_talk:Mabac|talk]]) 15 December 2010
cfg80211: World regulatory domain updated:
+
 
cfg80211:    (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
+
== broadcom-wl work well ==
cfg80211:    (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
+
I'm running a new dv7-7000 with a Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01). I could not get this to work with the kernel drivers. The signal was so weak it wouldn't obtain an IP address from DHCP, even right next to the APUsing broadcom-wl did the trick and things are working great.--[[User:Skarphace|Skarphace]] ([[User talk:Skarphace|talk]]) 05:16, 21 July 2012 (UTC)
cfg80211:    (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
+
cfg80211:    (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
+
cfg80211:    (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
+
cfg80211:    (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
+
brcm80211 0000:08:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
+
brcm80211 0000:08:00.0: setting latency timer to 64
+
  wlc_bmac_attach:: deviceid 0x4353 nbands 2 board 0xe macaddr: c4:17:xx:xx:xx:xx
+
ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
+
wl_set_hint: Sending country code US to MAC80211
+
wl0: Broadcom BCM43xx 802.11 MAC80211 Driver (1.82.8.0) (Compiled at 15:30:26 on Nov 27 2010)
+
cfg80211: Calling CRDA for country: US
+
cfg80211: Regulatory domain changed to country: US
+
cfg80211:    (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
+
cfg80211:    (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
+
cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
+
cfg80211:     (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
+
cfg80211:     (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
+
cfg80211:    (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
+
cfg80211:    (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
+

Revision as of 08:04, 6 February 2013

b44 not load

I have the same configuration mentioned in the instructions. Dell Inspiron with BCM4401 and BCM4328 cards.

I still can not get these two cards to work together.

I have configured my machine just like the method stated but my ethernet card (b44) will not load.

Is there something else that could cause a conflict between multiple Broadcom modules?

Device not showing up

Hi, I'm new to editing wiki sites. So I don't really know if there's a convention about how people are going to interact when editing others pages. I added a sentence under the section "Device not showing up" that for me it worked only if i removed the exclamation mark before lib80211. I guess I should have posted something here first. I'm sorry if I have violated the process in anyway and you are free to remove it. But I leave it there so that you can decide if it fits in the page or not. Sorry for any trouble this might have caused.
-- Mabac (talk) 15 December 2010

broadcom-wl work well

I'm running a new dv7-7000 with a Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01). I could not get this to work with the kernel drivers. The signal was so weak it wouldn't obtain an IP address from DHCP, even right next to the AP. Using broadcom-wl did the trick and things are working great.--Skarphace (talk) 05:16, 21 July 2012 (UTC)