Difference between revisions of "Talk:Browser plugins"

From ArchWiki
Jump to: navigation, search
(Adobe Flash Player: Hardware acceleration: re)
m (updated info about google-chrome-stable)
 
(36 intermediate revisions by 8 users not shown)
Line 1: Line 1:
== plugin location ==
+
== Opera 33 - no support for PPAPI ==
  
firefox (3.6.13) on arch 64 bit does look at /usr/lib/mozilla/plugins
+
I am not sure that description of that Opera 33 supports PPAPI is correct in head of the article. -- Andy Crowd - [[wikipedia:蔡依林|蔡依林]] 18:50, 8 November 2015 (UTC)
  
instead of
+
:This was implemented over a year ago: [http://blogs.opera.com/desktop/2014/06/opera-developer-23-pepper-flash-coming-opera/]. What makes you think otherwise? -- [[User:Alad|Alad]] ([[User talk:Alad|talk]]) 18:55, 8 November 2015 (UTC)
  
~/mozilla/plugins/ or
+
:: Do you use Opera? I got problem after update to version 33, cannot play flash video, error that flash is not available. -- Andy Crowd - [[wikipedia:蔡依林|蔡依林]] 19:10, 8 November 2015 (UTC)
~/.mozilla/plugins/
+
  
at least for libnpjp2.so I need to link to the correct /usr/lib/mozilla/plugins for it to work
+
::: Yes, but I haven't upgraded from v32 yet. I'd suggest you to file a bug. -- [[User:Alad|Alad]] ([[User talk:Alad|talk]]) 19:16, 8 November 2015 (UTC)
  
== Blue Tint Flash problem reloaded ==
+
:::: Ok. Then just wait for a few more updates to opera and see if it will be the same "BUG". -- Andy Crowd - [[wikipedia:蔡依林|蔡依林]] 19:26, 8 November 2015 (UTC)
  
To solve the blue tint problem I had to right-click a flash element already running and set (in "preferences") off the hw acceleration, otherwise I had blue tint regardless the libvdpau workaround.
+
::::: SOLVED - my pepper flash update stuck on version 17 but no errors about flash version was on adobe website, now everything works after I updated it to the latest. May be add this type of bug:
 +
::::: {{Note|If flash videos doesn't work in opera then pepper flash must be updated to the newest version. <br>You can compare in "about:plugins" with listed on [http://www.adobe.com/software/flash/about/ adobe website].}}
 +
::::: 20:39, 14 November 2015‎ Andy Crowd
  
Should this be added to the wiki?
+
:::::: Wouldn't you see the same in Chromium though, when the browser is updated but the plugin is not? The cause/symptom relation isn't too clear in the suggested note. -- [[User:Alad|Alad]] ([[User talk:Alad|talk]]) 21:01, 14 November 2015 (UTC)
  
== Adobe Flash Player: Hardware acceleration ==
+
::::::: google-chrome-stable uses only: /opt/google/chrome/PepperFlash/libpepflashplayer.so (if path to file doesn't exist then it still shows plugin in the list but flash videos cannot be loaded)
 
+
::::::: Opera uses: /usr/lib/PepperFlash/libpepflashplayer.so if path/file doesn't exist it using /usr/lib/chromium/PepperFlash/libpepflashplayer.so next it looking for /opt/google/chrome/PepperFlash/libpepflashplayer.so
The Article states ''For hardware acceleration on Intel/AMD, you can use {{AUR|libvdpau-va-gl}} — VAAPI backend for VDPAU. For AMD you should also install {{AUR|xvba-video}}''.
+
::::::: Chromium uses only: /usr/lib/PepperFlash/libpepflashplayer.so if path/file doesn't exist then no plugin is listed/used.
Can someone clarify that? It's totally unclear to me, which ATI/AMD drivers are meant. I assume, I need xvba-video when I use the catalyst/fglrx driver. What about libvdpau-va-gl? Do I need this when using the open-source radeon-driver? Do I need this if you use catalyst? Or do I need this anyway? [[User:Holzhaus|Holzhaus]] ([[User talk:Holzhaus|talk]]) 21:33, 25 October 2013 (UTC)
+
::::::: The "manifest.json" file contains flash player version. Chromium/Chrome has no problems with old version but Opera not allowing to use older versions of it and shows no errors, flash videos just didn't play even on adobe website.
 
+
::::::: Andy Crowd - [[wikipedia:蔡依林|蔡依林]] 17:27, 16 November 2015 (UTC)
:See [[VA-API]], I wonder why it isn't linked from this page... -- [[User:Lahwaacz|Lahwaacz]] ([[User talk:Lahwaacz|talk]]) 06:48, 26 October 2013 (UTC)
+
 
+
::As I understand that page, {{AUR|libvdpau-va-gl}} and {{AUR|xvba-video}} are unnecessary, no matter what driver you use. I will then remove that part from the article and link the page you suggested. [[User:Holzhaus|Holzhaus]] ([[User talk:Holzhaus|talk]]) 08:58, 27 October 2013 (UTC)
+
 
+
:::Ah, see also [[Talk:VA-API#VDPAU vs VAAPI relationship]] for the {{AUR|libvdpau-va-gl}} and {{AUR|xvba-video}} detail, they are necessary to support VDPAU through VAAPI on Intel cards and AMD cards with proprietary drivers. However, you've correctly linked to [[VDPAU]], FlashPlayer does not use VAAPI. (Sorry for suggesting the [[VA-API]] link, I noticed [[VDPAU]] later...) -- [[User:Lahwaacz|Lahwaacz]] ([[User talk:Lahwaacz|talk]]) 09:19, 27 October 2013 (UTC)
+

Latest revision as of 17:27, 16 November 2015

Opera 33 - no support for PPAPI

I am not sure that description of that Opera 33 supports PPAPI is correct in head of the article. -- Andy Crowd - 蔡依林 18:50, 8 November 2015 (UTC)

This was implemented over a year ago: [1]. What makes you think otherwise? -- Alad (talk) 18:55, 8 November 2015 (UTC)
Do you use Opera? I got problem after update to version 33, cannot play flash video, error that flash is not available. -- Andy Crowd - 蔡依林 19:10, 8 November 2015 (UTC)
Yes, but I haven't upgraded from v32 yet. I'd suggest you to file a bug. -- Alad (talk) 19:16, 8 November 2015 (UTC)
Ok. Then just wait for a few more updates to opera and see if it will be the same "BUG". -- Andy Crowd - 蔡依林 19:26, 8 November 2015 (UTC)
SOLVED - my pepper flash update stuck on version 17 but no errors about flash version was on adobe website, now everything works after I updated it to the latest. May be add this type of bug:
Note: If flash videos doesn't work in opera then pepper flash must be updated to the newest version.
You can compare in "about:plugins" with listed on adobe website.
20:39, 14 November 2015‎ Andy Crowd
Wouldn't you see the same in Chromium though, when the browser is updated but the plugin is not? The cause/symptom relation isn't too clear in the suggested note. -- Alad (talk) 21:01, 14 November 2015 (UTC)
google-chrome-stable uses only: /opt/google/chrome/PepperFlash/libpepflashplayer.so (if path to file doesn't exist then it still shows plugin in the list but flash videos cannot be loaded)
Opera uses: /usr/lib/PepperFlash/libpepflashplayer.so if path/file doesn't exist it using /usr/lib/chromium/PepperFlash/libpepflashplayer.so next it looking for /opt/google/chrome/PepperFlash/libpepflashplayer.so
Chromium uses only: /usr/lib/PepperFlash/libpepflashplayer.so if path/file doesn't exist then no plugin is listed/used.
The "manifest.json" file contains flash player version. Chromium/Chrome has no problems with old version but Opera not allowing to use older versions of it and shows no errors, flash videos just didn't play even on adobe website.
Andy Crowd - 蔡依林 17:27, 16 November 2015 (UTC)