Difference between revisions of "Talk:CUPS"

From ArchWiki
Jump to: navigation, search
(Device node permissions: new section)
m (rm closed discussions)
(11 intermediate revisions by 4 users not shown)
Line 1: Line 1:
 
==Kernel modules==
 
==Kernel modules==
 
+
The whole kernel modules section is confusing. Is it mandatory? What exactly should we do?<br>
The whole Kernel modules section is confusing. Is it mandatory? What exactly should we do?
+
-- [[User:Drozzy|Drozzy]] ([[User_talk:Drozzy|talk]]) 10:37, April 10, 2012
  
 
== Print button greyed-out in GNOME print dialogs ==
 
== Print button greyed-out in GNOME print dialogs ==
  
 
As suggested by the Arch wiki, I used the  
 
As suggested by the Arch wiki, I used the  
# HostNameLookups Double
+
# HostNameLookups Double
 
option. However, that resulted in following error message:  
 
option. However, that resulted in following error message:  
 
IP lookup failed - connection from localhost closed!
 
IP lookup failed - connection from localhost closed!
Line 15: Line 15:
 
http://www.cups.org/str.php?L4070+Qversion:%20-feature
 
http://www.cups.org/str.php?L4070+Qversion:%20-feature
  
Removing the HostNameLookups double form the cups config file resolved my issue. Not sure why this used to solve instead of create problems.
+
Removing the HostNameLookups double form the cups config file resolved my issue. Not sure why this used to solve instead of create problems.<br>
 +
-- [[User:Davidovitch|Davidovitch]] ([[User_talk:Davidovitch|talk]]) 07:24, July 4, 2012‎
  
 
== Device node permissions ==
 
== Device node permissions ==
  
I got a problem after update of hplip / cups and foomatic. My printer not working anymore.
+
I got a problem after update of {{pkg|hplip}} / {{pkg|cups}} and foomatic. My printer not working anymore.
  
 
So I first check possible problems and read section Device node permissions. It's recommended to verify that permissions are 660. It was my case so I am looking to find another solution.
 
So I first check possible problems and read section Device node permissions. It's recommended to verify that permissions are 660. It was my case so I am looking to find another solution.
Line 25: Line 26:
 
After a long time and read I was back to this section. I read also section below Device node permission troubleshooting. As my conf was with well permission I don't really read all carefully. It was the 3rd/4th time before I see the note about 666 permissions. I tried this and it's solved my problem.
 
After a long time and read I was back to this section. I read also section below Device node permission troubleshooting. As my conf was with well permission I don't really read all carefully. It was the 3rd/4th time before I see the note about 666 permissions. I tried this and it's solved my problem.
  
So I think it would be great to make also a note on Device node permissions about 666. Because my conf look allright as writing in wiki, but in fact not.
+
So I think it would be great to make also a note on Device node permissions about 666. Because my conf look alright as writing in wiki, but in fact not.<br>
 +
-- [[User:Ioo|Ioo]] ([[User_talk:Ioo|talk]]) 19:09, July 19, 2012‎

Revision as of 20:58, 16 December 2012

Kernel modules

The whole kernel modules section is confusing. Is it mandatory? What exactly should we do?
-- Drozzy (talk) 10:37, April 10, 2012

Print button greyed-out in GNOME print dialogs

As suggested by the Arch wiki, I used the

# HostNameLookups Double

option. However, that resulted in following error message: IP lookup failed - connection from localhost closed!

and I wasn't able to add printers via the CUPS web interface (internal server error)

It seems there is an outstanding bug with respect to the HostNameLookups: http://www.cups.org/str.php?L4070+Qversion:%20-feature

Removing the HostNameLookups double form the cups config file resolved my issue. Not sure why this used to solve instead of create problems.
-- Davidovitch (talk) 07:24, July 4, 2012‎

Device node permissions

I got a problem after update of hplip / cups and foomatic. My printer not working anymore.

So I first check possible problems and read section Device node permissions. It's recommended to verify that permissions are 660. It was my case so I am looking to find another solution.

After a long time and read I was back to this section. I read also section below Device node permission troubleshooting. As my conf was with well permission I don't really read all carefully. It was the 3rd/4th time before I see the note about 666 permissions. I tried this and it's solved my problem.

So I think it would be great to make also a note on Device node permissions about 666. Because my conf look alright as writing in wiki, but in fact not.
-- Ioo (talk) 19:09, July 19, 2012‎