Difference between revisions of "Talk:Eclipse"

From ArchWiki
Jump to: navigation, search
(Created page with "= Eclipse crashes with xulrunner 2.x= Hi, just installed latest eclipse. It crashed all the time, so I did a bit research: http://www.eclipse.org/swt/faq.php#browserlinux Eclipse...")
 
(Eclipse crashes with xulrunner 2.x)
Line 1: Line 1:
 
= Eclipse crashes with xulrunner 2.x=
 
= Eclipse crashes with xulrunner 2.x=
 
Hi, just installed latest eclipse. It crashed all the time, so I did a bit research:
 
Hi, just installed latest eclipse. It crashed all the time, so I did a bit research:
 +
 
http://www.eclipse.org/swt/faq.php#browserlinux
 
http://www.eclipse.org/swt/faq.php#browserlinux
Eclipse 3.6.x and newer: Mozilla 1.4 GTK2 - 1.7.x GTK2 and XULRunner 1.8.x - 1.9.2.x, and WebKitGTK+ 1.2.0 and newer
+
Eclipse 3.6.x and newer:
 +
Mozilla 1.4 GTK2 - 1.7.x GTK2
 +
XULRunner 1.8.x - 1.9.2.x
 +
WebKitGTK+ 1.2.0 and newer
  
 
Here the solution:
 
Here the solution:
 
https://bbs.archlinux.org/viewtopic.php?id=115543
 
https://bbs.archlinux.org/viewtopic.php?id=115543
 
+
since gnome3 the webkit library name changed from libwebkit-1.0.so to libwebkitgtk-1.0.so, so I did
since gnome3 the webkit library name changed from libwebkit-1.0.so to libwebkitgtk-1.0.so, so I did
+
# cd /usr/lib
ln -s libwebkitgtk-1.0.so libwebkit-1.0.so.2
+
# ln -s libwebkitgtk-1.0.so libwebkit-1.0.so.2
and
+
and
-Dorg.eclipse.swt.browser.UseWebKitGTK=true
+
-Dorg.eclipse.swt.browser.UseWebKitGTK=true
works again
+
works again
  
 
Can u add this to the wiki? -- [[User:Der harm|Der harm]] 20:16, 6 May 2011 (EDT)
 
Can u add this to the wiki? -- [[User:Der harm|Der harm]] 20:16, 6 May 2011 (EDT)

Revision as of 00:18, 7 May 2011

Eclipse crashes with xulrunner 2.x

Hi, just installed latest eclipse. It crashed all the time, so I did a bit research:

http://www.eclipse.org/swt/faq.php#browserlinux

Eclipse 3.6.x and newer:
Mozilla 1.4 GTK2 - 1.7.x GTK2
XULRunner 1.8.x - 1.9.2.x
WebKitGTK+ 1.2.0 and newer

Here the solution: https://bbs.archlinux.org/viewtopic.php?id=115543

since gnome3 the webkit library name changed from libwebkit-1.0.so to libwebkitgtk-1.0.so, so I did
# cd /usr/lib
# ln -s libwebkitgtk-1.0.so libwebkit-1.0.so.2
and
-Dorg.eclipse.swt.browser.UseWebKitGTK=true
works again

Can u add this to the wiki? -- Der harm 20:16, 6 May 2011 (EDT)